[Suse 11.0] Bład instalacji sterowników - source-path


(patrx95) #1

Witam.

Mam problem z instalacją sterowników nvidii na mój system opensuse 11.0.

Wydaje mi się że już wszystko zrobiłem tzn. wyszedłem z "X'a" zainstalowałem pakiety gcc, make i kernel-source z tym że w ten ostatni pakiet nie jest widziany przez system.

Żeby było jaśniej wkleję kod błędu:

nvidia-installer log file '/var/log/nvidia-installer.log'

creation time: Wed Jun 9 20:08:35 2010

installer version: 1.0.7


option status:

  license pre-accepted : false

  update : false

  force update : false

  expert : false

  uninstall : false

  driver info : false

  precompiled interfaces : true

  no ncurses color : false

  query latest version : false

  OpenGL header files : true

  no questions : false

  silent : false

  no recursion : false

  no backup : false

  kernel module only : false

  sanity : false

  add this kernel : false

  no runlevel check : false

  no network : false

  no ABI note : false

  no RPMs : false

  no kernel module : false

  force SELinux : default

  no X server check : false

  no cc version check : false

  force tls : (not specified)

  X install prefix : (not specified)

  X library install path : (not specified)

  X module install path : (not specified)

  OpenGL install prefix : (not specified)

  OpenGL install libdir : (not specified)

  utility install prefix : (not specified)

  utility install libdir : (not specified)

  doc install prefix : (not specified)

  kernel name : (not specified)

  kernel include path : (not specified)

  kernel source path : (not specified)

  kernel output path : (not specified)

  kernel install path : (not specified)

  proc mount point : /proc

  ui : (not specified)

  tmpdir : /tmp

  ftp mirror : ftp://download.nvidia.com

  RPM file list : (not specified)


Using: nvidia-installer ncurses user interface

-> License accepted.

-> Installing NVIDIA driver version 195.36.24.

-> Performing CC sanity check with CC="cc".

-> Performing CC version check with CC="cc".

ERROR: The kernel header file

       '/lib/modules/2.6.25.5-1.1-default/build/include/linux/kernel.h' does

       not exist. The most likely reason for this is that the kernel source

       path '/lib/modules/2.6.25.5-1.1-default/build' is incorrect. Please

       make sure you have installed the kernel source files for your kernel and

       that they are properly configured; on Red Hat Linux systems, for

       example, be sure you have the 'kernel-source' or 'kernel-devel' RPM

       installed. If you know the correct kernel source files are installed,

       you may specify the kernel source path with the '--kernel-source-path'

       command line option.

ERROR: Installation has failed. Please see the file

       '/var/log/nvidia-installer.log' for details. You may find suggestions

       on fixing installation problems in the README available on the Linux

       driver download page at http://www.nvidia.com.

Z góry dziękuję za pomoc.

Pozdrawiam.


(etam) #2

Możesz powiedzieć coś więcej? Bo chyba właśnie tego ci brakuje.

/lib/modules/2.6.25.5-1.1-default/build/include/linux/kernel.h' does not exist

pokaż wynik “ls /usr/src/”


(BenderBendingRodriguez) #3

W takim razie zainstaluj linux-kernel-headers

Następnym razem proponuję się wczytać w logi. Tam są najczęściej przyczyny niepowodzenia (header file). Zresztą to i tak lepiej niż inni bo podałeś log z instalacji:) Niektórzy czasem chcą wypróbować nasze jasnowidzenie :wink:


(patrx95) #4

kernel-headers mam właśnie zainstalowane, a jeszcze tam pisze coś o zainstalowaniu pakietu kernel-devel, a jego właśnie w yast nie mogę znaleźć - trzeba go koniecznie instalować?

linux linux-2.6.25.20-0.7-obj linux-obj

linux-2.6.25.20-0.7 linux-2.6.25.5-1.1-obj packages

(etam) #5

Hmm… Ciekawe…

A pokaż co zwraca “ls -l /lib/modules/*/build” oraz “uname -r”


(RubasznyRumcajs) #6

Nie żebym się czepiał, ale 30 czerwca kończy się wsparcie dla OpenSUSE11.0 :~ na szczęście nowa wersja ma wyjść 15 lipca :slight_smile:

A tak ad rem- czemu nie instalujesz sobie sterów z repozytorium (Nvidii- domyślnie wyłączone, trza dodać np w yascie)? za nowe/stare?


(BenderBendingRodriguez) #7

RubasznyRumcajs ma rację, przesiądź się na coś “aktualnego” a jeśli planujesz i tak pozostać przy 11.0 stery do NVIDII masz tutaj w postaci “łan klika” :lol:

http://dev.compiz.org/~cyberorg/2008/06 … nsuse-110/


(patrx95) #8

etam ,

ls -l /lib/modules/*/build pokazuje tylko to:

makedumpfile.config Module.symvers

uname-r wskazuje na tą wersję kernel’a:

2.6.25.5-1.1-default

RubasznyRumcajs

ojoj to muszę update wkrótce zrobić, systemu już dobre pół roku nie uruchamiałem ^^ więc do lipca posiedzę na ubuntu 10.04 :slight_smile:

dlaczego?? bo chciałem się nauczyć instalować paczki .run ale no niestety mi coś nie wychodzi :wink:

BenderBendingRodriguez

właśnie teraz zainstalowałem sterowniki do suse’a 1-clickiem, hmm… a teraz jak mogę sprawdzić czy rzeczywiście prawidłowo stery się zainstalowały?


(BenderBendingRodriguez) #9

Sprawdź czy masz moduł nvidia załadowany komendą lsmod | grep nvidia

Jeśli coś się pokaże to oznacza że masz sterowniki załadowane z tym że nie jestem pewien czy w 11.0 nie trzeba przypadkiem zmodyfikowac /etc/X11/xorg.conf i wpisać nvidia zamiast nv.


(Soren) #10

W każdej dystrybucji z xorg.conf driver powinien być ustawiony na nvidia (zamiast otwartego nv)…


(patrx95) #11
patryk@patryk-desktop:~$ lsmod | grep nvidia

nvidia 7825536 34 

agpgart 34760 1 nvidia

i2c_core 24832 2 nvidia,i2c_nforce2

hmm… włączone??


(BenderBendingRodriguez) #12

Wygląda na to że tak, włączone :slight_smile:


(patrx95) #13

ok, dzięki wszystkim za odpowiedzi :wink:

temat-solved; do zamknięcia

pozdrawiam