System nie wykrywa karty graficznej


(Andonezja) #1

Witam,

Od paru dni przy przy próbach uruchamiania programów Adobe wykrzaczył mi jakiś błąd-

a ponieważ ostatnio istotnie zapełnił mi się dysk systemowy, pomyślałam, że to przez brak miejsca na dysku/pamięci, który photoshop sygnalizował mi już jakiś czas temu i wykosiłam z dysku 30 gb. nie wiem czy w trakcie tego usunęłam jakieś ważne dane (nie sądzę, poza własnymi plikami usunęłam chyba tylko zawartość folderu "Temp"), ale sprawa zamiast się poprawić, trochę się pogorszyła. Postanowiłam więc zainstalować nowy sterownik do GeForce'a, instalacja skończyła się niepowodzeniem. wtedy mnie tknęło i weszłam do menadżera urządzeń w celu odinstalowania karty i zainstalowania jej od nowa, a tu zdziwienie -

Przy uruchamianiu systemu po restarcie komputera (stara, skautowska metoda;)) wyskakiwał mi z kolei analogiczny błąd do tego przy uruchamianiu np. Adobe Readera, z tym że dotyczył plików "dinotify.exe" i "pnidui.dll" (ten ostatni wymieniłam na prawidłowy, dostępny w internecie - błąd przestał wyskakiwać, system nadal schrzaniony).

Ogólnie konkluzja jest taka, że nie wiem co konkretnie spowodowało, że system nie rozpoznaje wcześniej zainstalowanych podzasobów komputera, ale bez tego nie jestem w stanie pracować, więc trzeba coś z tym zrobić. Próba uruchomienia panelu NVidii kończy się wywaleniem komunikatu, że karta "NVidia nie została wykryta w systemie". Próbowałam uruchamiać sfc /scannow -> na moim normalnym profilu administratora w ogóle nie reagował (okno pojawiało się na pół sekundy i znikało), w trybie awaryjnym rozpoczął przeprowadzanie tego skanu - ale odeszłam od komputera, a jak wróciłam nie było żadnego śladu, raportu, okno sfc wyłączone.

Mój wniosek po kilkunastu latach pracy na Windowsie jest taki - pojawił się jakiś problem z bibliotekami systemowymi. I teraz dochodzimy do meritum - czy istnieje jakiś sprytny program, który sprawdzi mi stan bibliotek Windowsa i ewentualnie naprawi brakujące? Płytka instalacyjna jest dla mnie bezużyteczna, system normalnie działa, uruchamia się, wszystko teoretycznie chodzi, tylko chodzi tak, jakby nie było karty graficznej, co powoduje szereg kolejnych problemów ze wszystkimi właściwie aplikacjami.

Pewnie wyjaśniłam to tragicznie i skończy się na reinstalce systemu, ale może ktoś, coś?

Oczywiście nie mam punktów przywracania systemu ani kopii zapasowej..


(XMan) #2

Sprawdź:

  1. instalację odpowiednich sterowników do swojej płyty głównej tzw. Chipset.

  2. instalację Windows 7 Service Pack 1.

Wybierz/zainstaluj odpowiednie bit. 32 lub 64.


(Andonezja) #3

instalator crashuje podczas update’u chipsetu (instalator MSI) - załączam crash report, z którego chyba nic nie wynika

http://www.sendspace.com/file/d06jr9

spróbuję z service packiem, ale był on instalowany razem z systemem (zintegrowany na płycie), więc nie wróżę tutaj sukcesu…


(Kwalimir) #4

Z tego loga co podałaś wynika że próbowałaś instalować sterowniki od karty graficznej ATI to i raczej się nie mogło udać.Podaj jaki masz model płyty głównej to zlinkujemy sterownik do “chipsetu”.


(Andonezja) #5

korzystałam z wbudowanego MSI Suite i ichszego programiku Live Update - wygląda to mniej więcej tak:

http://i.imgur.com/FUjbL0H.png?1

załączany wcześniej log dotyczy instalki AMD Chipset Drivers, ale tak czy siak, próbując użyć tegoż genialnego firmowego “total installera” do update’owania/instalowania czy pojedynczych komponentów, czy wszystkich na raz, za każdym razem jest jakiś crash. jakby system bardzo nie chciał pozwolić na zainstalowanie tych sterowników;)

model płyty głównej 760GM-P23 (FX)

http://pl.msi.com/product/mb/760GM-P23–FX-.html


(Kwalimir) #6

Czyli sterowniki dobre instalowałaś.Coś chyba wywaliłaś niepotrzebnie w czasie robienia porządków na dysku.Możesz też sprawdzić dysk na obecność błędów, system sprawdzić czymś w stylu programu SystemMechanic, ewentualnie sprawdzić czy nie ma jakiejś infekcji.Jedno jest pewne coś masz w systemie namieszane i może być trudno ustalić przyczynę.


(Andonezja) #7

przyczyny raczej nie ustalimy, szukam remedium :wink:

sprawdzę ten programik SystemMechanic, najbardziej by się przydał program sprawdzający koherentność wszystkich bibliotek systemowych i nadpisanie brakujących/wadliwych, coś tak jak kiedyś się robiło w starym dobrym XP-ku opcję “naprawiania systemu” z płytki instalacyjnej;) jest takie cudo?

procedura-naprawy-systemu-windows-przez-nadpisanie-t447116.html

co myślicie o tym sposobie? czy to może tutaj coś pomóc? nie ukrywam, najbardziej zależy mi na utrzymaniu wszystkich zainstalowanych programów, mam pilne zlecenie i nie mam za bardzo czasu tracić całego dnia na backup danych, pełen reinstall systemu + instalację całego oprogramowania od nowa…


(Kwalimir) #8

FixWin ma taką funkcje ale o ile się orientuje to to samo co sfc /scannow.Sprawdzić zawsze można, dodatkowo bardzo często pomaga strona Microsoftu z gotowymi fixami do systemu:

http://support.microsoft.com/fixit/


(Andonezja) #9

taaa, przy fixwinie to samo co przy sfc - kolejna ciekawostka

http://i.imgur.com/GsbY2Cs.png

http://i.imgur.com/ZhSrVLf.png

system wyraźnie leży i kwiczy

szczególnie intrygujący jest ten błąd cmd, widział ktoś kiedyś cos podobnego?


(XMan) #10

Najpierw sprawdź:

Dysk C:\PPM (prawym przyciskiem myszki) --> Właściwości --> zakładka Narzędzia --> Sprawdzanie błędów --> Sprawdź:

kliknij aby powiększyć:

gv5_Obraz-1.jpg rf468_Obraz-2.jpg

Zaznacz tak jak jest na screenach – Automatycznie napraw błędy systemu plików – Skanuj dysk i próbuj odzyskać uszkodzone sektory – Rozpocznij.

Reset…

Czekaj aby komputer naprawił problemy - nie przerywaj.

Po tym jeżeli dawno nie wykonywałaś defragmentacji – wykonaj za pomocą systemowego programu lub innego np:

Auslogics Disk Defrag

Defraggler

IObit Smart Defrag


(Kwalimir) #11

Jeżeli to co XMan , napisał nie pomoże daj logi do działu bezpieczeństwo bo może się mylę ale coś mi to na infekcje wygląda.


(Andonezja) #12

scandisk nie wykazał żadnych błędów woluminu, defragmentację mam ustawioną co tydzień, ale na wszelki wypadek robię ponownie - może coś się sknociło przy moim ręcznym clean-upie…

szkoda, że nie jestem w stanie ocenić, czy problem niewczytywania sterowników pojawił się już wcześniej, i go nie zauważyłam, czy dopiero w wyniku moich działań.

@kwalimir

infekcja? hmm skanowałam system anti-malware’m, antivirus też działa, a system mechanic posprawdzał rejestry i uznał mój system za zdrowy.

EDIT: Załączam screena z kolejnym wyskakującym mi błędem, który mnie zainteresował.

“w magazynie brak miejsca dla wykonania tego polecenia”

Spotkaliście się kiedyś z czymś takim?

http://i.imgur.com/3fKFaex.png


(Kwalimir) #13

HM… coś z pamięcią? Sprawdź ile masz wolnej pamięci i czy przypadkiem plik wymiany (pamięć wirtualna) nie jest wyłączony lub za mały.Spróbuj też odinstalować na chwilę antywira bo może coś blokować.Defragmentacja nic Ci nie da poza szybszym dostępem do dysku, problemów z systemem na pewno nie zlikwiduje.


(Andonezja) #14

pamięć jest ok, mam 8 GB pamięci RAM, pliki stronicowania też ustawione ponad zalecanej normy, poddaję się, robię reinstalkę systemu :frowning: dziękuję wszystkim.


(Kwalimir) #15

OK bo to jakiś ciężki przypadek, spróbuj jeszcze może przed reinstalacją zresetować bios i sprawdź czy to pomogło bo nic innego mi nie przychodzi do głowy.