TL-WR740N brak połączenia


(Cerberxes) #1

Witam, wcozraj podłączyłem komputer kablem do wspomnianego w tytule tematu routera, wczoraj również wszystko działało poprawnie.

Dzis natomiast Firefox nie odczytuje stron, ping w cmd nie działa, ale co dziwne działa gg.

To naprowadziło mnie na trop źle skonfigurowanego DHCP/DNS...

Jak sprawdzić czy mam rację? Jak poprawnie to skonfigurować?


(Bor1904) #2

Najprawdopodobniej to wina DNS.

Może najpierw wyjaśnię jak działa DNS w takich domowych sieciach z routerkami na przedzie.

Np przeglądarka internetowa (lub klient ftp, ping itp usługi) dostaje zadanie otworzyć/pobrać coś np. z wp.pl.

Sprawdza czy ma to (strone WWW) w swoim buforze, jak nie ma to trzeba będzie to jednak pobrać.

Odwołuje się do pliku hosts w katalogu windows czy jest tam wpis odnośnie wp.pl (pewnie nie ma) więc pyta dalej.

Czas zapytać o adres IP resolver DNS - usługę w systemie operacyjnym. Resolver sprawdza czy ostatnio nie było już pytania o tą domenę (jeżeli by było to pobrał by dane z buforowanej pamięci) jeżeli nie ma to sprawdza jaki adres IP jest ustawiony we właściwościach TCP/IP komputera, żeby go odpytać. Otrzymuje adres lokalnego serwera DNS (najczęsciej jest to buforujący serwer DNS na routerku) i wysyła do niego zapytanie o adres ip dla wp.pl.

On sprawdza w pamięci czy posiada taki wpis i jak nie posiada to ma adresy głównych serwerów DNS na świecie. Wybiera jeden z nich i pyta się o adres do serwera mającego informacje o pod domenach .pl . Otrzymuje adres gdzie ma się pytać i pyta ten serwer o adres serwera posiadającego informacje o wp.pl. Gdy ma już wreszcie informacje o adresie wp.pl z ostatniego serwera to odsyła ją (routerek) do resolvera na komputerze , a on przekazuje przeglądarce że wp.pl to 212.77.100.101 i ona dopiero wtedy pobiera dane z otrzymanego adresu IP.

Pytanie co gdy jakaś usługa (np gg) nie używa w ogóle nazw domenowych tylko adresy IP ? W takim układzie system DNS mógłby nie istnieć bo nic nie wymaga tłumaczenia - resolver staje się bezrobotny.

Pytanie co w momencie gdy adresu DNS nie ma we właściwościach TCP/IP (bo nie został prawidłowo pobrany z DHCP lub ktoś zapomniał go na sztywno przypisać np 8.8.8.8)? W takim wypadku większość usług złoży zapytanie do resolvera i na tym koniec bo on nie jest jasnowidzem i nie wie gdzie w świecie są jakieś serwery DNS... :frowning:

Jak najszybciej sprawdzić czy problem jest w DNS?

ping wp.pl a po tym ping 212.77.100.101 - i już wszystko wiemy bo ping to też usługa, która wymaga współpracy z resolverem DNS.

Gdy DNS działa, ale kulawo to naturalnie polecenie nslookup.

Na zdrowie!


(Cerberxes) #3

Dziękuję za teorię, jednak nie wiem

1) czy jest sens zmieniać DNS na stałe na te np. od OpenDNS

2) czy to może jednak też wina DHCP (bo po około 24h od ostatniego nadania adresu przez operatora - bo podłączyłem na chwilę komputer do modemu kablowego, żeby sprawdzić czy działa internet - internet przestał działać

3) skoro mam sieć od Toyi to czy powinienem w ustawieniach routera mieć dynamic IP czy static IP?

4) czy może mieć to jakiś związek z pojawieniem się nowego MAC od routera w monitoringu ISP?


(Bor1904) #4
  1. Lepiej mieć swój lokalny (bliżej cache)

2.Czy jest wina DHCP to nikt nie wywróży dopóki nie sprawdzisz co DHCP przyznał

3.Najprawdopodobniej dynamic bo mało kto dla indywidualnego klienta bawi się w statyczne adresy

4.Pojawienie się nowego MAC może troszkę namieszać ale najprawdopodobniej nie jesteś uwierzytelniany przez ISP na podstawie adr fizycznego a co do DHCP to dzierżawa jest pod dany adres MAC właśnie... po teorie odsyłam tu:

http://sieci-komputerowe.net/jak-to-dzi ... ziala-dhcp

pzdr


(Cerberxes) #5

Gdzie to sprawdzić i na które parametry patrzeć?


(Bor1904) #6

na routerze w czymś ala status a w kompie cmd -> ipconfig /all


(Cerberxes) #7

Którą z linijek podać żeby można orzec co jest źle? Nie będę przecież wklejał całości :smiley:


(Bor1904) #8

wklej całość ;]

no nie widzisz cco pisze w sekcji WAN/Internet ?

jakieś IP maska brama dns informacja o stanie połączenia ?


(Cerberxes) #9

IPv4 address 192.168.1.100 (preferred)

subnet mask: 255.255.255.0

default gateway: 192.168.1.1

dhcp server: 192.168.1.1

dns servers: 192.168.1.1

netbios over tcpip: enabled

Są wymienione jeszcze 2 "adaptery": tunnel adapter isatap i teredo tunneling pseudo interface

obydwa mają dhcp enabled: no


(Bor1904) #10

czyli połączenie router komputer jest na 99% ok i problemem jest część router dostawca - potrzebny widok statusu w routerze ;]


(Cerberxes) #11

Internet przestaje działać co równo 24h.

Wejście do panelu kontrolnego routera i wciśnięcie "Release" od razu pomaga.

Mam pytanie jak skonfigurować router, żeby nie trzeba było co 24 h wciskać release/renew.

Zmiana DNS na OpenDNS nic nie zmieniła i tak ok. 21.00 net się wyłączył ;/

-- Dodane 29.01.2011 (So) 21:18 --

Instalacja najnowszego firmware również nie pomogła...

Czemu gg działa, a firefox nie po 24h od ostatniego manualnego release/renew w sterowaniu routerem?

Jakieś sugestie?


(Ceteerel) #12

@Cerberus

Też mam ten problem, choć nie wiem czy dzieje się tak co równe 24h. GG działa, strony w przeglądarce nie. Zmiana DNSów na OpenDNS również nie pomogła. Mam nawet opcję w ruterze Address Lease Time w sekcji DHCP - max 2880 minut, czyli to powinno być 48h. Teraz mam ustawione 1440, ale zmiana na 2880 też nie pomogła. Co więcej też korzystam z routera TP-Link tyle że model WR941N i mieszkam w Łodzi - korzystam z internetu od Toya.

Dlatego nie wiem czy to problem routerów TP-Link, czy coś od firmy Toya - nie wiem, może coś z tym ich modemem.