Ubuntu 6.12 - beryl


(komin15) #1

Witam

Instaluje beryla, ale już na początku po wpisaniu komendy

sudo apt-get install ubuntu-desktop

System krzyczy że błąd

Czytanie list pakietów... Gotowe

Budowanie drzewa zależności       

Reading state information... Gotowe

ubuntu-desktop jest już w najnowszej wersji.

Należy uruchomić `apt-get -f install', aby je naprawić:

Następujące pakiety mają niespełnione zależności:

  nautilus-sendto: Wymaga: gaim (>= 1:2.0) ale nie zostanie zainstalowany

                   Wymaga: gaim (< 1:3.0) ale nie zostanie zainstalowany

  ubuntu-desktop: Wymaga: gaim ale nie zostanie zainstalowany

E: Niespełnione zależności. Spróbuj 'apt-get -f install' bez pakietów (lub podaj rozwiązanie).

Potem daje komendę

sudo apt-get update

w ostatnich linijkach w konsoli pojawia sie

Czytanie list pakietów... Gotowe

W: GPG error: http://wine.budgetdedicated.com edgy Release: Następujące sygnatury nie mogły zostać zweryfikowane z powodu braku klucza publicznego: NO_PUBKEY 58403026387EE263

W: Duplicate sources.list entry http://deb.svx.pl edgy/main Packages (/var/lib/apt/lists/deb.svx.pl_dists_edgy_main_binary-i386_Packages)

W: Duplicate sources.list entry http://deb.svx.pl edgy/universe Packages (/var/lib/apt/lists/deb.svx.pl_dists_edgy_universe_binary-i386_Packages)

W: Należy uruchomić apt-get update aby naprawić te problemy.

następnie komenda

sudo apt-get upgrade

i znowu błąd gaima

Reading state information... Gotowe

Należy uruchomić `apt-get -f install', aby je naprawić.

Następujące pakiety mają niespełnione zależności:

  nautilus-sendto: Wymaga: gaim (>= 1:2.0) ale nie jest zainstalowany

                   Wymaga: gaim (< 1:3.0) ale nie jest zainstalowany

  ubuntu-desktop: Wymaga: gaim ale nie jest zainstalowany

E: Niespełnione zależności. Spróbuj użyć -f.

komenda

sudo apt-get dist-upgrade

i błąd

Reading state information... Gotowe

Należy uruchomić `apt-get -f install', aby je naprawić.

Następujące pakiety mają niespełnione zależności:

  nautilus-sendto: Wymaga: gaim (>= 1:2.0) ale nie jest zainstalowany

                   Wymaga: gaim (< 1:3.0) ale nie jest zainstalowany

  ubuntu-desktop: Wymaga: gaim ale nie jest zainstalowany

E: Niespełnione zależności. Spróbuj użyć -f.

Komenda

gksudo gedit /etc/apt/sources.list

W konsoli napis

(gedit:6652): GnomeUI-WARNING **: While connecting to session manager:

Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed.

otwiera sie gedit dodaje

deb http://ubuntu.beryl-project.org edgy main

zapisuje i dodaje w konsoli klucz

wget http://ubuntu.beryl-project.org/root@lupine.me.uk.gpg -O- | sudo apt-key add -

tutaj bez błędów. komenda

sudo apt-get update

ostatnie linie

Czytanie list pakietów... Gotowe

W: GPG error: http://wine.budgetdedicated.com edgy Release: Następujące sygnatury nie mogły zostać zweryfikowane z powodu braku klucza publicznego: NO_PUBKEY 58403026387EE263

W: Należy uruchomić apt-get update aby naprawić te problemy.

komenda

sudo apt-get install beryl-core beryl-plugins beryl-plugins-data emerald beryl-settings beryl-manager beryl beryl-dev emerald-themes

i błąd

Czytanie list pakietów... Gotowe

Budowanie drzewa zależności       

Reading state information... Gotowe

Należy uruchomić `apt-get -f install', aby je naprawić:

Następujące pakiety mają niespełnione zależności:

  beryl: Wymaga: libberylsettings0 ale nie zostanie zainstalowany

         Wymaga: libberyldecoration0 ale nie zostanie zainstalowany

  beryl-core: Wymaga: libberylsettings0 ale nie zostanie zainstalowany

              Wymaga: libxcomposite1 ale nie zostanie zainstalowany

  beryl-dev: Wymaga: libberylsettings-dev ale nie zostanie zainstalowany

             Wymaga: x11proto-gl-dev ale nie zostanie zainstalowany

             Wymaga: libgl1-mesa-dev ale nie zostanie zainstalowany

             Wymaga: libstartup-notification0-dev ale nie zostanie zainstalowany

             Wymaga: libxcomposite-dev ale nie zostanie zainstalowany

             Wymaga: libxdamage-dev ale nie zostanie zainstalowany

  beryl-plugins: Wymaga: libberyldecoration0 ale nie zostanie zainstalowany

                 Wymaga: libberylsettings0 ale nie zostanie zainstalowany

                 Wymaga: libxcomposite1 ale nie zostanie zainstalowany

                 Wymaga: libberyldecoration0 ale nie zostanie zainstalowany

  beryl-settings: Wymaga: beryl-settings-bindings ale nie zostanie zainstalowany

  emerald: Wymaga: libemeraldengine0 ale nie zostanie zainstalowany

           Wymaga: libberyldecoration0 ale nie zostanie zainstalowany

  nautilus-sendto: Wymaga: gaim (>= 1:2.0) ale nie zostanie zainstalowany

                   Wymaga: gaim (< 1:3.0) ale nie zostanie zainstalowany

  ubuntu-desktop: Wymaga: gaim ale nie zostanie zainstalowany

E: Niespełnione zależności. Spróbuj 'apt-get -f install' bez pakietów (lub podaj rozwiązanie).

Jak zainstalowac, beryla?


(Sawyer47) #2

Wyraźnie jest napisane w logach, po pierwsze zajmij się tym:

Czytanie list pakietów... Gotowe

W: GPG error: http://wine.budgetdedicated.com edgy Release: Następujące sygnatury nie mogły zostać zweryfikowane z powodu braku klucza publicznego: NO_PUBKEY 58403026387EE263

W: Duplicate sources.list entry http://deb.svx.pl edgy/main Packages (/var/lib/apt/lists/deb.svx.pl_dists_edgy_main_binary-i386_Packages)

W: Duplicate sources.list entry http://deb.svx.pl edgy/universe Packages (/var/lib/apt/lists/deb.svx.pl_dists_edgy_universe_binary-i386_Packages)

W: Należy uruchomić apt-get update aby naprawić te problemy.

Na forum.ubuntu.pl - GPG Error (jest w FAQ) + usuń zduplikowane wpisy.


(komin15) #3

Usunąłem wpisy i dodałem klucz.

komenda

sudo apt-get update

Nie udało się pobrać http://security.ubuntu.com/ubuntu/dists/edgy-security/Release.gpg Nie udało się przetłumaczyć nazwy 'security.ubuntu.com'

Czytanie list pakietów... Gotowe

E: Nie udało się pobrać niektórych plików indeksu, zostały one zignorowane lub została użyta ich starsza wersja.

Ale to nie powinno przeszkodzić w instalacji beryla. komenda

sudo apt-get install beryl-core beryl-plugins beryl-plugins-data emerald beryl-settings beryl-manager beryl beryl-dev emerald-themes

i to samo co wcześniej

Czytanie list pakietów... Gotowe

Budowanie drzewa zależności       

Reading state information... Gotowe

Należy uruchomić `apt-get -f install', aby je naprawić:

Następujące pakiety mają niespełnione zależności:

  beryl: Wymaga: libberylsettings0 ale nie zostanie zainstalowany

         Wymaga: libberyldecoration0 ale nie zostanie zainstalowany

  beryl-core: Wymaga: libberylsettings0 ale nie zostanie zainstalowany

              Wymaga: libxcomposite1 ale nie zostanie zainstalowany

  beryl-dev: Wymaga: libberylsettings-dev ale nie zostanie zainstalowany

             Wymaga: x11proto-gl-dev ale nie zostanie zainstalowany

             Wymaga: libgl1-mesa-dev ale nie zostanie zainstalowany

             Wymaga: libstartup-notification0-dev ale nie zostanie zainstalowany

             Wymaga: libxcomposite-dev ale nie zostanie zainstalowany

             Wymaga: libxdamage-dev ale nie zostanie zainstalowany

  beryl-plugins: Wymaga: libberyldecoration0 ale nie zostanie zainstalowany

                 Wymaga: libberylsettings0 ale nie zostanie zainstalowany

                 Wymaga: libxcomposite1 ale nie zostanie zainstalowany

                 Wymaga: libberyldecoration0 ale nie zostanie zainstalowany

  beryl-settings: Wymaga: beryl-settings-bindings ale nie zostanie zainstalowany

  emerald: Wymaga: libemeraldengine0 ale nie zostanie zainstalowany

           Wymaga: libberyldecoration0 ale nie zostanie zainstalowany

  nautilus-sendto: Wymaga: gaim (>= 1:2.0) ale nie zostanie zainstalowany

                   Wymaga: gaim (< 1:3.0) ale nie zostanie zainstalowany

  ubuntu-desktop: Wymaga: gaim ale nie zostanie zainstalowany

E: Niespełnione zależności. Spróbuj 'apt-get -f install' bez pakietów (lub podaj rozwiązanie).

(nero) #4

a próbowałeś:

?

Przecież konsola podaje Ci co powinieneś spróbować. Wkradł się jakiś błąd i nie zainstalujesz nic dopóki go nie naprawisz. Spróbuj:


(komin15) #5

Odpowiedź systemu na komendę

sudo apt-get -f install

Czytanie list pakietów... Gotowe

Budowanie drzewa zależności       

Reading state information... Gotowe

Naprawianie zależności... Gotowe

Zostaną zainstalowane następujące dodatkowe pakiety:

  gaim gaim-data

Sugerowane pakiety:

  libzephyr3

Zostaną zainstalowane następujące NOWE pakiety:

  gaim gaim-data

0 aktualizowanych, 2 nowo instalowanych, 0 usuwanych i 2 nieaktualizowanych.

11 nie w pełni zainstalowanych lub usuniętych.

Konieczne pobranie 0B/2201kB archiwów.

Po rozpakowaniu zostanie dodatkowo użyte 16,6MB miejsca na dysku.

Czy chcesz kontynuować [T/n]? T

(Odczytywanie bazy danych ... 116821 plików i katalogów obecnie zainstalowanych.)

Rozpakowanie gaim-data (z .../gaim-data_1%3a2.0.0+beta3.1-1ubuntu9_all.deb) ...

dpkg: błąd przetwarzania /var/cache/apt/archives/gaim-data_1%3a2.0.0+beta3.1-1ubuntu9_all.deb (--unpack):

 próba nadpisania `/usr/share/man/man1/gaim.1.gz', który istnieje także w pakiecie gaim2

dpkg-deb: podproces paste został zabity sygnałem (Broken pipe)

Rozpakowanie gaim (z .../gaim_1%3a2.0.0+beta3.1-1ubuntu9_i386.deb) ...

dpkg: błąd przetwarzania /var/cache/apt/archives/gaim_1%3a2.0.0+beta3.1-1ubuntu9_i386.deb (--unpack):

 próba nadpisania `/usr/share/applications/gaim.desktop', który istnieje także w pakiecie gaim2

dpkg-deb: podproces paste został zabity sygnałem (Broken pipe)

Wystąpiły błędy podczas przetwarzania:

 /var/cache/apt/archives/gaim-data_1%3a2.0.0+beta3.1-1ubuntu9_all.deb

 /var/cache/apt/archives/gaim_1%3a2.0.0+beta3.1-1ubuntu9_i386.deb

E: Sub-process /usr/bin/dpkg returned an error code (1)

Co teraz?


(nero) #6

Od kiedy występuje ten problem?

Tzn. robiłeś coś wcześniej czy zaobserwowałeś to dopiero teraz przy próbie instalacji beryla?


(komin15) #7

o gaim’e już wcześniej informowało, ale go nie używam, wiec sie nie przejmowałem, a ten błąd co wyżej to od “próby” instalacji beryl’a

Przed wczoraj instalowałem bardo dużo uaktualnień.

Złączono Posta : 23.02.2007 (Pią) 19:20

5d851c1e29ec0022m.png

Teraz mi wyskakuje takie coś.