Ubuntu 9.10- duże obciążenie procesora


(Dawiddek55) #1

Witam

zrzutekranu1g.th.png

na załączonym screenie widać, jak bardzo procek (Athlon x2 5200+) muli, ok 60% procka jest zżerane nieustannie. Nie wiem od czego tak jest, na karcie procesy wszystkie łykają 0% procka-no jedynie ten menedżer zżera jakieś 15 %-jednak nawet jak go wyłacze zużycie procka nieraz jest normalne a nieraz wysoko skacze- co się dzieje? Czy to może być indexowanie? jak to wyłączyć?

PS jak wyłacze gnome monitor to nieraz jest 100% procka przez chwile, później jest 5 %....te obciążenie jest bardzo nie ustatkowane.


(Kaka') #2

Być może jest to spowodowane przez iowait. Jaki masz dysk twardy (ATA czy SATA)?

Sprawdzaj obciążenie procesora w programie "top", a nie w menadżerze urządzeń (to rysowanie wykresów czasami potrafi zeżreć swoje). Ewentualnie doinstaluj htop i tam patrz.

Zainstaluj również program iotop i sprawdź czy to mulenie procka nie jest przypadkiem spowodowane przez iowait.


(Dawiddek55) #3

kaka- udało mi się zainstalować iotop- gdy próbuję zainstalować top konsolanie rozpoznaje tego programu. Uruchomiłem program iotop i on wskazuje tylko prace dysku i procesy- jest lista procesów- u mnie każdy z nich zrzera 0% procesora a jednak obecnie mam 40% obciążenia.

-- Dodane 02.11.2009 (Pn) 19:48 --

aha dysk to SATA 500GB

tego iowait nie ma w ogóle na liście procesów w tym programie


(Marcinch7) #4

U mnie na 9.10 świeżo postawionym zabiera ok. 20%...

Coś w tym jest.

EDIT: Na 9.04 miałem top zainstalowany, top w konsoli wpisz.


(Dawiddek55) #5

no to terazubu przeszedł sam siebie :frowning: zżera nieustannie 100% procka- dalej tak być nie może-to uniemożłiwia prace z komputerem :frowning: :frowning:

-- Dodane 02.11.2009 (Pn) 20:01 --

heh teraz wpisałem sudo top i wyświetliła sie lista procesów-iotop zżera równo 100% procka... jak to wyłączyć?

-- Dodane 02.11.2009 (Pn) 20:06 --

ok poradziłem sobie i zabiłem iotop programem top, obciążenie spadło ze 100% do 40%-z tego co widze to te 40% to Xorg-co to? i dlaczego tyle zżera? Można to zabić?

-- Dodane 02.11.2009 (Pn) 20:08 --

zabiłem xorga i zostałem wylogowany teraz procek na poziomie 20%- też troche za wysoko-dlaczego ten xorg zżera tyle zasobów?


(Marcinch7) #6

Xorg - serwer graficzny. Takie hmmm coś co wyświetla na ekranie.


(dragonn) #7

Sterowniki własnościowe do karty graficznej zainstalowałeś?


(Kaka') #8

Spróbuj wywalić gadżety z pulpitu i sprawdź jakie będzie obciążenie CPU.


(Dawiddek55) #9

stery zainstalowane,

Kaka'-wywaliłem gadżety, i teraz X.org zabiera mi całe 10%procka czsami spada to do 7%

czy to może być wina compiza? Mam do niego manager i używam tylko kilka podstawowych efektów (gumowe okienka, kostka, przełącznik aplikacji)-reszta większość powyłączana...

-- Dodane 03.11.2009 (Wt) 17:28 --

hmmm... wartość x.org też skacze, obecnie 20-30%-nieraz 10% anieraz 7-5%

-- Dodane 03.11.2009 (Wt) 17:31 --

po wyłączeniu compiza i kompletnym zamknięciu gadżetów x.org łyka 15-80% procka :open_mouth: więc compiza z listy podejrzanych mozna skreślić....


(Kaka') #10

Dość trudno określić co może powodować takie ciągłe obciążenie procesora. Z jednej strony może to być zwykła aplikacja, która akurat 'coś tam oblicza'. Z drugiej strony, problem może nawet leżeć w samym X.Orgu (czyli krótko mówiąc: bug).

Sprawdź jeszcze czy przypadkiem takie duże zużycie CPU nie jest spowodowane przez Firefox. Jeżeli nie, to polecałbym zrobić downgrade xorga i wtedy ocenić sytuację.


(Dawiddek55) #11

hmmm to jest chyba niezależne od aplikacji, czy to FFc czycompiz czy screenlets-obciążenie jest zawsze podobne. Masz jakiś porządny poradnik jak zrobić downgrade X.Orga? wiem że jest sporo w sieci, ale pewnie połowa jest niekompletna..


(Kaka') #12

Można to zrobić na kilka sposobów. Ja stosuję kilka, w zależności od sytuacji.

1) Pobierasz najważniejsze paczki X.Orga z Ubuntu 9.04 (czyli xorg-core, etc.) i instalujesz je za pomocą dpkg.

2) Haszujesz aktualne repo, dodajesz repo z 9.04, usuwasz X.Orga, paczki xorga z katalogu cache APT i instalujesz ponownie X Server.

A w kwestii samego problemu obciążenia CPU... Widzę, że używasz GNOME. Jest to rozbudowane środowisko graficzne, więc również i w nim nie możemy wykluczyć błędu. Proponuję zainstalować jakiś lekki menadżer okien, na przykład Fluksboksa i przez jakiś czas popracować na nim (dajmy na to 2 godziny), z tymi samymi aplikacjami co pod GNOME. Kto wie, może wtedy wyjdzie szydło z worka...


(roobal) #13

Tak jak pisał Kaka' do tego proponuję przyszpilić Xorga, jeśli zamierzasz na niższej wersji jechać w przyszłości to będzie on pomijany w aktualizacjach, czyli po prosty Xorg nie będzie aktualizowany automatycznie. W tym celu stwórz plik /etc/apt/preferences , w ten sposób:

touch /etc/apt/preferences

I wpisz w nim taką zawartość:

Package: Nazwa pakietu

Pin: numer wersji pakietu

Pin-Priority: 1001

Jeśli będziesz chciał przyszpilić kilka pakietów, to wpisów musi być kilka w tym jednym pliku dla każdego pakietu osobno.

Pozdrawiam!


(Marcinch7) #14

Downgrade X.ORG

  1. Otwierasz /etc/apt/sources.list jakimś edytorem dajmy na to gedit: sudo gedit /etc/apt/sources.list

  2. Przed każdym wpisem dodajesz hash czyli "#"

  3. Poniżej wklejasz to:

    deb http://pl.archive.ubuntu.com/ubuntu/ jaunty main restricted

    deb-src http://pl.archive.ubuntu.com/ubuntu/ jaunty main restricted

    deb http://pl.archive.ubuntu.com/ubuntu/ jaunty-updates main restricted

    deb-src http://pl.archive.ubuntu.com/ubuntu/ jaunty-updates main restricted

    deb http://pl.archive.ubuntu.com/ubuntu/ jaunty universe

    deb-src http://pl.archive.ubuntu.com/ubuntu/ jaunty universe

    deb http://pl.archive.ubuntu.com/ubuntu/ jaunty-updates universe

    deb-src http://pl.archive.ubuntu.com/ubuntu/ jaunty-updates universe

    deb http://pl.archive.ubuntu.com/ubuntu/ jaunty multiverse

    deb-src http://pl.archive.ubuntu.com/ubuntu/ jaunty multiverse

    deb http://pl.archive.ubuntu.com/ubuntu/ jaunty-updates multiverse

    deb-src http://pl.archive.ubuntu.com/ubuntu/ jaunty-updates multiverse

    deb http://security.ubuntu.com/ubuntu jaunty-security main restricted

    deb-src http://security.ubuntu.com/ubuntu jaunty-security main restricted

    deb http://security.ubuntu.com/ubuntu jaunty-security universe

    deb-src http://security.ubuntu.com/ubuntu jaunty-security universe

    deb http://security.ubuntu.com/ubuntu jaunty-security multiverse

    deb-src http://security.ubuntu.com/ubuntu jaunty-security multiverse

  4. sudo apt-get update

  5. sudo apt-get autoremove xserver-xorg

  6. Usuwasz cache APT'a - nie wiem jak to zrobić.

  7. Restart i nie będzie środowiska graficznego, wpisz w linii poleceń: sudo apt-get install xserver-xorg

  8. Restart.

  9. sudo gedit /etc/apt/sources.list

  10. Usuwasz "nowe" wpisy i odhashowujesz stare.

  11. sudo apt-get update

Dobrze napisałem? :stuck_out_tongue:


(Dawiddek55) #15

toś dowalił, kolego :smiley: Uważasz że człowiek tak zielony jak ja na 100% usunie "chache apta"- ta, na 100% :o

konkretniej


(Marcinch7) #16

Usuwasz gwiazdki które dałeś, a wpisy które wkleiłeś usuwasz.


(roobal) #17

A tak o:

sudo apt-get clean

Nie zapomnij jeszcze przyszpilić pakietów tak jak pisałem, bo po pierwszym wykonaniu sudo apt-get upgrade , Xorg Ci się automatycznie zaktualizuje a chyba nie taki ma być efekt prawda?

Pozdrawiam!


(Dawiddek55) #18

ten sposób wydaje mi się OK, tylko skąd pobrać te paczki, i co to jest dpkg.

-- Dodane 04.11.2009 (Śr) 17:41 --

heh nie wiem jak przyszpilić tego x.orga- niewiem jak wpisac w naziwe i ten pon pozatym nie można w konsoli pisać w kilku linijkach można tylko w jednym ciągu.....


(Marcinch7) #19

@up - dpkg -i nazwapaczki.deb


(roobal) #20

Paczki możesz pobrać ręcznie bezpośrednio z serwera, do których link masz właśnie /etc/apt/sources.list. A dpkg :arrow: http://pl.wikipedia.org/wiki/Dpkg między innymi Apt korzysta z dpkg.

Przecież Ci napisałem :slight_smile:

Przy ręcznej instalacji aby nie zagubić się w zależnościach proponuję zamiast i dać x, czyli wypakować bezpośrednio zawartość paczki do wybranego katalogu, w ten sposób:

dpkg -x nazwa_paczki /

Pozdrawiam!