Ubuntu 9.10 - Niechcący usunąłem ALSĘ. Jak odzyskać dźwięk?

Witam,

Po aktualizacji Ubuntu z wersji 9.04 do 9.10 zastałem brak dźwięku. Szukałem sposobów w Google i próbowałem je zrobić i wtedy niechcący wywaliłem ALSĘ. Teraz w ogóle nie mogę jej przywrócić, przy wykonywaniu polecenia ./configure wywala mi, że nie znalazł jądra :?

Czy jest jakiś sposób, aby przywrócić to oprogramowanie bez żadnych problemów? Cały czas próbuję ją zainstalować i wywala błąd opisany powyżej.

![-o<

A tak przy okazji, są jakieś sposoby na odzyskanie dźwięku? Próbowałem różnych sposóbów i nic :frowning:

Ale dlaczego chcesz alsę instalować ze źródeł?? Nie możesz użyć repozytorium i zainstalować alsę ??

Chciałem ją zaktualizować. Jakie jest polecenie, żeby zainstalować ALSĘ z repozytorium (jestem początkujący)?

A takie

sudo apt-get install alsa

Pakiet alsa to metapakiet, więc dociągnie automatycznie zależności :slight_smile:

Pozdrawiam!

Zainstalowałem, ale mimo tego nie działa nadal dźwięk. Zmieniam tematykę tego wątku :wink:

Teraz chcę się dowiedzieć, jak odzyskać dźwięk. Próbowałem różnych sposobów z Google, ale mimo tego nie działają :frowning:

Proszę o podawanie sposób. Dźwięk jest mi potrzebny, proszę o szybką pomoc!

Najlepiej jak jesteś początkujący to włącz sobie synaptic i tam poszukaj wszystkiego z alsa w nazwie, z tego co pamięŧam (bo niestety na ubunciaku nie siedzę a na S(I)USIaku to jest chyba narzędzie typu alsaconf które Ci skonfiguruje alse, a chciałbym się przy okazji zapytać, w jaki sposób usunąłeś alsę?

W ustawieniach administratora bądź systemowych powinieneś mieć dźwięk i musisz tam ustawić sterownik przez który ma odtwarzać… też miałem takie problemy… jak siedziałem na ubuntu, potem wszystko działało… teraz niestety… zmuszony jestem na windowsa…

Przy próbie włączenia ustawień dźwięku pojawia się komunikat “Oczekiwanie na odpowiedź systemu dźwięku” i stoi! :frowning:

EDIT

Jednak coś poszło i system wyświetlił ustawienia…lecz nie ma tam żadnego sterownika na liście :o

Pokaż zawartość pliku /etc/modprobe.d/alsa-base.conf i wyniki poleceń:

lspci | grep Audio

lsmod | grep ^snd

I jeśli to się odbywa na laptopie, to podaj jego model.

Pozdrawiam!

alsa-base.conf

# autoloader aliases

install sound-slot-0 /sbin/modprobe snd-card-0

install sound-slot-1 /sbin/modprobe snd-card-1

install sound-slot-2 /sbin/modprobe snd-card-2

install sound-slot-3 /sbin/modprobe snd-card-3

install sound-slot-4 /sbin/modprobe snd-card-4

install sound-slot-5 /sbin/modprobe snd-card-5

install sound-slot-6 /sbin/modprobe snd-card-6

install sound-slot-7 /sbin/modprobe snd-card-7


# Cause optional modules to be loaded above generic modules

install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }

#

# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)

install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }

install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }

install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }

#

install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }

# Cause optional modules to be loaded above sound card driver modules

install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }

install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }


# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)

install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }

# Prevent abnormal drivers from grabbing index 0

options bt87x index=-2

options cx88_alsa index=-2

options saa7134-alsa index=-2

options snd-atiixp-modem index=-2

options snd-intel8x0m index=-2

options snd-via82xx-modem index=-2

options snd-usb-audio index=-2

options snd-usb-us122l index=-2

options snd-usb-usx2y index=-2

options snd-usb-caiaq index=-2

# Ubuntu #62691, enable MPU for snd-cmipci

options snd-cmipci mpu_port=0x330 fm_port=0x388

# Keep snd-pcsp from being loaded as first soundcard

options snd-pcsp index=-2

# Power down HDA controllers after 10 idle seconds

options snd-hda-intel power_save=10 power_save_controller=N

lscpi | grep Audio

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)

lsmod | grep ^snd

snd_hda_intel 435764 0 

snd_pcm_oss 46208 0 

snd_mixer_oss 22528 1 snd_pcm_oss

snd_pcm 83204 2 snd_hda_intel,snd_pcm_oss

snd_seq_dummy 10756 0 

snd_seq_oss 37760 0 

snd_seq_midi 14208 0 

snd_rawmidi 29568 1 snd_seq_midi

snd_seq_midi_event 15104 2 snd_seq_oss,snd_seq_midi

snd_seq 57008 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event

snd_timer 29704 2 snd_pcm,snd_seq

snd_seq_device 14988 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq

snd 62628 9 snd_hda_intel,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device

snd_page_alloc 17032 2 snd_hda_intel,snd_pc

Liczę na szybką pomoc :slight_smile:

Wykonaj to w konsoli:

sudo echo "options snd-hda-intel model=auto" >> /etc/modprobe.d/alsa-base.conf

I napisz czy coś się zmieniło :slight_smile:

Pozdrawiam!

Nie działa :frowning:

EDIT

DZIAŁA! !!

Pozmieniałem trochę w konfiguracji GRUB’a i dźwięk wrócił!