Urban Terror na Linuksa w formie pliku DEB


(Koszal No 1) #1

tak jak w tytule mam Ubuntu 9.04 poszukuję Urban terror 4.1 na linuksa ale koniecznie w pliku o rozszerzeniu .deb

inne nie moge zainstalować. chodzi o archiwa, gdy postępuję tak jak należy czyli ./configure , make , make install to nic kompletnie się nie dzieje.


(marcin82) #2

Witam.

Może to Ci coś pomoże.

http://portal.suse.pl/wiki/index.php/Urban_Terror

Sprawdź od razu czy takiego pliku nie masz już w rozpakowanych źródłach:

http://vlaai.snt.utwente.nl/pub/games/urbanterror/urt40-linux-installer.sh

Nie każdy program instaluje się poprzez ./configure make makeinstall . Czasami będzie to właśnie skrypt wykonywalny, do odpalenia w konsoli.


(Koszal No 1) #3

ok pobrałem plik deb gry zainstalowałem instalator dał komunikat że gra zainstalowana pomyślnie ale nigdzie jej nie widzę żebym mógł ją uruchomić??? :cry:


(Poczta2001) #4

Witam!

Ja ściągnąłem spakowanego urban terrora i po rozpakowaniu były tam: binarka do windowsa oraz binarka dla linuksa ioUrbanTerror.i386

Klikam na tą binarkę dla linuksa i działa.

Może nie jest to ściśle odpowiedź na Twoje pytanie, no bo nic nie instaluje się, tylko ściąga gierkę, rozpakowuje i gra :smiley:


(Koszal No 1) #5

znalazłem folder z Urbanem ale nie mam tam żadnego pliku który uruchamia grę. jak jest u Ciebie. jak na coś kliknę to tylko mam możliwą edycję ale nie wiem jak w dalszym ciągu uruchomić grę

-- Dodane 07.09.2009 (Pn) 20:52 --

http://zapodaj.net/c5d4296f9513.png.html tutaj screen jak ten folder wygląda


(marcin82) #6

Zajrzyj do readme. Może tam coś będzie jak uruchomić grę. Wpisz w konsoli jeszcze taką komendę:

whereis urban terror

. Można jeszcze inaczej zlokalizować plik prawdopodobnie *.bin (wykonywalny).

sudo updatedb

, a potem

locate urban terror

Polecenie "where is" powinno dać odpowiedź, gdzie znajduję się plik uruchamiający gry. Ale może to też być równie dobrze skrypt.


(Koszal No 1) #7

1 polecenie nic nie daje nic nie znajduje. 2 polecenie tak samo nic. 3 polecenie znajduje pliki ale nie wiem który to wykonywalny jaką powinien mieć końcówkę w nazwie?


(marcin82) #8

Nie grałem w to, nie instalowałem, ale wydaje mi się, że powinien być plik *.bin

Drugie polecenie nie pokaże, bo to tylko uaktualnia bazę danych plików w systemie (coś jak indeksowanie w Vista). Locate pokaże Ci wszystkie pliki związane z grą. Może spróbuj tak jak kolega wyżej napisał. Czyli, nie pakiet instalowany w systemie, a osobny katalog z grą, rozpakujesz w /home i tak jak już wyżej napisano.


(Koszal No 1) #9

męczę się i męczę i widzę że linuks robi wszystko żebym się go pozbył... czego twórcy linuksa nie wyjdą na przeciw użytkowników tylko utrudnia najprostsze czynności.

-- Dodane 07.09.2009 (Pn) 21:33 --

ok umieściłem rozpakowaną grę w folderze home bo miałem również i zip. ale nie ma tam żadnego pliku bin.

screen http://zapodaj.net/129fb62274fc.png.html


(Poczta2001) #10

Witam!

Męczysz się chłopie bo to nie Windows i przez to kombinujesz jak w Windows zamiast sobie życie ułatwiać :wink:

Po drugie primo :smiley: to uwagi możesz mieć do twórców gry, że nie zrobili instalatora jak w Windowsie, a nie na linuksa.

Po trzecie primo początki zawsze są trudne...

Zciągnąłeś sobie zipa z grą. Ok.

Rozpakowałeś grę. Ok.

Nie znalazłeś pliku bin bo nie zawsze jest bin :wink:

Są tam za to pliki binarek wyróżnione niebieskimi ikonkami: ioUrbanTerror.exe i binarka pod Linuksa ioUrbanTerror.i386

Kliknij na binarkę pod linuksa (dwukrotnie lub jednokrotnie jak tam masz ustawione w systemie) i UT powinien się uruchomić.

:smiley: A jakby się nie uruchomił to sprawdź prawoklikiem, czy plik ioUrbanTerror ma ustawiony atrybut "wykonywalny"

Gierka działa pod linuksem bardzo sprawnie. Można się najpierw sprawdzić w pojedynkach z botami:

uruchamiasz najpierw konsole, w konsoli /bot_enable 1

następnie przeładowanie ustawień: /reload

i w konsoli można już dodawać boty np.

/addbot raven (lub boa, lub chicken lub tiger etc....)

Powodzenia! :smiley:


(Koszal No 1) #11

wiem jak działa gierka gram już 2 lata ale na windzie i stąd moje problemu ubuntu mam nie całą dobę... zrobiłem jak mówisz i grę odpaliłem tylko że bardzo źle chodzi wręcz nie da się grać samo menu nawet się zacina. Może to wina sterowników bo przyznam się że żadnych nie instalowałem... i nie wiem jak to jest w linuksie bo sam system bez sterowników działa idealnie! !!


(Poczta2001) #12

Prawdopodobnie nie masz zainstalowanych sterowników do karty graficznej. Sukces, że w ogóle gra u Ciebie ruszyła bez uruchomionej akceleracji.

Wszystko zależy jaką masz kartę grafiki. Jeżeli jest to np. karta Nvidii to trzeba pobrać i zainstalować stery od producenta, bo domyślne, otwarte sterowniki dostarczane z systemem nie uwzględniają 3D (ale za to są otwarte :smiley: ) .

W ubunciorze jest tam (mówię z pamięci bo nie mam go zainstalowanego) menadżer sterowników własnościowych (czy cóś w tym guście), który automatycznie zciągnie i zainstaluje wymagany moduł sterownika z internetu. Po zrestartowaniu środowiska graficznego (lub całego kompa) akceleracja powinna działać, a gierka powinna hulać!


(Koszal No 1) #13

hmm korzystałem z tego menedżera sterowników własnościowych ale nie mam tam nic od grafiki tylko mi pobrał jakiś do modemu. Moja karta graficzna to VIA Chrome N89CE jest to zintegrowana grafa... i jakoś nie mogę na google znaleźć sterowników do niej... będę wdzięczny za pomoc lub jakieś namiary... gierkę muszę mieć bo jestem już w fazie uzależnienia... :smiley:


(Poczta2001) #14

Generalnie najłatwiej jest pod linuksem z kartami Nvidii i Ati. Z kartami Via nie miałem do czynienia. Ze słyszenia tylko o projekcie openChrome. Jeśli masz na tyle cierpliwości to może przeszukiwanie np. ubuntu open chrome coś da. W każdym razie bez sterownika o gierkach można zapomnieć... :frowning:


(Koszal No 1) #15

tomek@tomek-laptop:~$ sudo apt-get install xserver-xorg-video-openchrome

[sudo] password for tomek:

Czytanie list pakietów... Gotowe

Budowanie drzewa zależności

Odczyt informacji o stanie... Gotowe

xserver-xorg-video-openchrome jest już w najnowszej wersji.

0 aktualizowanych, 0 nowo instalowanych, 0 usuwanych i 2 nieaktualizowanych.

tomek@tomek-laptop:~$

i tyle nie wiem jak to rozumieć


(Poczta2001) #16

A jeszcze jedno. Po wpisaniu w googlu nazwy twojej karty wyskoczyła mi strona Via Linux Portal, gdzie można sobie zciągnąć sterowniki do kart Via pod różne linuksy. Jest tam także sterownik - Driver dla Ubuntu 8.04LTS w wersji stabilnej i nowsze w wersji beta (oraz kody źródłowe do w/w). Zawsze można spróbowć jak to będzie działać.

http://linux.via.com.tw/support/downloadFiles.action

Powodzenia!


(Koszal No 1) #17

już ściągam widzę że jest to plik o rozszerzeniu gz jak to zainstalować?


(Poczta2001) #18

Jeśli chodzi o listing :

To oznacza to, że w systemie jest obecna najnowsza wersja, którą można znaleźć w repozytoriach. Ale może na stronie producenta są jeszcze nowsze. :smiley:

-- Dodane 08.09.2009 (Wt) 21:40 --

tar.gz to archiwum - coś jak zip :wink:

Wystarczy to rozpakować i przeczytać plik readme, gdzie jest napisane, że trzeba przejść do rozpakowanego katalogu i uruchomić znajdujący się tam plik vinstall na przykład poprzez sudo ./vinstall

Natępnie uruchomić powtórnie komputer

W pliku /etc/X11/xorg.conf w sekcji Device powinno być "via"


(Koszal No 1) #19

"plik vinstall na przykład poprzez sudo ./vinstall" żebym dobrze zrozumiał mam otworzyć terminal poprzez programy itd wpisać sudo . /vinstall i tyle ale jak to rpbie nic się nie instaluje, mam jedynie to - command not found

i tyle....

za to w miejscu w którym podajesz mam to...

xorg.conf (X.Org X Window System server configuration file)

This file was generated by dexconf, the Debian X Configuration tool, using

values from the debconf database.

Edit this file with caution, and see the xorg.conf manual page.

(Type "man xorg.conf" at the shell prompt.)

This file is automatically updated on xserver-xorg package upgrades *only*

if it has not been modified since the last upgrade of the xserver-xorg

package.

Note that some configuration settings that could be done previously

in this file, now are automatically configured by the server and settings

here are ignored.

If you have edited this file but would like it to be automatically updated

again, run the following command:

sudo dpkg-reconfigure -phigh xserver-xorg

Section "Device"

Driver "via"

VendorName "VIA Tech"

BoardName "via"

Identifier "Configured Video Device"

EndSection

Section "Monitor"

Identifier "Monitor"

ModeLine "720x480" 26.7 720 736 808 896 480 481 484 497

ModeLine "720x576" 32.7 720 744 816 912 576 577 580 597

ModeLine "800x480" 29.58 800 816 896 992 480 481 484 497

ModeLine "848x480" 31.5 848 864 952 1056 480 481 484 497

ModeLine "856x480" 31.7 856 872 960 1064 480 481 484 497

ModeLine "960x600" 45.98 960 1000 1096 1232 600 601 604 622 -HSync +Vsync

ModeLine "1000x600" 48.07 1000 1040 1144 1288 600 601 604 622 -HSync +Vsync

ModeLine "1024x512" 41.3 1024 1056 1160 1296 512 513 516 531

ModeLine "1088x612" 52.95 1088 1128 1240 1392 612 613 616 634 -HSync +Vsync

ModeLine "1152x720" 67.32 1152 1208 1328 1504 720 721 724 746 -HSync +Vsync

ModeLine "1200x720" 70.18 1200 1256 1384 1568 720 721 724 746 -HSync +Vsync

ModeLine "1280x600" 61.50 1280 1336 1464 1648 600 601 604 622 -HSync +Vsync

ModeLine "1280x720" 74.6 1280 1341 1474 1688 720 721 724 746

ModeLine "1280x768" 80.1 1280 1344 1480 1680 768 769 772 795

ModeLine "1360x768" 85.50 1360 1392 1712 1744 768 783 791 807 +HSync +Vsync

ModeLine "1366x768" 85.86 1366 1440 1584 1800 768 769 772 795 -HSync +Vsync

ModeLine "1440x900" 106.47 1440 1520 1672 1904 900 901 904 932 -HSync +Vsync

ModeLine "1440x1050" 126.2 1440 1536 1688 1936 1050 1051 1054 1087

ModeLine "1600x900" 119.00 1600 1696 1864 2128 900 901 904 932 -HSync +Vsync

ModeLine "1600x1024" 136.36 1600 1704 1872 2144 1024 1025 1028 1060 -HSync +Vsync

ModeLine "1792x1344" 202.97 1792 1920 2112 2432 1344 1345 1348 1391 -HSync +Vsync

ModeLine "1856x1392" 218.57 1856 1992 2192 2528 1392 1393 1396 1441 -HSync +Vsync

ModeLine "1920x1080" 172.9 1920 2043 2249 2578 1080 1081 1084 1118

ModeLine "2048x1536" 266.95 2048 2200 2424 2800 1536 1537 1540 1589 -HSync +Vsync

ModeLine "720x480" 34.9 720 752 824 928 480 481 484 502

ModeLine "720x576" 42.6 720 760 832 944 576 577 580 602

ModeLine "848x480" 41.0 848 880 968 1088 480 481 484 502

ModeLine "856x480" 41.3 856 888 976 1096 480 481 484 502

ModeLine "1024x512" 53.3 1024 1072 1176 1328 512 513 516 535

ModeLine "1280x768" 103.0 1280 1360 1496 1712 768 769 772 802

ModeLine "1440x1050" 160.0 1440 1536 1696 1952 1050 1051 1054 1096

ModeLine "1280x768" 118.5 1280 1368 1504 1728 768 769 772 807

ModeLine "1440x1050" 184.5 1440 1544 1704 1968 1050 1051 1054 1103

ModeLine "848x480" 47.4 848 888 976 1104 480 481 484 505

EndSection

Section "Screen"

Monitor "Monitor"

SubSection "Display"

Modes "1024x768"

Virtual 1024 768

Depth 24

EndSubSection

SubSection "Display"

Modes "1024x768"

Virtual 1024 768

Depth 24

EndSubSection

Identifier "Default Screen"

Device "Configured Video Device"

EndSection

Section "Module"

Load "glx"

Load "dri"

Load "extmod"

EndSection

Section "DRI"

Group 0

Mode 0666

EndSection

-- Dodane 09.09.2009 (Śr) 14:40 --

chyba oznacza to że sterowniki są zainstalowane ale nadaj gra nie chodzi. oraz filmy katastroficznie się tną.

Jedyna zmiana na lepsze jaką zauważyłem w przesiadce na Ubuntu jest prędkość pobierania plików z internetu wzrosła o 300%.

-- Dodane 09.09.2009 (Śr) 14:47 --

po restarcie filmy ok ale grę jak mogłem odpalić to teraz nie mogę. mam tylko przez sekundę czarny monitor i wraca do pulpitu.

-- Dodane 09.09.2009 (Śr) 14:53 --

po restarcie w pliku mam teraz to:

xorg.conf (X.Org X Window System server configuration file)

This file was generated by dexconf, the Debian X Configuration tool, using

values from the debconf database.

Edit this file with caution, and see the xorg.conf manual page.

(Type "man xorg.conf" at the shell prompt.)

This file is automatically updated on xserver-xorg package upgrades *only*

if it has not been modified since the last upgrade of the xserver-xorg

package.

Note that some configuration settings that could be done previously

in this file, now are automatically configured by the server and settings

here are ignored.

If you have edited this file but would like it to be automatically updated

again, run the following command:

sudo dpkg-reconfigure -phigh xserver-xorg

Section "Device"

Identifier "Configured Video Device"

EndSection

Section "Monitor"

Identifier "Configured Monitor"

EndSection

Section "Screen"

Identifier "Default Screen"

Monitor "Configured Monitor"

Device "Configured Video Device"

EndSection


(Poczta2001) #20

command not found - system nie może znaleźć pliku vinstall - czy znajdujesz się w rozpakowanym katalogu???