Urządzenie podłączone do routera widoczne z Internetu


(Czajo) #1

Witam. Zostałem zobowiązany do uruchomienia tablic LED w jednym z miast, by wyświetlały dane dynamicznie. Udało się spiąć tablicę z komputerem wewnątrz jednej sieci LAN. Jednak burmistrz wymyślił, że każda tablica ma być podpięta pod router LTE (z wyjściem RJ45). Dostałem taki jeden zabytek do testów: ZTE MF612. Wydaje mi się, że ustawiłem wszystko dobrze - tablica pobrała IP 192.169.0.100 (początek adresacji DHCP na routerze), więc ustawiłem przekierowanie wszystkich portów na ten adres oraz DMZ też na te IP. Tablica komunikuje się po porcie 21 (zmodyfikowany protokół FTP). Jednak z poziomu mojego programu nie mogę się połączyć (po lanie śmigało aż miło). Coś robię nie tak?


(bachus) #2

A testowałeś z zewnątrz? Z innej sieci?


(Czajo) #3

Tak testowałem że swojej sieci domowej.


(bachus) #4

Zezwoliłeś na ruch na firewall? Wyłączyłeś firewall na stacji roboczej?


(Czajo) #5

korzystam z firewalla z Comodo Internet Security. Zarówno z włączonym firewallem jak i wyłączonym jest to samo - nie mogę się połączyć z hostem. A może ja źle robię sprawdzając IP na komputerze podłączonym o routera LTE i to te IP wpisując w swoim programie zarządzającym tablicą? Jeśli wpiszę adres lokalny, to wszystko ładnie śmiga…


(roobal) #6

W tym LTE masz publiczne IP czy jesteś za NATem? Podejrzewam, że jesteś za NATem ISP. Jeśli tak, to musisz wykupić publiczne IP, o ile operator oferuję taką usługę.


(Czajo) #7

teoretycznie miasto miało zapewnić stałe publiczne IP, jednak przy każdym restarcie routera mam inne IP, więc chyba jest coś nie tak…


(bachus) #8

Dynamiczne IP nie jest jednoznaczne, że jesteś za NATem. Jak jednak wspomniał @roobal jest to wysoce prawdopodobne. 


(Czajo) #9

a można to jakoś łatwo sprawdzić?


(bachus) #10

Zapytać dostawcę, ew. zobaczyć na routerze jaki jest przyznawany adres (po stronie WAN).