VirtualDub, problem z Bitrate audio


(Speedy1993 1993) #1

Przy filmach które wgrywam, pojawia mi się taki komunikat problm.jpg

Więc jak wcisnę "nie" nie mam możliwości obróbki pliku, program wyłącza się lub nie mogę przesunąć filmu.

Jak wcisnę "tak" to dźwięk zaczyna wyprzedzać obraz, po wycięciu fragmentu i jego zapisaniu jest tak samo.

Więc co mam zrobić żebym mógł zapisać fragment filmu, a dźwięk i obraz się zgadzały.

Program to VirtualDubMod 1.6.0.0 SURROUND w VirtualDub-1.5.1 jest podobny komunikat, a w Ulead Video Studio po prostu dźwięk z obrazem nie zgadza się.

Z góry dzięki za każdą pomoc :smiley:


(Miniuwa) #2

Komunikat mówi o tym, że audio w filmie ma zmienny bitrate i raczej trudno o synchronizację z takim audio. Spróbuj wyodrębnić z niego audio, przekompresować w programie Audacity na audio CBR (stały bitrate) i scalić to w film. Ja też miałem problemy z desynchronizacją ale to była wina resizu ramki bądź zmienienia framerate'u. Nie wiem jak to jest z audio VBR ale myślę, że po tej operacji audio powinno się zgodzić z filmem.


(Placio74) #3

Korzystaj z aktualnych wersji - VirtualDub 1.8.8/1.9.2.

Sprawdź z włączonym 'wewnętrznym' dekoderem.

Options > Preferences... > AVI > Prefer internal audio decoders over installed third-party codecs

Oczywiście w aktualnej wersji VD przy komunikacie o VBR kliknij Nie.

Możesz nawet w ogóle wyłączyć wyświetlanie tego komunikatu.

Options > Preferences... > AVI > i wyłączone Warn when VBR audio is detected

Korzystasz z 'systemowego' kodeka MP3 (wymagany do dekodowania), czy masz podmieniony na jakiś inny?

Wypróbuj Avidemux.


(Speedy1993 1993) #4

Wyświetla się komunikat, ale wszystko jest w porządku, nie potrzebnie przerzucałem się na VDM

Nie mam pojęcia :frowning: