[Win7-64bit][kodeki-XVID] Nietypowy problem z napisami


(Otemba) #1

Mam ciekawy problem z napisami:

Na świeżym, zaktualizowanym systemie Win7 (64bit), na najnowszym pełnym wydaniu K-Lite Codec Pack, działają mi wszystkie filmy. Prawie wszystkie odtwarzają się z napisami. No właśnie, mam kilka filmów, które - jeżeli w katalogu znajdują się napisy - nie dość, że nie odtwarzają napisów, to jeszcze zawieszają większość odtwarzaczy (wm12 , media player classic, subedit player, all player). Jeśli natomiast w katalogu nie ma pliku z napisami, film odtwarzany jest poprawnie. Próby załadowania napisów zawieszają odtwarzanie i program.

Przyjrzałam się uważnie i dostrzegłam, że cechą wspólną tych filmów jest kodek - XVID. I to jedna konkretna wersja, opisana przez MediaInfo tak:

ID : 0

Format : MPEG-4 Visual

Format profile : Advanced Simple@L5

Format settings, BVOP : No

Format settings, QPel : No

Format settings, GMC : No warppoints

Format settings, Matrix : Default (H.263)

Codec ID : XVID

Codec ID/Hint : XviD

Natomiast pliki kodowane taką (praktycznie identyczną) wersją odtwarzają się poprawnie (z napisami i bez):

ID : 0

Format : MPEG-4 Visual

Format profile : Advanced Simple@L5

Format settings, BVOP : 2

Format settings, QPel : No

Format settings, GMC : No warppoints

Format settings, Matrix : Default (H.263)

Muxing mode : Packed bitstream

Codec ID : XVID

Codec ID/Hint : XviD

Czy ktoś ma jakiś pomysł na rozwiązanie tego problemu?

Będę bardzo wdzięczna :slight_smile:


#2

onna , proszę zapoznaj się z tą stroną oraz tym tematem, a następnie popraw tytuł tematu, używając przycisku ac7a4cd89050aa6e.gif


(Witkacy75) #3

Plik z napisami musi mieć DOKŁADNIE taką samą nazwę jak plik z filmem.

Wliczając w to wszystkie spacje, nawiasy i znaki specjalne oraz małe i duże litery.

Jeśli Twój odtwarzacz nie "łyka'' jakiegoś formatu to skonwertuj go na inny, np.: TXT >- SRT itp. itd.


(Tom837) #4

Witam

Zainstaluj sobie kodeki Windows 7 codecs z tutejszego portalu po uprzednim odinstalowaniu innych. :slight_smile: