Windows VPN [PPTP] - jak ustawić statyczny adres serwera?


(Konrad Jestem) #1

Witam serdecznie,

 

Utworzyłem VPN przez wbudowane narzędzie systemu Windows [PPTP].

Z aktualnym serwerem VPN będą łączyły się 2 zewnętrzne komputery, jednak sytuacja tego wymaga, aby mój serwer VPN miał swoje stałe ip, gdyż muszę się odwoływać do bazy MsSQL właśnie poprzez to ip.

Czy jest możliwość ustawienia tego? Jeśli tak to jak i gdzie?

 

Próbowałem przydzielić mu pulę adresów (wybierał pierwszy z brzegu więc było "niby ok"), ale w tym trybie nie działało udostępnianie zasobów po VPN - po prostu przestawało działać, komputery się nie widziały, ale z bazą po ip potrafiły się połączyć.

 

 

Pozdrawiam i liczę na Waszą pomoc, specjaliści.

 

 

EDIT1


(roobal) #2

VPN stawiasz na Windows Server czy na routerze, o którym kiedyś pisałeś? Czy masz na myśli klienta VPN? Co do IP, mówisz o IP dla VPN czy o IP serwera, bo z tego co pamiętam, to działa na Neostradzie, tak?


(Konrad Jestem) #3

Witam ponownie,

 

VPN postawiłem na Windows 7, tak jak pisałem - przez wbudowane narzędzie (ncpa.cpl itd).


(roobal) #4

U mnie serwer ma zawsze ten sam adres, nawet po zerwaniu połączenia. Postaw sobie serwer DHCP i zrób rezerwację adresów.

Te odwołania do bazy robisz przez jakiś skrypt, np. php? Do MySQL możesz łączyć się zdalnie bez użycia VPN.

Udostępnianie powinno działać. Nie szukaj zasobów w otoczeniu sieciowym, tylko łącz się z zasobami po IP serwera lub jego nazwie.


(Konrad Jestem) #5

A jak postawić serwer DHCP na systemie Windows 7? Muszę mieć do tego Windows Server czy da się to zrobić na siódemce?


(roobal) #6

Jak znajdziesz jakiś serwer DHCP, to możesz zrobić na Windows 7. Możesz spróbować skorzystać z DHCP routera, ale musiałby on obsługiwać wiele podsieci i serwer musiałby umieć przekazywać zapytania do serwera DHCP.

W pierwszym poście napisałeś MsSQL, co wzrokowo wyglądało na MySQL. W każdym razie myślę, że do MSSQL powinno dać się również podłączyć zdalnie bez użycia VPN, no chyba że chcesz koniecznie szyfrować połączenie przez VPN.

Znam ludzi co kupują VPS z Windows Server tylko po to, aby postawić na nim LAMP, więc takie rzeczy mnie nie dziwią.

 

Jaką adresację przypisywał serwer i o jakich routera mówisz. Napisz jak to jest połączone lub podaj schemat sieci.


(Konrad Jestem) #7

Komputer (serwer) ma router:

Maska podsieci:


(roobal) #8

Czyli adresy dla VPN przypisujesz z routera, do którego podpięty jest serwer? Przypisywałeś adresy z serwera VPN, np. z puli 10.1.1.1 - 10.1.1.99? Serwer może być w podsieci 192.168.2.0/25, a VPN może być w innej podsieci, serwer będzie routował ruch między podsieciami.


(Konrad Jestem) #9

Tak, dokładnie tak jak zaczynasz pisać.

Przypisalem niegdyś pulę 10.0.0.10-10.0.0.20

Przydzielalo ładnie ale z zasobami kompletna lipa.

Z udostępnianiem poradziłem sobie jednostronnie.

Ustawiłem pulę 192.168.2.70 - 192.168.2.75,

Klient poprawnie pinguje serwer, może korzystać z udostępnionych przez niego zasobów, natomiast nic nie działa w kierunku odwrotnym, nie da się korzystać z zasobów klienta, ani pingować komputera klienta z poziomu serwera.


(roobal) #10

Na takiej puli też powinno działać. Skonfiguruj serwer VPN na nowo, widocznie coś jest nie tak.


(Konrad Jestem) #11

Sprawdzę już jutro i dam znać jak poszło :slight_smile:


(roobal) #12

Czekam na info.


(Konrad Jestem) #13

Dałem sobie jednak spokój, bo mimo wszystko to i tak nie to rozwiązanie, jakie finalnie będzie zastosowane.

Czekam na kuriera z moim Routerboardem, natomiast mam nowe problemy, które poruszyłem w innych tematach na forum :slight_smile:

 

W każdym razie, wielkie dzięki za wszechstronną okazaną pomoc.


(roobal) #14

Ok, nie ma sprawy. Dzięki za info.