Xubuntu - problem z UbuDSL - błąd przy uruchamianiu systemu


(demisen) #1

Zainstalowałem Xubuntu 8.04 i następnie UbuDSL 0.9 Beta. Teraz za każdym uruchomieniem mam komunikat:

BŁĄÐ

UbuDSL: aplikacja została uruchomiona bez uprawnień administracyjnych. Program zostanie teraz zamknięty. Proszę uruchomić go ponownie, wykonując poniższe polecenie:

sudo /opt/ubudsl/ubudsl

I tak za każdym uruchomieniem, nie wykonuje tego tylko daje Aplikacje > Sieć > UbuDSL moniotowanie > Połącz, ale ten komunikat mnie denerwuje. NA Ubuntu 8.04 nie było tego.


(matiit) #2

A wpisz w konsoli sudo /opt/ubudsl/ubudsl


(demisen) #3

Uruchamia wtedy UbuDSL czyli to samo co ja robię ręcznie bo wyłączyłem automatyczne łączenie z autostartu. Jak pozbyć się tego ? Ubu działa poprawnie tak czy siak. Tylko za każdym razem te okienko :smiley:


(matiit) #4

Pokaż wynik tego:

ls -l /etc/init.d/

(demisen) #5

Proszę bardzo:

razem 392

-rwxr-xr-x 1 root root 2710 2008-04-19 06:19 acpid

-rwxr-xr-x 1 root root 762 2007-08-31 04:48 acpi-support

-rwxr-xr-x 1 root root 9708 2008-02-27 14:22 alsa-utils

-rwxr-xr-x 1 root root 1084 2007-03-05 07:38 anacron

-rwxr-xr-x 1 root root 1667 2007-05-23 14:59 apmd

-rwxr-xr-x 1 root root 2653 2008-04-07 23:38 apparmor

-rwxr-xr-x 1 root root 2181 2008-02-05 13:41 apport

-rwxr-xr-x 1 root root 969 2007-02-20 14:41 atd

-rwxr-xr-x 1 root root 2594 2008-03-21 11:38 avahi-daemon

-rwxr-xr-x 1 root root 6609 2008-04-21 09:34 bluetooth

-rwxr-xr-x 1 root root 3597 2008-04-19 07:05 bootclean

-rwxr-xr-x 1 root root 2121 2008-04-19 07:05 bootlogd

-rwxr-xr-x 1 root root 1768 2008-04-19 07:05 bootmisc.sh

-rwxr-xr-x 1 root root 3454 2008-04-19 07:05 checkfs.sh

-rwxr-xr-x 1 root root 10602 2008-04-19 07:05 checkroot.sh

-rwxr-xr-x 1 root root 6355 2007-05-30 14:29 console-screen.sh

-rwxr-xr-x 1 root root 1634 2008-01-28 18:49 console-setup

-rwxr-xr-x 1 root root 1761 2008-04-08 20:02 cron

-rwxr-xr-x 1 root root 2287 2008-04-21 22:15 cupsys

-rwxr-xr-x 1 root root 4546 2008-02-29 10:21 dbus

-rwxr-xr-x 1 root root 1506 2007-10-23 16:34 dhcdbd

-rwxr-xr-x 1 root root 1223 2007-06-22 06:55 dns-clean

-rwxr-xr-x 1 root root 3134 2008-04-21 17:47 gdm

-rwxr-xr-x 1 root root 7195 2008-04-05 01:38 glibc.sh

-rwxr-xr-x 1 root root 2301 2008-04-21 22:13 hal

-rwxr-xr-x 1 root root 1228 2008-04-19 07:05 halt

-rwxr-xr-x 1 root root 909 2008-04-19 07:05 hostname.sh

-rwxr-xr-x 1 root root 3576 2008-04-10 18:49 hotkey-setup

-rwxr-xr-x 1 root root 4528 2008-04-15 05:36 hwclockfirst.sh

-rwxr-xr-x 1 root root 4521 2008-04-15 05:36 hwclock.sh

-rwxr-xr-x 1 root root 1376 2008-01-28 18:49 keyboard-setup

-rwxr-xr-x 1 root root 944 2008-04-19 07:05 killprocs

-rwxr-xr-x 1 root root 1729 2007-11-23 10:06 klogd

-rwxr-xr-x 1 root root 2308 2007-12-12 00:00 laptop-mode

-rwxr-xr-x 1 root root 349 2008-04-11 00:57 linux-restricted-modules-common

-rwxr-xr-x 1 root root 748 2006-01-23 19:47 loopback

-rwxr-xr-x 1 root root 1399 2008-02-25 22:20 module-init-tools

-rwxr-xr-x 1 root root 596 2008-04-19 07:05 mountall-bootclean.sh

-rwxr-xr-x 1 root root 2430 2008-04-19 07:05 mountall.sh

-rwxr-xr-x 1 root root 1465 2008-04-19 07:05 mountdevsubfs.sh

-rwxr-xr-x 1 root root 1544 2008-04-19 07:05 mountkernfs.sh

-rwxr-xr-x 1 root root 594 2008-04-19 07:05 mountnfs-bootclean.sh

-rwxr-xr-x 1 root root 1244 2008-04-19 07:05 mountoverflowtmp

-rwxr-xr-x 1 root root 3123 2008-04-19 07:05 mtab.sh

-rwxr-xr-x 1 root root 1772 2007-12-03 21:50 networking

-rwxr-xr-x 1 root root 860 2007-11-21 19:31 nvidia-kernel

-rwxr-xr-x 1 root root 2377 2007-10-23 19:03 pcmciautils

-rwxr-xr-x 1 root root 693 2008-04-19 06:42 policykit

-rwxr-xr-x 1 root root 4721 2008-03-09 01:24 powernowd

-rwxr-xr-x 1 root root 177 2008-03-09 01:24 powernowd.early

-rwxr-xr-x 1 root root 375 2007-10-04 21:56 pppd-dns

-rwxr-xr-x 1 root root 1261 2008-03-13 23:24 procps

-rwxr-xr-x 1 root root 7891 2008-04-19 07:05 rc

-rwxr-xr-x 1 root root 522 2008-04-19 07:05 rc.local

-rwxr-xr-x 1 root root 117 2008-04-19 07:05 rcS

-rwxr-xr-x 1 root root 1492 2008-04-22 00:53 readahead

-rwxr-xr-x 1 root root 1957 2008-04-22 00:53 readahead-desktop

-rw-r--r-- 1 root root 1335 2008-04-19 07:05 README

-rwxr-xr-x 1 root root 692 2008-04-19 07:05 reboot

-rwxr-xr-x 1 root root 1000 2008-04-19 07:05 rmnologin

-rwxr-xr-x 1 root root 4945 2008-04-11 02:12 rsync

-rwxr-xr-x 1 root root 955 2007-10-23 18:01 screen-cleanup

-rwxr-xr-x 1 root root 1199 2008-04-19 07:05 sendsigs

-rwxr-xr-x 1 root root 585 2008-04-19 07:05 single

-rwxr-xr-x 1 root root 4215 2008-04-19 07:05 skeleton

-rwxr-xr-x 1 root root 510 2008-04-19 07:05 stop-bootlogd

-rwxr-xr-x 1 root root 647 2008-04-19 07:05 stop-bootlogd-single

-rwxr-xr-x 1 root root 864 2008-04-22 00:53 stop-readahead

-rwxr-xr-x 1 root root 3343 2007-11-23 10:06 sysklogd

-rwxr-x--x 1 root root 746 2008-06-22 20:26 ubudsld

-rwxr-xr-x 1 root root 2488 2008-04-11 14:21 udev

-rwxr-xr-x 1 root root 706 2008-04-11 14:21 udev-finish

-rwxr-xr-x 1 root root 6358 2008-04-07 23:19 ufw

-rwxr-xr-x 1 root root 4030 2008-04-19 07:05 umountfs

-rwxr-xr-x 1 root root 1833 2008-04-19 07:05 umountnfs.sh

-rwxr-xr-x 1 root root 1863 2008-04-19 07:05 umountroot

-rwxr-xr-x 1 root root 1815 2008-04-19 07:05 urandom

-rwxr-xr-x 1 root root 2814 2007-10-15 11:20 usplash

-rwxr-xr-x 1 root root 820 2008-04-14 09:51 vbesave

-rwxr-xr-x 1 root root 2445 2008-04-19 07:05 waitnfs.sh

-rwxr-xr-x 1 root root 1626 2008-03-12 22:27 wpa-ifupdown

-rwxr-xr-x 1 root root 1843 2008-03-13 16:11 x11-common

-rwxr-xr-x 1 root root 568 2008-03-30 07:41 xserver-xorg-input-wacom

(matiit) #6
sudo chmod -x /etc/init.d/ubudsl

W dniu 22.06.2008 , o godzinie 20:19 został dopisany post przez matiit

sudo chmod -x /etc/init.d/ubudsl

A jakby coś po restarcie nie działało to chmod +x /etc/init.d/ubudsl, ale powinno być wszystko ok.


(demisen) #7
chmod: nie ma dostępu do `/etc/init.d/ubudsl': No such file or directory

Sprawdziłem obie wersje.


(matiit) #8

sory.

sudo chmod -x /etc/init.d/ubudsld

(demisen) #9

Nadal nie bangla, ani z "+" ani z "-" <- terminal nie zwraca, żadnej informacji.

Pojawił się kolejny problem. Przez dodaj/usuń zainstalowałem sobie kilka programów (k3b, amarok, scribus etc.) po restarcie normalnie się loguje i na ekranie mam tylko ikony + tapetę. Znikneła mi dolna i górna belka. Zrobiłem prawym na pulpit i dodałem sobie, aby w menu kontekstowym mieć to co jest w górnej belce i np. amarok, k3b nie odpalają się. O co kaman ? Ten soft tylko dla KDE ? Z Ubuntu nie miałem takich problemów, ale schemat kolorów itp. z Xfce > GNOME więc nie poddam się.


(matiit) #10
chmod -x /etc/init.d/ubudsld

i reset

I sprawdź jeszcze czy nic ubudsl nie dodało do pliku /etc/rc.local

Co do drugiego problemu. Naciskasz alt+f2 i wpisujesz gnome-panel


(demisen) #11

Nadal nie bangla. Alt+f2 gnome-panel - nie można uruchomić. Zrobię reinstal może jakiś update coś zepsuł.