Zaniżony mnożnik procesora i nagłe wyłączanie się laptopa


(NRN) #1

Pytanie przedwstępne: co może powodować utknięcie zmiennego mnożnika w procesorze na wartości 6, dając mu ok. 1 GHz mocy, podczas gdy normalnie procesor ten ma 1,66 GHz?

Pytanie wstępne: co może być przyczyną nagłego wyłączania się komputera w czasie pracy w Windowsie, lub niezapowiedzianego wyłączania się systemu i w efekcie komputera w Linuxie?

Historia:

Jestem posiadaczem laptopa, wartego niegdyś sporo ponad 5 koła - Acer Aspire 5562 WXMi. Nic więc dziwnego, że próbuję go za wszelką cenę utrzymać przy życiu. Otrzymał już nowe pamięci, wyczynowy dysk 7200 obr./min zamiast domyślnego 5400. Ustrojstwo zaczęło się zagrzewać do 80* w idle i do 89* w max load. Wkurzony tym faktem, rozmontowałem laptopa (czyli zrobiłem to co bym zrobił ze stacjonarnym PC). Wbrew pozorom, było to niemal banalne zadanie, tylko ciężko było rozpoznać niektóre rodzaje złączek do wyjęcia, no i masakryczne były niektóre zatrzaski. Tak czy siak, rozmontowany laptop dał następujący wynik ekspertyzy grzania:

  • Paproch w wentylatorze

  • Zapchany kurzem radiator (prześwit był, ale skromny)

  • Przestarzała, silikonowa pasta termoprzewodząca w stanie kamienia łupanego

Procesor i GPU zostały przeze mnie oczyszczone ze starej pasty z użyciem benzyny ekstrakcyjnej i patyczków do uszu, a wszelkie pozostałości i smugi zostały wypolerowane chusteczkami higienicznymi (takie dostałem zalecenia od znajomego, który podobną czynność wykonywał). Wszystko lśniło. Chipset także oczyściłem, jednak gąbka dociskająca, termoprzewodząca, była w stanie zdatnym do dalszego użytku, zatem nie została zerwana i zastąpiona pastą. Na procesor nałożyłem 1 kroplę (rozmiar ziarna ryżu) pasty termoprzewodzącej (Arctic-Silver Ceramique, nie przewodzi prądu), GPU otrzymało kropli dwie (większa odległość od podstawki radiatora, którą trzeba było jakoś zapełnić). Wszystko porządnie skręcone wylądowało z powrotem w obudowie. Laptop został złożony, skręcony i uruchomiony dla testu z baterii. Wszystko pięknie działało, załączyłem więc zasilacz (jako, że bateria słabizna), odpaliłem maksymalną moc (oprogramowanie Acera) i załączyłem Prime95 dla testów. W międzyczasie przeglądałem parametry CPU-Z, CoreTemp, GPU-Z, SpeedFan, Manager Zadań Windows i Manager Wydajności Windows (czy jakoś tak to ostatnie). Wyniki:

  • GPU-Z - wszystko w normie

  • SpeedFan - wszystko w normie, temperatury GPU i CPU na poziomie 52*C (spadek o 40 w stosunku do stanu sprzed naprawy!)

  • Manager Zadań i Wydajności - w obu wszystko gra, wykresy były stabilne

  • CoreTemp i CPU-Z - CT pokazuje temperatury identyczne jak SpeedFan (mimo użycia innego sterownika do czujników). Jednakowoż, i CT i CPU-Z pokazały coś niepokojącego - mnożnik zablokowany na x6, częstotliwość końcowa na poziomie 99x MHz. Żadne operacje tego nie zmieniły.

  • Niedługo później komputer się wyłączył.

Dokonałem testu pod Linuxem. W managerze wszystkie parametry były stabilne, czujniki temperatur były identyczne. Wiatraczek jednak, pomimo tego, wchodził na bardzo wysokie obroty, po czym po 2-20 minutach (zależnie od podejścia - były 3) komputer się wyłączał (linux robił to delikatniej niż windows).

Wracamy wiec do pytań z początku i pytania zbiorczego: co jest nie tak?

EDIT:

Oryg tytuł: Problem z cpu Acer Aspire 5560series

Po zmianach (mam nadzieję, że Monczkinowi i innym będzie odpowiadać): Zaniżony mnożnik procesora i nagłe wyłączanie się laptopa

Niestety, na model nie starczyło znaków...


(Monczkin) #2

NRN , nazwij temat konkretnie, bez zbędnych problemów w tytule. Inaczej wyciągnę konsekwencje. Przeczytaj proszę ten temat. viewtopic.php?f=16&t=394978


(NRN) #3

Monczkin, gdybym miał pojęcie jaki to problem, zapewne bym napisał w temacie. Niestety, liter zabraknie na następujący: "Acer Aspire 5562 WXMi nie przegrzewa się, nie ma zwarcia, a nie osiąga maksymalnej mocy (blokuje mu się mnożnik) i wyłącza po 20 minutach pracy bez przyczyny.". Jeśli masz pomysł jak to skrócić - z miłą chęcią uszczegółowię tematykę, jako że sam nienawidzę tematów "Mam problem!". Jednakowoż ja uszczegółowiłem go maksymalnie jak tylko byłem w stanie: problem z CPU. Chętnie wysłucham Twoich porad (nie, to nie ironia, nie stosuję jej w Internecie) i zastosuję się do nich, jeśli tylko jesteś w stanie wskazać prawidłowy temat.

EDIT: póki co zmieniłem na taki jaki jest, ale przyznam szczerze, że teraz mnie on nie zadowala. Choćby z braku modelu laptopa, który się po prostu nie zmieścił.

EDIT2:

Jako, że nikt nie odpisuje, chciałbym dodać efekt moich poszukiwań w sieci. Znalazłem forum z takim oto postem:

Czyli:

  • Kolesiowi lapek się przegrzewał i wyłączał

  • Otworzył go, zobaczył brak pasty na CPU i GPU, co więcej pasta ta była w dziwnym stanie

  • Nasmarował Arctic Silver High Density (bratnia pasta do Arctic Silver Ceramique której użyłem)

  • Temperatura spadła z 80* do 58* i wszystko działa stabilnie.

A teraz porównajmy to do mnie:

  • Mi się lapek przegrzewał ale pracował stabilnie

  • Otworzyłem go, zobaczyłem bardzo mało pasty na CPU i ogrom na GPU, co więcej pasta była w dziwnym stanie

  • Nasmarowałem Arctic Silver Ceramique (bratnia pasta do Arctic Silver High Density której użył)

  • Temperatura spadła z 80* do 52*, mnożnik utknął na x6 i komputer się wyłącza

Wszystko niby identycznie, przyczyna problemu (ciepło) wyeliminowana, a efekty okazują się całkowicie odwrotne do zamierzonych (utrata stabilności). Nie rozumiem tego.