Zniekształcenia dźwięku i spowolnienie programu w Pure Data


(Pjotr24) #1

Witam.

Proszę o pomoc w następującej sprawie:

Mój sprzęt to laptop TOSHIBA Satellite L30, Microsoft Windows XP Home Edition 5.1, Intel Celeron M processor 1.60 GHz, 222 MB RAM, Plik stronicowania 425 MB (171 dostępnych), DirectX 9.0c; Karta dźwiękowa- Realtek HD Audio output, sterowniki karty- RtkHDAud.sys v. 5.10.0000.5257.

Korzystam z programu Pure Data tworząc multimedialne projekty muzyczne. Ostatnio, testując dość skomplikowany projekt napotkałem na następujący problem: program działał stabilnie mając wyłączony dźwięk (opcja 'compute audio'), jednak po włączeniu go i uruchomieniu projektu (odtwarzanie sampli z dysku, przetwarzanie dźwięku z urządzenia zewnętrznego) program zaczął zwalniać, zniekształcać dźwięk i odmawiać posłuszeństwa.

Czy można temu w jakiś sposób zaradzić? Czy ewentualna zmiana sterowników mogłaby pomóc, jeśli tak, to jakie byłyby najlepsze?

Ustawienia audio w PD: sample rate- 44100, delay (msec)- 70, input device- Realtek HD Audio Input, channels 2, output device- Realtek HD Audio Output, channels 2.

Będę wdzięczny za pomoc i radę.


(Lukaszk 89) #2

Wcześniej też tak działał czy normalnie wszystko grało?


(Pjotr24) #3

Wcześniej działał bez zarzutu. Wydawało mi się, że problemy zaczęły się po dokonaniu kilku skomplikowanych edycji i rozbudowaniu projektu w PD, ale po ich usunięciu i uproszczeniu całości, problemy nadal się pojawiają- dźwięk opóźnia się, zniekształca (pojawia się trzeszczenie i granulacja samego dźwięku), program się zacina i bardzo zwalnia, tak, że nawet wyłączyć go trudno. Wyłączenie dźwięku w programie (Audio OFF) normalizuje jego pracę (oczywiście bez dźwięku).


(Lukaszk 89) #4

Reinstal programu+ czyszczenie rejestru pomiędzy instalacjami.Jak nie pomoże będziemy dalej myśleć.


(boczi) #5

pjotr , proszę poprawić temat na konkretny, obrazujący problem używając opcji Edytuj


(Pjotr24) #6

Odinstalowałem program, wyczyściłem rejestr za pomocą RegCleaner, zainstalowałem ponownie. Niestety problem pozostał. Po włączeniu projektu z opcją Audio ON, po parunastu sekundach dźwięk zaczyna się zniekształcać, program zwalnia, pomaga tylko wyłączenie dźwięku (Audio OFF). Co można jeszcze zrobić?


(Lukaszk 89) #7

A sprawdzałeś na innym kompie?Znaczy odpalić projekt na innym?


(Pjotr24) #8

Sprawdziłem działanie projektu na dwóch komputerach, instalując tam PD. Za każdym razem były problemy z dźwiękiem: spowolnienie i zniekształcenia dźwięku (moduł odtwarzający plik z dysku jest częścią projektu). Dźwięk z wejścia zupełnie zniknął, chyba mikrofon się zepsuł, sprawdzę na innym.

Spróbuję zainstalować inną wersję PD (obecnie pracuję na PD-extended), może to coś zmieni.

Jakieś pomysły?