18 WOS PTTM, Convoy, Haulin - problem z uruchomieniem


(Sim09) #1

Mam 2 pytania.

  1. Jak zmienić w tych grach z OpenGL na DirectX?

  2. Co zrobić z błędem prism3D? Instalowałem patcha 1.07 w PTTM i nic to nie dało a w Convoyu i w Haulinie też ten błąd. Daję plik dziennika w PTTM w pozostałych wersjach tego nie robiłem.

    ******** : log created on : Fri Aug 15 09:38:02 2008

    ******** : engine v2.0 Nov 3 2004 13:03:37

    09:38:02 : [sys] init ...

    09:38:02 : [sys] running on Unknown version 6.0

    09:38:02 : [sys] DirectX 8.1 or better detected

    09:38:02 : [sys] using zlib version 1.2.1

    09:38:02 : [cpu] detecting cpu...

    09:38:03 : [cpu] GenuineIntel [Intel(R) Celeron(R) D CPU 3.33GHz] at ~3273MHz.

    09:38:03 : [cpu] Setting up code base to default C++ versions

    09:38:03 : [cpu] cpu features utilized: fpu cmov mmx sse sse2

    09:38:03 : [sys] startup ...

    09:38:03 : [mm] physical memory detected (785152K/299036K)

    09:38:03 : [mm] virtual memory detected (1311872K/1761000K)

    09:38:03 : [mm] trying to allocate memory pool (153600K)

    09:38:03 : [ds8] Available device : Podstawowy sterownik dźwięku ()

    09:38:03 : [ds8] Available device : Głośniki (Realtek High Definition Audio) ({0.0.0.00000000}.{2c069ff6-6bc6-495a-b520-548d18b872a8})

    09:38:03 : [ds8] Available device : Realtek Digital Output (Realtek High Definition Audio) ({0.0.0.00000000}.{818d9b2c-275b-40cb-8ea7-2c3df774bdc6})

    09:38:03 : [game] 18 WoS Pedal to the Metal init ver.1.07 (rev. 6619) retail version.

    09:38:04 : [game] home directory @ "C:/Users/gosc/Documents/18 WoS Pedal to the Metal/"

    09:38:04 : mount -o ro,p2 base.scs /

    09:38:04 : [zipfs] base.scs [crc32_0x5b15d284]

    09:38:04 : mount -o ro,p3 patch_1_07.scs /

    09:38:04 : [zipfs] patch_1_07.scs [crc32_0xe8aa0001]

    09:38:04 : mount -o ro,p1 data.scs /

    09:38:04 : [zipfs] data.scs [crc32_0x7c96ebd]

    09:38:04 : exec /config.cfg

    09:38:04 : [cor] executing /config.cfg

    09:38:04 : uset g_quality 1

    09:38:04 : uset g_game_details 1

    09:38:04 : uset g_view_dist 0.75

    09:38:04 : uset r_device gl

    09:38:04 : uset r_path 1

    09:38:04 : uset r_mode 800x600x16x0

    09:38:04 : uset r_fullscreen 1

    09:38:04 : uset s_3d_emulated 0

    09:38:04 : uset s_mix_rate 44100

    09:38:04 : [snd] select device (ds8)

    09:38:04 : [ds8] distance factor:1

    09:38:04 : ERROR [gl] Software OpenGL detected, refusing to run the game in OpenGL.

    09:38:04 : [gl] low driver: GDI Generic

    09:38:04 : [gl] vendor: Microsoft Corporation

    09:38:04 : [gl] version: 1.1.0

    09:38:04 : [gl] GL extensions: GL_WIN_swap_hint GL_EXT_bgra GL_EXT_paletted_texture

    09:38:04 : [gl] GL_max_texture_size: 1024

    09:38:04 : ERROR [vid] There is no rendering device 'gl'


(Xqwzts1) #2

pirat?


(Sim09) #3

Nie. Wczoraj kupiłem w dodatku KŚ GRY.


(Fempter) #4

Też miałem problem z Prism3D. Rada jest taka że musisz zainstalować najnowsze sterowniki do karty graficznej i po problemie :wink:


(Sim09) #5

Jeśli mam DirectX 10, to znaczy że mam najnowsze sterowniki? Zapomniałem napisać, że moja karta graficzna to ATI RADEON X1100.


(Fempter) #6

Zaaktualizuj sterowniki od karty graficznej. Znajdziesz je na stronie ATI/AMD.