2 dyski w laptopie/PC - dlaczego dostęp do nich trwa tak długo?


#1

Witam. Od długiego czasu dręczy mnie pytanie odnośnie dysków w kilku komputerach, z którymi miałem do tej pory do czynienia. Pierwszym z nich był komputer stacjonarny, z którego obecnie korzysta mój ojciec. Znajdują się w nim 2 x HDD od Samsunga, każdy ma 500GB. W kolejnym komputerze stacjonarnym miałem dysk SSD Samsunga 120GB i dysk HDD Seagate 1TB. Obecnie w laptopie mam dysk SSD Plextora 128GB i HDD WD 1TB (ostatni PC i obecny laptop to SATAIII, nie pamiętam jakiego typu były dyski w pierwszym PC). We wszystkich przypadkach mowa o dyskach wewnętrznych.

 

O co mi chodzi? Gdy w eksploratorze Windows klikam na dysk i chcę otworzyć jakiś folder, to pojawia się kółko koło kursora i mija chwila, zanim dany folder zostanie otwarty. Wygląda to tak, jakby system próbował uzyskać dostęp do dysku, trwa to jakieś 3-5s. Nie jest to zmulenie systemu, bo działa on w tym momencie normalnie. Po uzyskaniu dostępu do danego pliku czy folderu wszystko działa już normalnie i gdy skończę korzystanie z dysku i wrócę do niego ponownie, to kwestia się powtarza. Czym jest to spowodowane? Czy tak powinno być? Nie jest to problem? Jak widać, miałem te same objawy w trzech różnych komputerach na przestrzeni kilku lat. Przy czym w stacjonarce w momencie wchodzenia na dysk komputer wydawał taki specyficzny odgłos, jakby coś była zapinane, jakiś zatrzask czy coś - nie wiem jak to określić.

 

Dodam jeszcze, że nigdy nie miałem problemów z dyskami, mimo powyższych objawów wszystko chodziło szybko i stabilnie i żadne z dysków nie miały awarii, a pierwsza z wspomnianych stacjonarek działa już chyba 6 lat.

 

Jeśli miałbym zgadywać, czym jest to wywołane, to stawiałbym na ustawienia systemu lub BIOSu, które mają na celu oszczędność energii/wydłużenie żywotności dysku poprzez jakby chwilowe zawieszenie działania dysku, przez co nie pracuje on na pełnych obrotach, gdy nie jest używany i załącza się, gdy jest w użyciu.

 

Proszę o Wasze zdanie na ten temat. Dziękuję.


(wlprzemek) #2

Ja miałem podybny przypadek lecz u mnie 2 dyski po 500 GB tworzyły RAID i też zauważyłem lecz po jakimś czasie chyba te objawy się pokazały.

Walczylem ze sterownikami Intela RAID które były i nic nie pomogło.

Dopiero jak przy okazji format i od nowa system i jest ok śmiga normalne.


(Pablo_Wawa) #3

Ja na Windows XP nigdy nie miałem takich opóźnień, ale na Windows 7 czasami się tak działo (według mnie to ma związek z indeksowaniem i wyszukiwanem plików na takim dysku/folderze). Proponuję przełączyć tryb zasilania na poziom wysoka wydajność i wyłączyć usypianie wybranych dysków - może to pomoże?


(skrzek) #4

Mnie to wygląda jakby dysk był usypiany i w momencie gdy uzyskujesz dostęp dysk zaczyna się kręcić, musi się rozpędzić dlatego trwa to parę sekund. to charakterystyczne ‘zapięcie’ może być związane z parkowaniem głowicy.


#5

Zasilanie mam na najwyższej wydajności cały czas, ale sprawdzę w zaawansowanych ustawieniach zasilania. Nie chodzi mi właściwie o to, by coś zmieniać, chciałem tylko wiedzieć, czy nie jest to jakiś poważny problem. Gdyby okazało się, że jest, to wtedy bym próbował coś zmienić. Do tej pory mnie to co najwyżej lekko irytowało, nic więcej.


(skrzek) #6

Ciągłe usypianie dysku i parkowanie głowicy nie jest korzystne dla dysku.


(bachus) #7

Zacznij może od tego:

http://answers.microsoft.com/en-us/windows/forum/windows_7-files/optimize-this-folder-in-win-7/d1a51e10-cc3b-4cb1-8fa3-0cd23bc0c553

http://www.sevenforums.com/general-discussion/203713-make-folders-default-general-items-optimization.html