2 routery i problem z konfiguracją


(Harmichalh) #1

Witam, mam dwa routery i są połączone kablem. Połączone jest gniazdo LAN i gniazdo na kabel z internetem. W jaki sposób mogę podłączyć te routery, żeby na obu mieć internet, ale żeby działały jak normalne routery, a nie AP? Chcę, żeby kabel dla drugiego routera był jak normalny kabel z internetu dla dostawcy. Jeden router (ten co mam "dawać internet") to D-link DIR-615, a drugi to Planet WRT-415


(janki111) #2

kabel od internetu łączysz do WAN w dlinku -> z niego wychodzi lan1 do wan w Planet i powinno śmigać, oczywiście po konfiguracji


(Harmichalh) #3

Wczesnej już tak próbowałem, teraz znowu podłączyłem wszystko i nie działa. Jak skonfigurować oba routery?


(Pawel Pieczyrak) #4

Jeżeli ten router ma wbudowany modem ADSL to go wyłącz.


(Harmichalh) #5

Żaden z nich nie ma modemu.

-- Dodane 04.05.2011 (Śr) 18:35 --

Podłączyłem router (Planet) do kabla z internetem od dostawcy, ale to nic nie zmieniało. Zresetowałem router do ustawień fabrycznych, ustawiłem na nowo i wszystko działa. Przy okazji zauważyłem, że oba routery miały ustawiony ten sam MAC adres, ale to nie to było przyczyną problemów.


(jas_fasola) #6

W drugin przede wszystkim wyłącz serwer DHCP bo tak to jest konflikt. I kabel od jednego podłącz do sieci normalnie nie do WANu. W tym momencie DLink chodzi jako Router a Planet jako AP i tak ma byc chyba że chcesz mieć sieć wewnętrzną dodatkową. Ale jak chcesz aby się wszyscy ze sobą widzieli to musisz zrobić tak jak napisałem.


(Kpc21) #7

Oba działają jako router, ale mają ten sam adres IP i występuje konflikt.

Kolega właśnie chce mieć dwie odrębne sieci:

Tak więc jak najbardziej słuszne było podłączenie routera poprzez port WAN. Konflikt serwerów DHCP wystąpić tu nie może, bo mamy dwie odrębne sieci, między którymi jest NAT.

W jednym z routerów zmień adres IP w sieci LAN tak, żeby różnił się od adresu drugiego routera - np. z 192.168.1.1 na 192.168.2.1.


(Hnt) #8

A powiedz, co chcesz osiągnąć? Czy brakuje Ci fizycznie portów i chcesz jednym z nich rozszerzyć ich ilość?

Czy potrzebujesz dwóch osobnych podsieci? Napisz czego oczekujesz, a pomożemy Ci z prawidłową konfiguracją:slight_smile:

PZDR


(Harmichalh) #9

Komputery nie muszę być wykrywane, bo to co jest podłączone do 1. routera mnie nie interesuje. Routery są od siebie oddalone i połączone kablem. Są dwa bo sygnał z jednego jest za słaby. Poza tym interesuje mnie też zrobienie osobnej podsieci.

Połączyłem gniazdo LAN w 1. routerze nie skrosowanym kablem do gniazda WAN w drugim. Router zostawiłem na fabrycznych ustawieniach i mam połączenie. Problem w tym, że internet jest bardzo wolny, a łącze mam 16mbs. Jak podłączyłem komputer bez 2. routera do kabla, to wszystko działało szybko. Z drugim routerem łączyłem się przewodowo i bezprzewodowo, ale efekt ten sam. Na 100 pingów do 1. routera:

a)na kablu bez routera 0% straty, czas ok 1ms

b)na kablu z routerem 8% straty, czas ok 2ms

Co może być przyczyną wolnego połączenia i jak ten problem rozwiązać?


(Hnt) #10

OK. Podłączenie masz dobre. Router #2 na porcie WAN dostaje adres po DHCP czy statycznie - to nie ma znaczenia. Ważne by nie pokrywał się z innymi w sieci routera #1. W Twoim urządzeniu (Router #2) wyłącz NAT. Nie potrzebujesz translacji adresów, gdyż obie podsieci są prywatnymi, wystarczy, że Router #1 będzie NATował. Jeżeli będziesz chciał, żeby komputery z podsieci #1 widziały te z podsieci #2 musisz w Routerze #1 dodać trasę statyczną w tablicy routingu. Inaczej komunikacja jest tylko jednokierunkowa (więc nawet ping nie działa:). A dlaczego są straty? Może były problemy z podwójnym natem. Wyłącz też firewalla i inne tego typu bzdury - tym zajmuje się router brzegowy (#1), nie ma potrzeby dublowania.

PZDR!