64 bitowy Windows 7 i nietypowe zużycie RAM


(Detazu) #1

Witam szanownych użytkowników tego forum.

Chciałbym się zwrócić do Was z prośbą o pomoc. Już na drugim laptopie mam problem z nowo zainstalowanym Windows 7 64 bitowym.

Mianowicie, mam 8GB ramu. Po uruchomieniu Windowsa zajęte jest niecałe 2 GB (norma). Następnie gdy uruchamiam instalację jakiejś gry, to ciężko ukończyć taką instalację, bo po kilku chwilach okazuje się, że mam niemalże cały RAM zajęty i zaczyna swapować na dysku, mulenie itp.

Na 32 bitowym systemie nigdy mi się coś takiego nie przydarzyło, i to tylko i wyłącznie przez instalację czegoś. Gdy pamięć się wyczerpuje, w menedżerze zadań ani w jemu podobnych programach, nie ma żadnego procesu który zużywałby tą całą pamięć.

Ma ktoś pomysł dlaczego Windows 64 bitowy robi mi takie dowcipy? Osoby z którymi rozmawiałem nie miały takich problemów ze swoimi systemami. Może robię coś źle... nie mam pojęcia.

Z góry dziękuję za pomoc.


(sadaj72) #2

Może to przez przestarzały instalator gry. chyba że dzieje się tak podczas instalacji każdego programu.


(Detazu) #3

Stało się tak przy instalacji Mirror's Edge, a instalacji Dirta 3 nie mogłem ukończyć (chyba żebym poczekał cały dzień) bo tak duże swapowanie było, gdzie przed rozpoczęciem instalacji ram był prawie pusty (jak na starcie systemu). Na 32 bitowym mi się tak nie robiło, i nie mam pojęcia jak dociec przyczyny. Programy nie zajmują tyle co gry, więc pewnie nie zauważam tego zjawiska.

Gdy przerwałem instalację, wysokie zużycie ramu utrzymywało się jeszcze przez kilka minut, po czym samo spadło.

Pamięć wirtualna jest ustawiona na automatyczne dla wszystkich dysków. Co to może być... :frowning:


(system) #4

sprawdź w menadżerze urządżeń poprostu który proces/aplikacja ąż tyle ramu Ci zabiera

no zadań sorki


(Detazu) #5

Urządzeń? Sprawdzałem w menadżerze zadań jak i w monitorze zasobów w systemie, i niestety nie ma żadnego programu na liście który by tyle zabierał... najwięcej zabierał firefox ale tylko kilkaset MB a nie aż 7 GB... jestem w kropce.


(pawcio1212) #6

jeśli jest nowo zainstalowany to może przeinstaluj

przydało by się z innej płytki zainstalować może błąd jest na płycie


(Detazu) #7

Kiedyś instalowałem z innej płytki i też tak było, to raczej nie to. System jest oprócz tego poprawny, gdyby coś było źle, to by się przecież mógł nawet nie zainstalować. Może jest jakiś proces który odpowiada za zarządzanie pamięcią itp?


(sadaj72) #8

Może jakieś oprogramowanie zabezpieczające typu sandbox powoduje problemy.

Chociaż najłatwiej dojdziesz do tego co zjada ram za pomocą process explorera, włącz process explorer, następnie instalację która powoduje problemy i patrz który proces zaczyna zjadać pamięć.


(Detazu) #9

Zrobiłem jak napisałeś. Proces odpowiedzialny za instalację zajmował bardzo niewiele MB z tego co tam jest podawane. Zużycie pamięci w miarę instalacji ciągle rosło a w process explorerze nic nie wzbudziło moich podejrzeń. Po przerwaniu instalacji i zkillowaniu procesu, zużycie nadal jest wysokie.

Screen z tego programu wraz z zajętą pamięcią u góry: Link

I dalej nie wiem co jest przyczyną z tego programiku. ;/

Tzn? nie bardzo rozumiem. W windowsie się znajduje jakiś program który mógłby coś takiego powodować? co ciekawe dzieje się tak tylko przy instalacji.


(pawcio1212) #10

a format kasował wszystko czy została jakaś partycja z danymi możliwe że masz jakiegoś virusa albo inne szkoldiwe oprogramowanie


(Detazu) #11

to nowy laptop z podzielonym dyskiem na partycje w momencie instalacji. Będę jeszcze skanował ale wątpię żeby to coś dało.

Ostatnio jak mi się tak zrobiło to wróciłem do 32 bitowego systemu, ale teraz przy 8 GB to trochę nie bardzo...

Dlaczego tylko mi musi się tak dziać ;/

Przy innych instalacjach też się tak dzieje. Dlaczego 64 bitowy windows się tak zachowuje?


(sadaj72) #12

Domyślnie nie, ale czasami jest komponentem antywirusa.

Rozwijaną zakładkę przy wininit.exe też przeglądałeś?


(Detazu) #13

Tak, niestety nie ma tam nic podejrzanego. Sami zobaczcie. a zużycie przy tym widoku wciąż wysokie.

Może jest jakiś program, który jest w stanie przejrzeć pamięć i stwierdzić do czego lub z czego bierze się taki przyrost, albo coś... sam nie wiem. :roll:


(pawcio1212) #14

może jakiś uszkodzony sterownik nie pasuje mu 64x

najlepszym rozwiązaniem byłby sprawdzić w trybie awaryjnym jeśli tam jest dobrze to jakiś sterownik


(Detazu) #15

System dopiero co zainstalowany. Stery ze strony producenta. Poprzedni mój komp posiadał całkowicie inne podzespoły, więc stery były innych producentów lub z windows update, i było tak samo. Może log z jakiegoś programu mógłby komuś podpowiedzieć przyczynę albo coś takiego.

Spróbuję potem włączyć instalację gry w awaryjnym, zobaczymy jaki będzie tego rezultat.

EDIT: Instalacja bez montowania obrazu prawdopodobnie nie posiada tego buga, będę to jeszcze testował. Przyczyną mógł być poweriso, który notował tzw. 'memory leak'i.


(pawcio1212) #16

jeśli naprawde poweriso to polecam używać Alcohol 52% sam używam i nie mam żadnych problemów.


(DiamondBack) #17

Zaznacz opcję pokaż procesy wszystkich użytkowników. Czym sprawdzasz, że całą pamięć ci zabiera? Prawdopodobnie, jest błąd w instalatorze i stąd ten wyciek pamięci.


(Detazu) #18

Czym sprawdzam? czym się da. Menedżer zadań, monitor zasobów, process explorer.. to nietrudno sprawdzić, trudniej sprawdzić tylko skąd.

Btw. po zaznaczeniu opcji "pokaż procesy wszystkich użytkowników." nadal nie jest się w stanie zlokalizować procesu który zjada całą pamięć.

Wszech ogłaszam, że przyczyną był PowerIso v4.5. Tu ktoś opisał takie same objawy i konkluzję. W takim razie wyleczyłem się z tego softa i przechodzę na Alcohola 52% :smiley: Dzięki któremu instalacja z obrazów działa jak należy.

Dziękuję bardzo wszystkim, którzy chcieli pomóc. :wink: