Adapter DisplayPort do DVI - mruganie ekranu

Cześć. Mam problem z komputerem, który ostatnio składałem. Kupiłem kabel-adapter z DisplayPort na DVI https://www.morele.net/kabel-gembird-displayport-dvi-d-1-8m-czarny-ccdpmdvim6-612096/

Kabel podłączony jest do DisplayPort na płycie głównej - karta zintegrowana Intel UHD 630. Komputer ma świeży system, wszystkie sterowniki najnowsze zarówno od płyty jak i od Intela. Bios najnowszy wgrany.

Wszystko działa poprawnie do czasu, aż nie włączę Netflix pod Edge (Full HD). Obraz potrafi mrugnąć przez ułamek sekundy na czarno albo w dolnej połówce ekranu pojawia się glicz w postaci szumu czy zerwania ekranu.

Glicze potrafią się nie pojawić przez pół dnia żeby potem pojawiać się co chwila. W tym czasie nic nowego na komputerze nie jest uruchamiane. Co ciekawe, gdy glicz wystąpi na jednym monitorze to jakby propaguje się na drugi - podpięty kablem HDMI - DVI https://www.morele.net/kabel-hama-hdmi-dvi-d-1-5m-czarny-1221300000-615611/

Gdy wypnę kabel z DisplayPort i zostawię tylko ten drugi tj HDMI-DVI to wszystko działa.

Czytałem, że adapter DisplayPort do DVI powinien być aktywny https://support.displaylink.com/knowledgebase/articles/738618-display-intermittently-blanking-flickering-or-los

Są tam linki do producentów ale wolałbym opinię kogoś, kto miał podobny problem i rozwiązał go np kupnem konkretnego kabla czy adaptera.

a jakie masz ustawione odświeżanie na monitorze?

Zwykłe monitory biurowe, ustawione 60Hz i to jest jedyna opcja.

Możesz spróbować wyłączć ustawienia autoodświeżania panelu w centrum przetwarzania grafiki Intel.
Może to coś pomoże

Ale warto poczekać czy ktoś miał podobny problem. Ewentualnie jeżeli to tylko pod Netflixem to może to wina netflixa czy jakaś funkcja ochrony treści jako, że sygnał idzie na dwa monitory?

Skoro problemy tylko przy nefliksie (hbo itp) to może https://pl.wikipedia.org/wiki/HDCP na tej przejściówce się wywala? Z adapterami zawsze są jakieś przygody :wink:

@aesereht Niestety u mnie brak zakładki ‘System’.
@pocolog Być może, problem jest popularny, sporo właścicieli Macbooków go ma. Na razie podejrzewam kabel DP-DVI. Podobno przy kablu bez czipa karta graficzna rozpoznaje, że ma do czynienia ze złączem DVI od strony monitora i robi tą konwersję sygnału we własnym zakresie.

Postanowiłem zrobić eksperyment. Jest taki program jak CRU, gdzie można sobie dodać inne częstotliwości odświeżania. Dodałem 55 hz i działa. Obraz stabilny, zniknęły problemy z gliczami i migającym czarnym ekranem. Może komuś się przyda :slight_smile:

Widocznie jeden z monitorów z jakiegoś powodu nie lubi się z tą płytą główną/grafiką Intela albo jest jakiś problem ze sterownikiem karty Intel UHD.

1lajk

Raczej przejściówka lub kabel ma problem ze stabilnym przesyłaniem sygnału przy częstotliwości 60Hz. Dużo lepsze są lite kabelki posiadające z jednej strony DP, a z drugiej DVI - dużo niższe ryzyko zakłóceń.

A właśnie ciekawostka. Kupiłem lity kabelek DP/DVI - krótki 1m, żeby wykluczyć problem z długością. Podwójnie ekranowany jak to zachwalał producent. Glicza nie było, ale ekran zaczął migać. Czarny ekran raz na jakiś czas przez ułamek sekundy. Kupiłem przejściówkę DP1.2 do DVI (aktywną, z czipem https://www.avans.pl/komputery-i-tablety/akcesoria-komputerowe/adaptery-i-przejsciowki/adapter-displayport-m-1-2-dvi-24-5-f-4k-active) - dalej migotało na czarno. Dopiero trik z 55hz rozwiązał problem.
Wspomniany glicz wyglądał tak

Na razie dla mnie to jest co najmniej dziwne ale cieszę się że trik z minimalną zmianą częstotliwości odświeżania działa. Ten problem ma wiele osób, może komuś się przyda. Niektórzy rezygnują z 144hz, żeby pozbyć się problemów z przesyłem sygnału a może wystarczy obniżyć o do 140hz i będzie działać?

@pocolog ewidentnie to się jakoś wiąże z HDCP, bo Youtube 60kl/s w 4K chodziło bez zająknięcia. Trudne do debugowania bez źródeł :wink:

To jednak nie wina HDCP. Eksperymentowałem trochę i udało mi się efekt ‘mrugania’ uzyskać na programie Coolretroterm. Więc połączenie sypie się/miga gdy trzeba przesłać dużo danych przez port. Netflix ze swoim szczegółowym obrazem w Full HD z kinowym ‘ziarnem’ gdzie brak jednolitych powierzchni, pasuje do tego schematu.

Niższe rozdzielczości Netflix są już trochę rozmazane, mniej ziarniste i widać generują mniejszy ruch na porcie. Oczywiscie trik z obniżeniem częstotliwości odświeżania działa. Nie wiem dokładnie jak to działa, przydałby się inżynier od DVI/HDMI/DP :slight_smile:

Przygrzej kartę przynajmniej pół godziny czy nie będzie sypać pod obciążeniem https://www.geeks3d.com/furmark/downloads/

Grzałem Furmarkiem:). Ten monitor chyba jest jakiś dziwny po prostu, bo przy innym nie mam problemów. Co ciekawe 55hz daje na nim ostrzejszy obraz od 60hz.

Dziwne tylko jest to, że na drugim monitorze masz podobny efekt, ale skoro obniżenie odświeżania o 5Hz pomaga, to się chyba nie ma co kopać z koniem. To jest praktycznie niezauważalna różnica.


Sprawdź jeszcze w normalnych profilach monitora (bez zewnętrznych programów), czy nie masz profilu 59,94Hz. Może taki standardowy by wystarczył do poprawnej synchronizacji?

Bo to skomplikowana sprawa :wink: Na drugim monitorze mam podobny efekt tylko wtedy gdy ten drugi monitor podłączony jest równocześnie z tym problematycznym. Niestety nie mam 59,94 dlatego pomocny okazał się CRU.

Oczywiscie zgoda, wszystko działa, różnica jest niezauważalna a dodatkowo 55hz daje mi ładniejszy obraz (dziwne). Opisuje problem głownie po to, ze może ktoś skorzysta.

1lajk