Alsa. dmix i urządzenie lub zasoby zajęte


(arekk-99) #1

Ja nie wiem, czy tak być powinno, ze Pulse blokuje cały dostęp do Alsy, czy tak być nie powinno... Jednakowoż u mnie tak jest, pomimo zastosowania... Generalnie przepraszam, że nie stosuję jakichś atrybutów tekstowych, by kod stał się czytelniejszy, ale... Niedostępne to raczej jest, chyba że są jakieś htmlowskie komendy na to.

pcm.!default {

#type plug
#slave.pcm "softvol"
#}
#pcm.softvol {
#type softvol
#slave {
#pcm "plug:dmix"
#}
#control {
#name "PCM"
#card 1
#}
#}
pcm.!default {
type plug
slave.pcm "dmixer"
}
pcm.default {
type plug
slave.pcm "dmixer"
}
#ctl.!default {
#type hw
#card 1
#}
pcm.dsp0 {
type plug
slave.pcm "dmixer"
}
pcm.dmixer {
type dmix
ipc_key 1024
slave {
pcm "hw:1,0"
period_time 0
period_size 1024
buffer_size 4096
rate 44100
}
bindings {
0 0
1 1
}
}
#ctl.dmixer {
#type hw
#card 1
#}
ctl.mixer0 {
    type hw
    card 1
}

pcm type jack

#pcm.jack {
#    type jack
#    playback_ports {
#        0 system:playback_1
#        1 system:playback_2
#    }
#    capture_ports {
#        0 system:capture_1
#        1 system:capture_2
#    }
#}

Jack też nie działa. Łączy się z serwerem podobno, ale nie ma dźwięku, dlatego zakomentowałem.


(Dimatheus) #2

arekk-99 , zapoznaj się, proszę, z tym poradnikiem i stroną, a następnie - korzystając z przycisku Edytuj (na dole pierwszego posta po lewej stronie) - popraw tytuł wątku tak, by mówił konkretnie o problemie. Poprawnie zatytułowany wątek zwiększa szansę na uzyskanie szybkiej pomocy. Zignorowanie tej prośby będzie skutkować przeniesieniem tematu do kosza.

Pozdrawiam,
Dimatheus