Amarok 2, kubuntu 8.10 i dźwięk 5.1


(Shadowk) #1

Witam. Mam problem z ustawieniem dźwięku 5.1 w Amaroku 2. W Amaroku 1.4.10 mogłem ustawić Ustawienia > Moduł > Układ głośników > Surround 5.1, w tym nowym już tego nie ma. Dokładniej chodzi mi o klonowanie dźwięku stereo na pozostałe głośniki. Są może jakieś dodatkowe ustawienia w Amaroku 2? Czego używa ten amarok, bo w gxine ustawiłem też 5.1, ale to nic nie pomogło. Większość aplikacji odtwarza dźwięk we wszystkich głośnikach. Karta dźwiękowa to Realtek AC'97 (V8237).

.asoundrc wygląda tak:

#########################################################

#This is the standard setting (see: "!default")

#This profile, the default loaded, upmixes stereo sound to 5.1.


pcm.!default {

        type plug

        slave.pcm "surround51"

        slave.channels 6

        route_policy duplicate

}

########################################################

#This is the normal spdif output profile (optical, toslink).


pcm.!spdif {

    type plug

    slave.pcm "hw:0,1"

}


#######################################################

#This is what one could call the "factory default setting", in other words, it only plays the actual channels. so if you fx want to watch a 5.1 movie, on the analog output, this is the option you want. 



pcm.analog {

    type plug

    slave analog_slave;

}


pcm_slave.analog_slave {

        pcm surround51;

        format S32_LE;

}

(matiit) #2

Poszukaj w ustawieniach phonona. Czyli w centrum sterowania KDE czy jak tam to się teraz nazywa.


(Shadowk) #3

Trochę ubogie to moje centrum :frowning: Mogę wybrać tylko preferowane urządzenia audio, usuwanie przeplotu i pokazanie urządzeń OSS co mnie chyba nie dotyczy. Mam zainstalowane pakiety: phonon, phonon-backend-xine i libphonon4.