amaroK-could not be started


(Centrumopowiastek) #1

Gdy chce włączyć amaroK'a pojawia mi się taki komunikat:

amaroK could not be started, try typing amarok at a command prompt, perhaps the output can help

Próbowałem otworzyć przez skrót, przez "wykonaj polecenie" i przez konsolę, ale nic. Wcześniej wszystko było w porządku. Przy włączaniu przez konsolę:

[amaroK loader] connecting to /home/alfa/.kde/socket-c22-147.icpnet.pl/amarok.loader_socket

[amaroK loader] amaroK not running. Trying to start it..

amarok: [PluginManager] Plugin trader constraint: [X-KDE-amaroK-framework-version] == 3 and [X-KDE-amaroK-plugintype] == 'engine' and [X-KDE-amaroK-name] == 'void-engine' and [X-KDE-amaroK-rank] > 0

amarok: [PluginManager] Trying to load: libamarok_void-engine_plugin

amarok:

amarok: PluginManager Service Info:

amarok: ---------------------------

amarok: name : 

amarok: library : libamarok_void-engine_plugin

amarok: desktopEntryPath : amarok_void-engine_plugin.desktop

amarok: X-KDE-amaroK-plugintype : engine

amarok: X-KDE-amaroK-name : void-engine

amarok: X-KDE-amaroK-authors : (Max Howell,Mark Kretschmann)

amarok: X-KDE-amaroK-rank : 1

amarok: X-KDE-amaroK-version : 1

amarok: X-KDE-amaroK-framework-version: 3

amarok:

[amaroK loader] timed out trying to contact amaroK. 

[amaroK loader] exiting.

(Czarno to widzę...) #2

Nie bawiłeś się przypadkiem ustawieniami i namieszałeś z silnikiem?

Spróbuj usunąć/zmienić nazwę katalogu /home/Ty/.kde/apps/ amarok i uruchomić program ponownie. Którą masz wersję?


(Centrumopowiastek) #3

Nie.

Folder amaroka znalazłem tylko w usr/share/apps. Może być? :wink:

Wersja 1.1


(Czarno to widzę...) #4

Nie. Chodziło mi o ukryty (stąd ta kropeczka w nazwie) folder preferencji w Twoim katalogu domowym.

Wpisz rm -R ~/.kde/share/apps/amarok, żeby usunąć ten folder.

Zainteresuj się nowym wydaniem - 1.2.1:

http://amarok.kde.org/wiki/index.php/Download

Najlepiej sam sobie skompiluj ze źródeł.


(Centrumopowiastek) #5

Po usunięciu folderu amarok uruchomił się raz. Drugi już nie chciał :wink:

Próbowałem zainstalować wersję 1.2.1 z rpm'ów, ale dostałem taki komunikat:

Zostaną zainstalowane następujące 2 pakiety w celu spełnienia zależności (6 MB):

amarok-1.2-3.101mdk.i586

libmysql12-4.0.20-3.1.101mdk.i586

W porządku? (T/n) T


    ftp://rpm.pbone.net/pub/mandrake/mandrakelinux/official/updates/10.1/main_updates/./libmysql12-4.0.20-3.1.101mdk.i586.rpm

...pobieranie nie powiodło się: curl failed: exited with 19 or signal 0



...pobieranie nie powiodło się: curl: (19) Given file does not exist

instalowanie amarok-1.2-3.101mdk.i586.rpm

Instalacja nie powiodła się:

        libmysqlclient.so.12 is needed by amarok-1.2-3.101mdk

Instalacja zakończona niepowodzeniem, brakuje kilku plików:

    ftp://rpm.pbone.net/pub/mandrake/mandrakelinux/official/updates/10.1/main_updates/./libmysql12-4.0.20-3.1.101mdk.i586.rpm

Może zachodzić potrzeba aktualizacji bazy danych urpmi

Próbowałem ściągnąć z innego źródła libmysql, ale nie mogę znaleźć.


(Czarno to widzę...) #6

http://rpm.pbone.net

Ale sprawdziłem - nie mam tego pakiet ani na SuSE, ani na Slacku, a amaroK działa.

Spróbuj zainstalowac amaroKa tak: rpm -Uvh --force --nodeps amarok*.rpm


(Centrumopowiastek) #7

Dzięki, zainstalowało się, ale:

amaroK: [Loader] Starting amarokapp..

amaroK: [Loader] Don't run gdb, valgrind, etc. against this binary! Use amarokap p.

amarokapp: error while loading shared libraries: libmysqlclient.so.12: cannot op en shared object file: No such file or directory

...chyba będe musiał zainstalować libmysqlclient.so.12.

Właśnie przecież stamtąd nie mógł ściągnąć...


(Czarno to widzę...) #8

Otwórz tę stronę i wpisz libmysql w szukajce. Ściągnij pakiet i zainstaluj ręcznie rpm -ivh libmysql*.rpm.


(Centrumopowiastek) #9

Znalazł tylko php432-devel-4.3.8-3mdk.i586.rpm, które ma z 20 zależności...


(Czarno to widzę...) #10

Nie skracam linka, żebyć wiedział skąd to jest:

ftp://ftp.icm.edu.pl/vol/rzm/linux-mand ... k.i586.rpm


(Centrumopowiastek) #11

Bardzo dziękuje!