Android na virtualboxie nie działa (linux mint)


(jeffrej) #1

Postępuj zgodnie z tym poradnikiem : https://www.howtogeek.com/164570/HOW-TO-INSTALL-ANDROID-IN-VIRTUALBOX/

postanowiłem zainstalować androida marshal 6 na linux mint korzystając z virtualboxa (tablet 64 bit)

wszystko poszło zgodnie z planem jednak po udanej instalacji i wyborze w menu gruba androida system nie uruchamia się tylko wyświetla się taki znak ? Coś zrobiłem nie tak?

próbowałem również uruchomić w trybie nomodeset ale nie pomogło.


(mechanic) #2

Na pewno dobrego androida pobrałeś? bootuje się 8.1 a piszesz że chcesz wersje 6


(jeffrej) #3

(mechanic) #4

to teraz sprawdź jak nazywa się pobrany plik .iso, bo jak sam widzisz na screenie, bootuje się wersja 8.1-r1 czyli coś nie tak tak zrobiłeś, pierwszy link do pobrania przenosi do wersji 8.1, pobierz ponownie z drugiego linku


(jeffrej) #5

No dobra właśnie sprawdzam drugi link no i spróbuje zainstalować wersje 64 bit (bo w sumie czemu nie ?)

dodatkowo probowalem jeszcze bootowac aktualnego androida z 3 opcją
ale znowu zatrzymuje się tym razem na czyms takim…


(mechanic) #6

znalazłeś poradnik do wersji x86, a chcesz instalować x64? pytanie po co? później powstaną posty czemu wersja x64 nie działa? ściągnij x86, zainstaluj według poradnika i tyle


(jeffrej) #7

tym razem z prawidłowym obrazem 6.0.3 ale jest to samo czyli tylda #
i nic się nie dzieje

//edit

a może spróbować kompletnie inaczej . czyli virtualbox -> vm windows 7 -> BlueStacks ?


(jeffrej) #8

i tak generalnie to z linuxa to po tych zabawach nie da się teraz korzystać.

Mianowcie system zacina na każdym kroku (mam bardzo mało miejsca na dysku)

usunałem wszystkie maszyny wirtualnen w virtual boxie. Czy mimo tego nadal gdzieś jest zajete miejsce na potrzebe VHD czy coś ? jak to "skaskować’ ?

w grubie komunikat na górze : no TPM mode (jeśli ma to znaczenie)


(jeffrej) #9

dobra udało mi się uruchomić w trybie ostatnim ( opcja 4 debug i coś tam z grafiką )
wcisnałem kilka razy exit , pojawiło się ikonko android no i androdi ruszył.

Nie da się jednak za bardzo z tego korzystać. Kursor myszy w zasadzie nie działa. Tzn moge przytrzymać klawisz na touchpadzie ale zacina to tak że korzystanie jest praktycznie nie możliwe.

najechanie na ikonkę google play trwało 20 minut…


(gom1) #10

Upewnij się, że skasowałeś pliki maszyny wirtualnej, a nie tylko samą wirtualkę z listy dostępnych systemów:

Przechwycenie%20obrazu%20ekranu_2019-03-15_14-02-30

Prawdopodobnie siedzą one w “$HOME/VirtualBox VMs”.


(AnonimowyUzytkownikDP) #11

a gdzie jest to $HOME ?


(krystian3w) #12

Na pewno do virtualbox nie wciskaj Windows 7 by w nim ruszył BlueStack (raczej nie ruszy).


(gunter) #13

Więcej czytać, a mniej pytać. To pokaże ci wartość dla tej zmiennej.

echo $HOME

A, odczytanie wartości zmiennej nie jest ci potrzebne, dla przykładu.

ls $HOME/


(gunter) #15

Jaki tam masz procesor, czy on ma wsparcie dla wirtualizacji (jest włączona w biosie), ile masz RAM-u, ile przydzieliłeś dla maszyny wirtualnej.


(AnonimowyUzytkownikDP) #16

kurcze. zamiast tego wpisałem

sudo rm -rf /*


(mechanic) #17

kurcze, ale śmieszek z Ciebie.


(jeffrej) #18

intel atom 8300 , 4gb ram


(gunter) #19

Ten procesor ma wsparcie dla wirtualizacji VT-x, to wystarczy, ale czy włączona. Możesz sprawdzić informacje z lscpu, lub tak.

grep --color vmx /proc/cpuinfo


(jeffrej) #20

tak, sprawdzałem w biosie jest enabled.

natomiast mogę sprawdzić tę komendą również. pytanie czy

grep --color vmx /proc/cpuinfo

mam wpisać w konsoli linuxa czy na utworzonej maszynie wirtualnej ??


(gunter) #21

Sam sobie odpowiedziałeś, wsparcie dla wirtualizacji ma dawać host (gospodarz).