Animacje flash spowalniają komputer w każdej przeglądarce


(Morietto) #1

Mam następujący problem..Mój komputer baardzo zwalnia przy wyświetlaniu stron www z animacjami flash..próbowałem lżejszych środowisk (xfce, window maker fluxbox) i jest tak samo..próbowałem różnych przeglądarek (mozilla, epiphany, konqueror).. i zawsze tak jest że po wyświetleniu strony wiatraki zaczynają wariować a komputer zwalnia:/ co ciekawe w windowsie jest tak samo..co dziwne przy włączonych podstawowych efektach flash robi slajdy..mimo że sam compiz chodzi mi na luzach i nie spowalnia komputera...mój kolega mówił że miał podobną sytuacje i zacytuję go

mam się zaczynać bać?? wie ktoś co to może być i jak można rozwiązać ten problem?? on już ma miejsce dość dłuugi czas..może to wina brudu komputera?? nie czyściłem od nowości xD (ma 16 miesięcy) ale pod obudową jest w miarę czysto.. a może w biosie coś przestawić?? hmm..


(Maciek741992) #2

Zainstalowałeś stery do grafiki(firmowe of corse- tzw. "zamknięte")?

Jaki zegar?


(Morietto) #3

na windowsie mam firmowe.. na linuxie otwarte..ale np compiz chodzi jak talala..


(matiit) #4

Sprawdź ile procka zużywa system przy odtwarzaniu flashów i jak to się ma do średniego zużycia procesora.


(Morietto) #5

hmm.. mój procesor super jakiś nie jest (celeron D 3,20 ghz) ale flash nie powinien go męczyć.. przy wyświetlaniu tej strony zużycie skacze od 55% do 70.. do wyświetlania tylko i wyłącznie strony tego forum teraz.. przy przewijaniu góra dół lub szybkim pisaniu utrzymuje sie od 69 do 86 %.. a gdy odpalam np portal nuta.pl to skacze do od 86 do 99% po chwili bezczynności zaczyna się wachac i skakać w przedziale od 60% do 90 % przy przewijaniu strony znowu skacze na 99% i grafika reklam flashowych się rozjeżdża po cały ekranie.......


sprawdziłem zużycie procka na stronie startowej przeglądarki(ubuntu) i zużycie waha się od 3 do 10%


(Fisiu) #6

Jaka wersja flash?


(Morietto) #7

w obu przypadkach chyba najnowsza..bo na linuxie instalowałem miesiąc temu (z paczki tar ) a na windzie z 2 tygodnie temu... więc raczej najnowsza..


(Fisiu) #8

A dlaczego ręcznie instalowałeś? Zapewne flash jest w repozytoriach dla Twojej dystrybucji. Czasem nawet w kilku wersjach, może warto je wypróbować?


(Morietto) #9

ale jakie to ma znaczenie? przy instalacji nie było żadnych błędów..tutaj najprawdopodobniej coś w biosie nie gra chyba..albo komputer pada.. tak mi się wydaje.. tylko że on nie jest stary...i siadać nie powinien..


(Carooxx) #10

Może mieć znaczenie, może po prostu ta wersja Flasha źle współpracuje z kartą graficzną itp.

Może spróbował być zainstalować Gnash'a?


(Morietto) #11

karta to radeon 9250..wiem rewelacja to nie jest ale..flash... gnasha próbowałem i deformowało mi animacje...były w złych wymiarach itd...

ale to co piszesz jest jak na razie najbardziej prawdopodobną możliwą przyczyną...


(Fisiu) #12

No tak... Radeon na pokładzie...

Na lapku też mam radeona, i wykorzystanie procesora przy stronach z flashem jest równie zastanawiające...

Ja bym tutaj raczej podejrzewał, że coś jest nie teges ze sterownikami do karty graficznej... choć sam flash wydany przez Adobe na platformę linuksową też specjalnie dopracowany nie jest...

Mówiąc o sterownikach, nie mam na myśli ich nie/poprawnej instalacji/konfiguracji. Chodzi o to, że sterownik sam w sobie jest niezbyt przyjaźnie nastawiony do flasha... sądząc po wykorzystaniu procesora, można by stwierdzić, że to właśnie on jest utylizowany podczas wyświetlania animacji flash. A powinna chyba wtedy pracować karta graficzna (GPU)...

Jednak nie mam pojęcia, czy moje przypuszczenia mają jakąkolwiek podstawę... Jeśli ktoś jest bardziej zoorientowany w temacie, to proszę o wypowiedzenie się w tej sprawie.

Z kolei na desktopie nie zauważyłem takiej zbieżności... no ale tutaj już pracuje NVidia...


(Morietto) #13

Fisiu możliwe..ale wtedy stery od radeona na windzie też mogą być konfliktowe z flashem.. hmm.. nie przypominam sobie żeby winda muliła przy flashu bez firmowych sterowników...teraz (od 2 dni) mam bete ubuntu więc zostanę przy flashu.. a w wersji finalnej spróbuję gnasha..może już go bardziej dopracowali..

w razie czego pisze: kłopot nie pojawił się od zainstalowania bety ubuntu (8.10) był już znacznie wcześniej..

Fisiu mnie też dziwi że grafika obciąża procka.. powinna kartę.. nie zmula compiza...ale ciekawe jest też to że gdy włącze compiza filmy np. z youtuba slajdują...przy odtwarzaniu flv na np. totemie tego kłopotu nie ma...:confused: tylko na przeglądarce...


(Fisiu) #14

Sterownik do radeona na platformę Windows działa raczej bez zarzutu. Podejrzewam tylko ten linuksowy, zarówno fglrx jak i radeon...

Jeśli przeglądasz strony www z flashem, to za wyświetlanie animacji odpowiada właśnie ta wtyczka - flash-plugin. Natomiast jak włączysz pobrany plik *.flv i oglądasz w video-playerze (mplayer, totem, kaffeine, vlc), to wówczas kodeki zainstalowane w systemie odpowiadają za obraz. W takiej sytuacji wszystko działa poprawnie....