ANTERGOS - porady, pytania, rozwiązania


#1

Zainstalowałem Antergos i nie działą drukowanie. Sterowniki do Samsung M2022W wgrałem te same co do Ubuntu i wywala error internal CUPS serwera. Co z tym zrobić, żeby drukarka działąła, żeby ten serwer CUPS działał cały czas?? Znalazłem różne poradniki jak uruchomić CUPS, ale to nic nie daje wpisując w Terminalu. Pomózcie.


#2

Drukarke print PDF zainstalował, a Samsunga M2022W nie chce mimo wgrania sterownikóœ przez Terminal tych samych co dla Ubuntu. Zrzut ekranu:


#3

Co to znaczy, że w Antergosie wgrałeś sterowniki te same co w Ubuntu? W jaki sposób?
W AUR masz samsung-unified-driver, który prawdopodobnie obsługuje także tę drukarkę. Instalacja w różny sposób. Antergos - o ile pamiętam - instaluje yaourt, zatem wykorzystaj go do instalacji. Nadto - jest tam chyba pamac lub octopi, które również pozwalają zainstalować z AUR.
Musisz mieć podniesioną usługę cups i skonfigurować drukarkę np. w przeglądarce podając adres: http://localhost:631


(cyanoone) #4

Trzeciej opcji od góry bym spróbował :slight_smile:


#5

Paczka samsung-unified-driver-printer zawiera sterownik “Samsung M2020 Series” który wydaje się być właściwy dla tej drukarki. Ten sam (chyba) sterownik zawiera też paczka samsung-printers (6 od góry).
Dawniej jedna z nich zawierała również jakieś GUI do obsługi drukarek Samsunga, ale teraz już chyba nie (nie wygląda, by zawierała).

Pomiędzy obu paczkami są - jak się wydaje - pewne drobne różnice, choć sam sterownik (plik ppd) wydaje się być taki sam w obu wersjach. Można zatem zainstalować albo samsung-unified-driver-printer albo samsung-printers i w razie problemów, odinstalować a zainstalować drugą. Póżniejsza konfiguracja w zależności od środowiska lub w przeglądarce wpisując wcześniej podany adres.

Jeżeli wgrałeś “te same sterowniki co w Ubuntu” - cokolwiek by to nie znaczyło, to powinieneś raczej je odinstalować, albowiem paczki dla Ubuntu a dla Archa są odmienne.

Przed instalacją musi być podniesiona i uruchomiona usługa CUPS (zdaje się, że jest, ale nie zawadzi):
sudo systemctl enable org.cups.cupsd.service
sudo systemctl start org.cups.cupsd.service

Aha, skoro to drukarka z W w nazwie, to jest z nią możliwość połączenia po sieci bezprzewodowej. Sprawdź, czy jest widoczna. Jeśli nie - to mogą być niezbędne pewne zmiany w avahi (zob.: https://wiki.archlinux.org/index.php/CUPS#Network i https://wiki.archlinux.org/index.php/CUPS#Network_2)


#6

Zostaję na Ubuntu bo wszystko działa i nie trzeba się aż tak wczuwać i kombinować, żeby drukarka działała.