Apache i MySQL w XAMPP nie działa WIN7 64bit


(Flakadrian) #1

Witam! Mam problem z XAMPP w Windows 7 HomePremium 64bit, po instalacji wszystko działało klika dni później przestał działać apache i mysql. Nie mam SKYPE, mam utorrent, nod32, aqq, dumeter, vmware. Zainstalowany na dysku bez systemu. Gdy włączam XAMPP dostaje komunikat: Current directory D:\xampp, Run this program only from your XAMPP root directory. Czy ma to jakiś związek, że apache i mysql nie działa ? że nie jest na dysku admina? gdy naciskam start dostaje komunikat : Busy... Apache started [Port 80], Busy... MySql started [Port 3306] ,dodaje że IIS mam wyłączone.

Bardzo proszę o pomoc..


(ra-v) #2

No można że sam mam podobny problem z tym że na Win XP 64b. U mnie chyba tego nie zauważyłem "Current directory D:\xampp, Run this program only from your XAMPP root directory", ale mam problem z Apachem - dostaję komunikat "Busy... Apache started [Port 80]", natomiast MySQL działa. IIS miałem włączone i wyłączone - bez różnicy (nawet nie wiem co to jest). Też nie wiem gdzie jest problem.

U mnie to występuje od początku, we firewall jest wszystko dobrze ustawione.


(djgrzenio) #3

system blokuje port 80. :slight_smile:

zmien w /xampp/apache/conf/httpd.conf

Listen [::]:80 <- cos takiego lub podobnego zakomentuj

Listen 8080 <- to dodaj

i wtedy odnos sie do localhost(lub adres):8080


(mktos) #4

Jeżeli Apache nie startuje, bo port jest zajęty to albo można zmienić port na inny, albo za pomocą polecenia

netstat -abno

da się zobaczyć jakie aplikacje i o jakich PID używają danego portu. Trzeba wyśledzić co używa portu 80 (LISTENING na 0.0.0.0:80 albo np. [::]:80), dowiedzieć się co to może być i wyłączyć.

Parę miesięcy temu znalazłem, że gdy IIS jest wyłączony to i tak jakaś usługa Microsoftu (powiązana z Zune o ile pamiętam) zajmuje sobie port 80 - dla startującego IIS go zwalnia, a dla Apache już nie.


(suchjy) #5

zabij w menedżerze urządzen procesy od skype np skype.core , ktory tam wisi


(Robneo) #6

Co Wy ludzie widzicie w tym xamppie zarówno na linuxie jak i na windzie.Szczerze powiem ,że prościej jest

zamontować phpmyadmin na linuxie z repozytorium.Wszystko działa bezproblemowo i nie ma problemów.

Co do windowsa to może działa to lepiej ale i tak zdarzają się problemy jak nie z portem to z czym innym.

Sam korzystam z lina i wszystko śmiga mi bez problemu.Z windowsa tez korzystam ale tylko w pracy.Pozdro.