Apache2 nie wymaga rozszerzeń w plikach .php do otworzenia


(pain3hp) #1

Apache nie wymaga mi rozszerzeń podawania plików w przeglądarce tzn zalozmy jest plik.php to jak wejdę http://localhost/plik nie chciałbym aby tak było, gdzie mogę to zmienić?

  1. Również nie chciałbym żeby przegladarka otwierała foldery i pokazywala pliki w nich bo teraz jak wlacze folder bez index.php/html to wyswietla ona wszystkie pliki w tym folderze zamiast komunikat "nie ma takiej strony"

czyli zalozmy mam w public_html folder "sklep" a wnim kilka plikow ale nie ma pliku index i jak wejdę w localhost/sklep to przegladarka pokazuje te wszystkie pliki... Gdzie mogę to zmienić?

DZIEKI Z GORY


(Drobok) #2

Usuń z cfg apache

Options Indexes FollowSymLinks

AllowOverride None

Co do rozszerzenia, to nie masz przypadkiem w htaccess ustawionego rewrite na rozszerzenie php ?


(pain3hp) #3

Zrobiłem tak w pliku /etc/apache2/sites-available/default bo tylko w nim znalazłem kod który podałeś jednak to nie działa, chyba że źle to zrobiłem, jeśli możesz podaj dokładnie ten plik. dzieki

ServerAdmin webmaster@localhost


	DocumentRoot /var/www

#	

# Options FollowSymLinks

# AllowOverride None

#	


		Options Indexes FollowSymLinks MultiViews

		AllowOverride None

		Order allow,deny

		allow from all



	ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/


		AllowOverride None

		Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch

		Order allow,deny

		Allow from all



	ErrorLog ${APACHE_LOG_DIR}/error.log


	# Possible values include: debug, info, notice, warn, error, crit,

	# alert, emerg.

	LogLevel warn


	CustomLog ${APACHE_LOG_DIR}/access.log combined


    Alias /doc/ "/usr/share/doc/"


        Options Indexes MultiViews FollowSymLinks

        AllowOverride None

        Order deny,allow

        Deny from all

        Allow from 127.0.0.0/255.0.0.0 ::1/128

-- Dodane 21.08.2011 (N) 21:46 --

zrobiłem restart apacha


(roobal) #4

Jakie masz uprawnienia do katalogu? Pokaż wynik polecenia

ls -l ~/public_html/

Pozdrawiam!