Arch (Antergos) po wczorajszej aktualizacji zatrzymuje uruchamianie się na czarnym ekranie konsoli

Logi jakie widać na czarnym ekranie (Nie wiem czy te logi mają z tym coś wspólnego.):
do_IRQ: 0.55 No irq handler for vector
Spectre V2 : Spectre mitigation: LFENCE not serializing, wsitching to generic retpoline

Konsola mruga co kilka sekund. Czekałem nawet długi i nic się nie dzieje.

Wczoraj robiłem aktualizację, dzisiaj z tty2 zrobiłem również aktualizację więc system jest w najnowszej wersji.

Skąd odczytać jakieś przydatne logi, żeby wiedzieć w czym problem?

A nie masz jakiegoś problemu ze sterownikiem?
To tylko sugestia.

Do tej pory nie miałem żadnych problemów. Z rok-dwa lata mam ten system.

Czytałem że po aktualizacji Xorga są jakieś problemy ze sterownikiem nvidii link.

Mam sterowniki nvidii. To co mam zrobić? te 20-flags.conf utworzyć i wpisać tam tę treść?
Ustawilem to i teraz pojawiają się dodatkowe logi z systemd ale klawiatura sie zacina(?) że nawet uruchomić ponownie nie mogę. Muszę przyciskiem.

Tak. Potem zrestartuj komputer.

To tam się coś mieli w tym czasie i potem zacznei działać? Ile mniej wiecej potrwa?
Też to robiłeś?
Na noc zostawić kompa czy szybciej? xD

Ale co ma mielić? Nie powinno nic mielić. Wprowadziłeś zmiany do konfiguracji serwera X to zrestartuj komputer i tyle.

Ja nic nie robiłem, bo mojej wersji sterowników i karty ten problem nie dotyczy … do czasu :smiley:

Ale u mnie się coś mieli (już po dodaniu pliku i włączeniu ponownie systemu), ekran robi się całkiem czarn i po chwili zapala i tak w kółko. (jak usunę ten plik to się po prostu zatrzymuje ale da się klawiaturą restartować, przełączyć na inne tty itd.)

No to skoro nie działa to jedynym wyjściem jest usunięcie tego pliku i obniżenie wersji xorg-server oraz
xorg-server-common. Potem trzeba czekać na poprawkę od Nvidii … o ile będzie.

Jak nie masz programu downgrade to dodaj repozytorium archlinux.fr do /etc/pacman.conf i zainstaluj,
a potem obniżaj wersję:

[archlinuxfr]
SigLevel = Never
Server = http://repo.archlinux.fr/$arch

PS
Przez ten pseudo wysiwyg można na łeb dostać …

2lajki

No i to pomogło. Dzięki. :slight_smile:

Chciałem się zapytać jak to z tym Xorg ma się do innych sterowników GPU.
Komentarze link to nie było dobre miejsce.
Za odpowiedź Dziękuje :laughing:.

Zaktualizuję, że jest dostępne trochę mniej nieoficjalne rozwiązanie - trzeba zainstalować paczkę nvidia-340xx-dkms z AUR ale wsparcie tylko do końca roku lub użyć sterowników Nouveau.

https://wiki.archlinux.org/index.php/NVIDIA#Unsupported_drivers

If you have a GeForce 300 series card or older (released in 2010 or earlier), Nvidia no longer supports drivers for your card. This means that these drivers do not support the current Xorg version. It thus might be easier if you use the Nouveau driver, which supports the old cards with the current Xorg.

However, Nvidia’s legacy drivers are still available and might provide better 3D performance/stability if you are willing to downgrade Xorg:

  • For GeForce 8/9, ION and 100-300 series cards [NV5x, NV8x, NV9x and NVAx], install the nvidia-340xx-dkmsAUR package. (supports the latest Xorg but has issues with Linux 5.0+)