[Arch] Bardzo powolne działanie efektów pulpitu


(144 Kuba) #1

Nie dam rady zmusić Archa do uruchomienia Compiza. DE które zainstalowałem to XFCE. Zarówno na zamkniętych sterownikach od nVidii jak i na Noveau, które zainstalowałem Compiz nie chce współpracować.

Po wydaniu komeny: compiz --replace komputer zawiesza się na jakąś minutę po czym mogę już operować między oknami tylko, że nie ma żadnych śladów aktywacji poza tym, że tracę wszystkie skróty, klawiszowe, tracę dekorację, nie mogę przenosić okien. xcompmrg też nie pokazuje cienii.

Tracę pomysły już i zastanawiam się czy wybrałem na pewno dobrą dystrybucje...


(nintyfan) #2
compiz ccp --replace

(144 Kuba) #3

Niesamowite o.0

Na jakiej podstawie to działa? Co w ogóle robi te polecenie?

Dziękuję serdecznie


(nintyfan) #4

ccp to plugin konfiguracji Gnoma(nie wiem czy gnome-config czy gsettings).


(144 Kuba) #5

No i się nacieszyłem. Compiz działa fajnie ale na Nouveau (otwartych sterownikach) na których nawet Teeworlds nie śmiga na 100% (a powinno). Po instalacji sterowników od nVidii przełączanie pulpitu trwa ok minutę :stuck_out_tongue: tutaj mój xorg

# nvidia-xconfig: X configuration file generated by nvidia-xconfig

# nvidia-xconfig: version 295.40 (buildmeister@swio-display-x86-rhel47-04.nvidia.com) Thu Apr 5 22:33:07 PDT 2012



Section "ServerLayout"

    Identifier "Default Layout"

    Screen "Default Screen" 0 0

    InputDevice "Keyboard0" "CoreKeyboard"

    InputDevice "Mouse0" "CorePointer"

EndSection


Section "InputDevice"


    # generated from default

    Identifier "Keyboard0"

    Driver "keyboard"

EndSection


Section "InputDevice"


    # generated from default

    Identifier "Mouse0"

    Driver "mouse"

    Option "Protocol" "auto"

    Option "Device" "/dev/psaux"

    Option "Emulate3Buttons" "no"

    Option "ZAxisMapping" "4 5"

EndSection


Section "Monitor"

    Identifier "Monitor0"

    VendorName "Unknown"

    ModelName "Unknown"

    HorizSync 28.0 - 33.0

    VertRefresh 43.0 - 72.0

    Option "DPMS"

EndSection


Section "Device"

    Identifier "n"

    Driver "nvidia"

EndSection


Section "Screen"

    Identifier "Default Screen"

    Device "n"

    Monitor "Monitor0"

    Option "AllowGLXWithComposite" "True"

    Option "RenderAccel" "True"

    Option "AddARGBGLXVisuals" "True"

    SubSection "Display"

        Modes "nvidia-auto-select"

    EndSubSection

EndSection


Section "Extensions"

    Option "Composite" "Enable"

EndSection

(ra-v) #6

Czy ty aby na pewno te sterowniki zaciągnąłeś. Czasem pomaga zainstalowanie starszych.

Mi z kolei Nouveau nigdy efekty nie chodziły albo w ogóle system nie chodził.


(144 Kuba) #7
[kuba@arch-desktop ~]$ pacman -Q | grep nvidia

nvidia 295.40-3

nvidia-utils 295.40-1

Hm, to chyba oznacza, że są zainstalowane. Powoli zaczyna mnie to denerwować, sam nie wiem gdzie leży przyczyna.

glxears:

71742 frames in 5.0 seconds = 14348.293 FPS

i na fullscreenie

10085 frames in 5.0 seconds = 2016.928 FPS

To chyba jest tak jak trzeba ale z kolei Teeworlds (po prostu przykładowa gra 2D) nie chodzi w ogóle (jest ekran ładowania i na tym staje zawieszając cały komp).


(marcin82) #8

Niekoniecznie, podaj wynik:

lspci -k | grep -A3 VGA

(144 Kuba) #9

Wynik to:

[kuba@arch-desktop ~]$ lspci -k | grep -A3 VGA

02:00.0 VGA compatible controller: NVIDIA Corporation G80 [GeForce 8800 GTS] (rev a2)

	Subsystem: NVIDIA Corporation Device 0420

	Kernel driver in use: nvidia

edit: pomogła instalacja najnowszych sterowników beta z AURa (dzisiaj wyszła aktualizacja)