Arch - brak dźwięku, brak urządzeń audio


(Henio Mazurek) #1

Witam. Nie przedłużając - Arch - świeżo po instalacji - brak dźwięku. Na Archu siedzę niecałe dwa lata i nigdy nie było problemu. Mam dwie karty dźwiękowe - jedna zintegrowana i druga - SoundBlaster 4832 (ta karta ma działać). Kartę dokładałem pół roku temu (karta sprawna). Środowisko - Gnome3. W ustawieniach dźwięku nie widać żadnych urządzeń audio. Brak jest ikonki regulacji dźwięku na panelu Gnome, co ciekawe w momencie logowania jest (speaker-test na koncie użytkownika jak i roota produkuje ciszę).

Alsa wykrywa kartę. Wyjścia Master i PCM nie są wyciszone.

Wynik lspci

00:00.0 Host bridge: Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller (rev 02)

00:01.0 PCI bridge: Intel Corporation 82G33/G31/P35/P31 Express PCI Express Root Port (rev 02)

00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 01)

00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 01)

00:1c.1 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 2 (rev 01)

00:1d.0 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 (rev 01)

00:1d.1 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 01)

00:1d.2 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 01)

00:1d.3 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 01)

00:1d.7 USB controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 01)

00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)

00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)

00:1f.2 IDE interface: Intel Corporation N10/ICH7 Family SATA Controller [IDE mode] (rev 01)

00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 01)

01:00.0 VGA compatible controller: NVIDIA Corporation G92 [GeForce GTS 250] (rev a2)

03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)

04:01.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 08)

04:01.1 Input device controller: Creative Labs SB Live! Game Port (rev 08)

lsmod

snd_emu10k1 121673 0 

snd_rawmidi 15014 1 snd_emu10k1

snd_ac97_codec 90085 1 snd_emu10k1

snd_hda_codec_realtek 150550 1 

snd_seq_device 4284 2 snd_rawmidi,snd_emu10k1

snd_util_mem 1836 1 snd_emu10k1

snd_hda_intel 20114 0 

snd_hda_codec 76147 2 snd_hda_intel,snd_hda_codec_realtek

snd_pcm 60595 4 snd_hda_codec,snd_hda_intel,snd_ac97_codec,snd_emu10k1

snd_timer 15438 2 snd_pcm,snd_emu10k1

snd_hwdep 4942 2 snd_hda_codec,snd_emu10k1

snd 44501 10 snd_hwdep,snd_timer,snd_pcm,snd_hda_codec,snd_hda_intel,snd_seq_device,snd_hda_codec_realtek,snd_ac97_codec,snd_rawmidi,snd_emu10k1

snd_page_alloc 5869 3 snd_pcm,snd_hda_intel,snd_emu10k1

groups 'użytkownik'

lp games video audio optical storage scanner power camera users

rc.conf

#

# HOSTNAME: Hostname of machine. Should also be put in /etc/hosts

#

HOSTNAME="myhost"


# Use 'ip addr' or 'ls /sys/class/net/' to see all available interfaces.

#

# Wired network setup

# - interface: name of device (required)

# - address: IP address (leave blank for DHCP)

# - netmask: subnet mask (ignored for DHCP) (optional, defaults to 255.255.255.0)

# - broadcast: broadcast address (ignored for DHCP) (optional)

# - gateway: default route (ignored for DHCP)

# 

# Static IP example

# interface=eth0

# address=192.168.0.2

# netmask=255.255.255.0

# broadcast=192.168.0.255

# gateway=192.168.0.1

#

# DHCP example

# interface=eth0

# address=

# netmask=

# gateway=


interface=eth0

address=

netmask=

broadcast=

gateway=


# Setting this to "yes" will skip network shutdown.

# This is required if your root device is on NFS.

NETWORK_PERSIST="no"


# Enable these netcfg profiles at boot-up. These are useful if you happen to

# need more advanced network features than the simple network service

# supports, such as multiple network configurations (ie, laptop users)

# - set to 'menu' to present a menu during boot-up (dialog package required)

# - prefix an entry with a ! to disable it

#

# Network profiles are found in /etc/network.d

#

# This requires the netcfg package

#

#NETWORKS=(main)


# -----------------------------------------------------------------------

# DAEMONS

# -----------------------------------------------------------------------

#

# Daemons to start at boot-up (in this order)

# - prefix a daemon with a ! to disable it

# - prefix a daemon with a @ to start it up in the background

#

# If something other takes care of your hardware clock (ntpd, dual-boot...)

# you should disable 'hwclock' here.

#

DAEMONS=(gdm dbus hwclock syslog-ng network netfs crond alsa)

Jedyną zmianą w stosunku do stanu sprzed awarii jest to, że katalog użytkownika jest na partycji ntfs, ale to chyba nie powinno mieć wpływu na dźwięk.

Może coś przeoczyłem, ale nie mam pojęcia co.


(moongoose) #2

Witam

Poczytaj to

http://www.centrum24.org/ogolnie-linux/150-multimedia/412-konfiguracja-alsy-arch-linux.html

i to

http://umara.furud.net/index.php/linux/117-linux-i-dwie-karty-muzyczne

Może znajdzie się rozwiązanie

Pozdrawiam


(Henio Mazurek) #3

Sprawdziłem powyższe linki i niestety nie znalazłem rozwiązania.

Zainstalowałem kde - dźwięk działa. Po przelogowaniu na gnome nie działa.

Tak więc winne jest środowisko gnome3.

Jak uzyskać dźwięk w gnome?


(Jakub Cichon) #4

Sprawdź czy masz zainstalowany pakiet alsa-base (choć teoretycznie powinien być on instalowany wraz z alsa).

Poza tym checknij czy przypadkiem nie masz równocześnie zainstalowanych alsa i pulseaudio. Jeśli tak, spróbuj w konsoli wpisać polecenie:

$ pulseaudio --kill

lub

$ killall pulseaudio

jeśli po tym dźwięk się pojawi, masz rozwiązanie problemu.