Arch - Dota 2(wine), hibernacja, cpufreq, nautilus mount iso


(Vatri91) #1

Witam. Przesiadłem się właśnie z Ubuntu na Archa. Jestem pozytywnie zaskoczony działaniem całego. System działa o wiele stabilniej niż Ubuntu i nie mam problemu ze sprzętem.

1) Głównym powodem przesiadki na archa były przestarzałe stery od nvidii, a nvidia-experimental nie chciał współpracować z bumblebee. Mam problem z wine, bo nie mogę za nic świecie odpalić Doty, ani Torchlighta 2. Na ubuntu nie miałem z tym problemu. Dota 2 zawiesza się przy odpaleniu. Nie ważne czy korzystam z intela, czy z optiruna, lub primusa. Efekt jest ten sam. Bubmblebee działa chyba poprawnie, bo testowałem go z Heroes of Newearth i wszystko było ok.

2) Z trochlightem jest innym problem. Nie działa prawdopodobnie przez to, że nie da się zainstalować vc2010redist_x86.exe. Aplikacja ma platiunum na winehq, a na archu nie dało jej się zainstalować (Błąd programu i fc).

wine 1.5.25

nvdia 630m bubmlebee nvidia 313

3)Następny problem to CPU Frequency Scaling. Mam zainstalowany cpupower z rozszerzeniem CPU Freq do gnome shella. Mam tylko dwie opcje cpufreq_ondemand, cpufreq_performance. Brakuje mi cpufreq_powersave. cpupower frequency-info też podaje tylko 2 governorsy.

4)W ubuntu fajną opcją było montowanie obrazów z poziomu nautilusa.

W archu rozwiązałem to tym sposobem

https://wiki.archlinux.org/index.php/Mo ... es_as_user [wiki.archlinux.org]

ale gdy chce odmotować obraz, klikając na ikonkę dysków po lewej stronie nautilusa, to wywala błąd.

"umount /ścieżka Odmotowanie nie powiodło się: Operacja niedozwolona.

Wiecie co z tym zrobić?

5)Ostatnia pytanie. Jak aktywować możliwość hibernacji? Mam partycje swap. Laptop ma płytę główną z efi.

Będę wdzięczny za pomoc.

Ps. Mam do rozdania zaproszenia do Doty 2. Gra przynajmniej na poprzednim systemie działała ok. Chętni Pw.


(ra-v) #2
  1. Nie mam pojęcia co może być

Jedynie co do sterowników mogę się wypowiedzieć, że bierze się ze strony nvidia.com - są najlepsze.

  1. Czasem pomaga zainstalowanie innej wersji WINE , czasem wyczyszczenie ~/.wine (bezpieczniej przeniesienie), czasem skorzystanie z PlayOnLinux który dobiera wersję WINE. Z WINE jest ten problem, że coś po prostu działa albo nie działa, niezależnie od “koloru” jaki ma na wine.hq

  2. Szukaj gdzieś w pliku scaling_available_frequencies w katalogu /sys/devices/system/cpu/cpu0/cpufreq. Nie wszystkie procesory obsługują każdą politykę skalowania. Miałem przypadek nawet że na niektórych ustawieniach się przywieszał. Może to zależeć nie tyle od procka co od jądra.

  3. Musisz to robić jako root. Zwykły mount, umount działa. Możesz też używać też GUI np. AcetoneISO.

  4. Na każdym nowszym Linuxie mi się automatycznie pojawiała, wystarczyło mieć włączonego i zamontowanego swapa o większej wielkości niż pamięć RAM.


(Vatri91) #3
  1. Pliku o którym mówiłeś nie da się nawet z poziomu roota edytować o.0. Masz rację. W tym pliku tkwią opcje do skalowania procesora

  2. Zrobiłem hibernacje, ale nie wiem jak dodać opcje do dasha gnome-shella. Zainstalowałem alternatywne menu, ale w nim też nie ma tej opcji.

Na razie działa

$ systemctl suspend

$ systemctl hibernate

  1. [solvet]Zainstalowałem sterowniki bubmblebee od nowa i ruszyło

  2. Zainstalowałem msxml3 i vcrun zainstalowało się, ale gra dalej nie odpala. Taki błąd otrzymuje

http://img837.imageshack.us/img837/2113 … 314102.png [img837.imageshack.us]

  1. Pojawił się u mnie kolejny problem. Natywny steam nie działa poprawnie. Pomomo, że używam primusa, to gry działają z 1-2 fpsami. Mowa to o ss3 i bastionie.

(ra-v) #4

Wg mnie 6. ma związek z 1. - Jak coś nie chodziło instalowałem z www.nvidia.com - http://www.youtube.com/watch?v=POVqUhto5EM. Tak też robiłem na Fedorze i zawsze było ok.

  1. ja odpalam przez polecenie wine /sciezka/do/programu/exe

(Vatri91) #5
  1. Dodałem moduł powersave do autostartu jądra i wszystko jest ok.

  2. Edycja gruba i kompilacja schematu alternatywnego statusu menu pomogła

  3. Zainstalowałem sterowniki bubmblebee od nowa i ruszyło

  4. Zrobiłem skrypt oparty o umount.

  5. Zainstalowałem msxml3 i vcrun zainstalowało się, ale gra dalej nie odpala. Taki błąd otrzymuje

http://img837.imageshack.us/img837/2113 … 314102.png [img837.imageshack.us]

  1. Wole nie instalować innych sterowników, niż te dołączone z bumblebee. Według wiki archa istalacja zwykłych sterów może zrobić burdel w systemie. Sterowniki są i tak najnowsze

    sudo pacman -Qs nvidia

    [sudo] password for adrian:

    local/bumblebee 3.1-2

     Bumblebee brings Optimus Support for Linux Through VirtualGL. You need to
    
     install proper drivers separately. Can be used with Nouveau or Nvidia
    

    local/lib32-nvidia-utils-bumblebee 313.26-1

     NVIDIA drivers utilities and libraries (32-bit). Repacked and installed in
    
     away that won't break LibGL from mesa.
    

    local/libvdpau 0.6-1

     Nvidia VDPAU library
    

    local/nvidia-bumblebee 313.26-1

     NVIDIA drivers for linux. Packaged for Bumblebee
    

    local/nvidia-utils-bumblebee 313.26-1

     NVIDIA drivers utilities and libraries. With LibGL and xorg modules
    
     installed in a different directory.
    

Problem tkwi tu

http://steamcommunity.com/app/221410/di … 395110175/