Arch - nie mogę uruchomić KDE4 i KDM


(Marek77k) #1

Mam problem z uruchomieniem KDE4 w ogóle kdm nie startuje tylko przy uruchamianiu system zatrzymuje się na login. Oczywiście po wpisaniu z konsoli loginu i hasła system pod konsolą działa. Linux który posiadam to Arch który już pracuje na systemd. Wszystko co było potrzebne do systemd jest poprawnie skonfigurowane i działało nawet po aktualizacji kde 4.9.3. Mam też dodane systemctl enable kdm.service, a do wystartowania iksów potrzebny mi jest moduł i915 , który jest dodany do gruba. Jedyne co mi przychodzi na myśl to, że może muszę usunąć katalog ~.kde4 lub wprowadzić jakieś zmiany w pliku kdmrc? Skoro dmesg nie pokazuje żadnych błędów z xorg i kartą graficzną. Po tych zmianach z systemd nie wiem już nic, co gdzie szukac rozwiązania.


(linux_to_syf_^^) #2

Może wklej na czym kde się wywala? Co wyrzuca startx (o ile masz zainstalowany, jeśli nie to w archu jest chyba osobna paczka)?


(Marek77k) #3

Na tym X server. Utworzenie xorg.conf też nic nie daje.

kdm[297]: X server died during startup

kdm[297]: X server for display :0 cannot be started, session disabled

(linux_to_syf_^^) #4

Nie możesz odpalić X'ów jak człowiek z pominięciem kdm?

startx 2> co_xy_boli

I w pliku "co_xy_boli" odczytać logów ze startu X'ów?


(Marek77k) #5

Mogę tylko ze i taki wynik nie jest długi, dlatego nawet nie trzeba do pliku tego logu przenosić.

startkde

$Display not set cannot connet to the X server

Jeżeli chodzi Ci o xinitrc to nie mam tego pliku w /etc/X11/xinit/xinitrc , żeby w nim ustawić exec startkde na początku skryptu.


(linux_to_syf_^^) #6

startkde możesz odpalić jak wstaną Ci X'y. w pliku: ~/.xinitrc (ustawienia dla użytkownika)

exec startkde

i w konsoli

startx

(Marek77k) #7

Po prostu nie miałem zainstalowanej paczki od startx czyli xorg-xinit. Ponieważ korzystałem z kdm i nie była mi potrzebna. Podaję wynik startx

X.Org X Server 1.13.0

Release Date: 2012-09-05

X Protocol Version 11, Revision 0

Build Operating System: Linux 3.6.3-1-ARCH i686 

Current Operating System: Linux user 3.6.6-1-ARCH #1 SMP PREEMPT Mon Nov 5 13:14:42 CET 2012 i686

Kernel command line: root=/dev/sda3 ro i915.modeset=1 

Build Date: 08 November 2012 07:12:52PM


Current version of pixman: 0.28.0

	Before reporting problems, check http://wiki.x.org

	to make sure that you have the latest version.

Markers: (--) probed, (**) from config file, (==) default setting,

	(++) from command line, () notice, (II) informational,

	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.

(==) Log file: "/var/log/Xorg.0.log", Time: Mon Nov 12 21:46:34 2012

(==) Using config directory: "/etc/X11/xorg.conf.d"

Initializing built-in extension Generic Event Extension

Initializing built-in extension SHAPE

Initializing built-in extension MIT-SHM

Initializing built-in extension XInputExtension

Initializing built-in extension XTEST

Initializing built-in extension BIG-REQUESTS

Initializing built-in extension SYNC

Initializing built-in extension XKEYBOARD

Initializing built-in extension XC-MISC

Initializing built-in extension SECURITY

Initializing built-in extension XINERAMA

Initializing built-in extension XFIXES

Initializing built-in extension RENDER

Initializing built-in extension RANDR

Initializing built-in extension COMPOSITE

Initializing built-in extension DAMAGE

Initializing built-in extension MIT-SCREEN-SAVER

Initializing built-in extension DOUBLE-BUFFER

Initializing built-in extension RECORD

Initializing built-in extension DPMS

Initializing built-in extension X-Resource

Initializing built-in extension XVideo

Initializing built-in extension XVideo-MotionCompensation

Initializing built-in extension XFree86-VidModeExtension

Initializing built-in extension XFree86-DGA

Initializing built-in extension XFree86-DRI

Initializing built-in extension DRI2

Loading extension GLX

(II) [KMS] Kernel modesetting enabled.

(EE) 

(EE) Backtrace:

(EE) 0: /usr/bin/X (xorg_backtrace+0x49) [0x81e4999]

(EE) 1: /usr/bin/X (0x8048000+0x1a0886) [0x81e8886]

(EE) 2: linux-gate.so.1 (__kernel_rt_sigreturn+0x0) [0xb76e940c]

(EE) 3: /usr/bin/X (xf86SetScrnInfoModes+0x30c) [0x80f68dc]

(EE) 4: /usr/bin/X (xf86InitialConfiguration+0x1589) [0x80fa459]

(EE) 5: /usr/lib/xorg/modules/drivers/radeon_drv.so (0xb6fb2000+0x44cf9) [0xb6ff6cf9]

(EE) 6: /usr/lib/xorg/modules/drivers/radeon_drv.so (0xb6fb2000+0x3fe2c) [0xb6ff1e2c]

(EE) 7: /usr/bin/X (InitOutput+0xbc3) [0x80c0db3]

(EE) 8: /usr/bin/X (0x8048000+0x1f526) [0x8067526]

(EE) 9: /usr/lib/libc.so.6 (__libc_start_main+0xf5) [0xb7336605]

(EE) 10: /usr/bin/X (0x8048000+0x1faf9) [0x8067af9]

(EE) 

(EE) Segmentation fault at address 0x0


Fatal server error:

Caught signal 11 (Segmentation fault). Server aborting


(EE) 

Please consult the The X.Org Foundation support 

	 at http://wiki.x.org

 for help. 

(EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.

(EE) 

Server terminated with error (1). Closing log file.

xinit: giving up

xinit: unable to connect to X server: Connection refused

xinit: server error[/code]


Spróbuję może wyłączyć kdm

[code]systemctl disable kdm

I dopiszę do gruba znowu init=/usr/lib/systemd/systemd. Sprawdzę jeszcze czy mam zainstalowany libgl swrast_dri.so i restart.


(linux_to_syf_^^) #8

Więc to nie wina KDE ;].

Szybkie strzały przed pracą:

1) Kernel command line: root=/dev/sda3 ro i915.modeset=1

Nie masz modesettingu w kernelu na stałe?

2) /usr/lib/xorg/modules/drivers/radeon_drv.so

To radeon czy intel :wink:? Zdecyduj się.

Systemd to tylko menadżer skryptów startowych. Raczej nie pomoże na segmentation fault w X.


(Marek77k) #9

Mam grafikę hybrydową więc mam zainstalowane pakiety xf86-video-intel i xf86-video-ati. Kiedyś miałem zainstalowane catalyst ale już są odinstalowane ich skryptem deinstalacyjnym. Czyli ten wpis i915.modeset=1 od kernela 3.6.6 jest teraz niepotrzebny? Może to dlatego że używam nadal starej wersji gruba, grub 2.0 automatycznie wszystko ustawia. To mam odinstalować ten pakiet ati czy dodać moduł radeon do blacklist?

Edit.

Napisz tylko tyle. linux_to_syf^^ wielkie wielkie dzięki. Szukałem rozwiązania w systemd, kdm, kde a tu po prostu winny był zainstalowany pakiet xf86-video-ati. Po odinstalowaniu wszystko już działa jak dobrze. Nie wiem czy ostatnia aktualizacja systemu miała na to wpływ (KDE 4.9.3 ktore przecież kilka dni działało bez szwanku), jednak wcześniej te dwa pakiety z driverami nie gryzły się ze sobą. Usunąłem też te wpisy z gruba i system bez problemu wstaje. Nie będę już w to wnikał grunt że działa, ewentualnie wyłączę jeszcze w biosie tą kartę graficzną AMD Radeon. Niepotrzebnie tylko skasowałem katalog ~.KDE4 teraz musze wszystko na nowo dostosować. Dzięki jeszcze raz.


(linux_to_syf_^^) #10

Też mam 2 karty, ale nvidia/intel. Pierwszą sesję X raczej odpalasz na intelu. Więc albo wywal ati(gdy i tak nie korzystasz), albo dodaj wpis w /etx/X11/xorg.conf ustawiając grafikę na intela w sekcji device (znajdziesz łatwo przykładowe wpisy na necie) - w elinksie Ci nie przekleje :wink:. Możliwe, że po jakimś update xorg chce domyślnie korzystać z ati. U mnie na nvidii to nie przejdzie.

Co do parametru w grubie - ciężko powiedzieć. Zależy od kompilacji jajka(można modesetting na sztywno wkompilować). Jeśli polegasz na tej z archa - to zależy od widzimisie developerów. I różni ludzie, na różne problemy z tym narzekali (u mnie głównie gryzło się z buforem ramki).


(Marek77k) #11

Dokładnie jak piszesz,ale teraz nie wksazane jest żeby tworzyć plik xorg.conf. Tylko korzystać lepiej z tego co system utworzy. Pod Linuksem nie korzystam z ati, ale pod winowsem już tak. A samo korzystanie z make menuconfig w dystrybucji roling relase i kompilowanie jądra z innymi parametrami niż standardowe to się trochę nie opłaca. Zwłaszcza że bardzo szybko wprowadzają nowy kernel, no ale w sytuacjach co już nic nie pomaga to nie ma innego wyjścia.