ArchLinux - dźwięk raz jest, a raz go nie ma


(fufus) #1

Mam problem z dźwiękiem pod moim Archem, otóż raz jest, raz nie... np. wczoraj sobie spokojnie słuchałem radia zet online (przeglądarka), oglądałem filmiki na yt, a dziś już nie ma dźwięku (wcześniej też raz był, raz nie) ;D

Natomiast mimo że np. dźwięku w przeglądarce teraz nie mam to amarok sobie gra spokojnie, ale kadu chyba milczy bo nic nie pipcze mimo że chyba powinno :wink:

Posiadam dwie karty dźwiękowe zintegrowana + Creative SB Live! 24bit (czy jakoś tak ta nazwa leciała) na PCI i z niej właśnie korzystam jako głównej.

W KDE'owskim menadżerze ustawione mam tak:

Ktoś ma jakieś pomysły? Cinnarch nie miał problemu więc coś tylko ustawić trzeba.


(marcin82) #2

Czy cokolwiek zmieni po restarcie zastosowanie komendy (jako root):

alsactl store

Odnośnie Kadu - sprawdź moduł obsługi dźwięki zewnętrznym programem. Jako polecenie do odgrywania dźwięku ustaw:

/usr/bin/aplay

(fufus) #3

było jak jest, amarok sobie np. gra, ale w przeglądarce dźwięku nie ma ;( vlcplayer też nie ma dźwięku.


(marcin82) #4

Zainstaluj pakiet libcanberra. Czy masz zainstalowanu PulseAudio? Jeśli tak - rozważ jego usunięcie.


(foreste) #5

Wylącz w biosie zintegrowaną

potem z /etc/xdg/autostart wywal pulseaudio lub pulseaudiokde

tylko nie 2 naraz bo będzie ci ciągle pytać o osuniecie kart z listy.


(fufus) #6

nie mam PulseAudio, wgrałem libcanberra i nic jak było tak jest. Zaraz spróbuję znaleźć w biosie czy da się wyłączyć tą kartę, ale do tej pory tej opcji nie widziałem (w sumie to nie szukałem).


(foreste) #7

Zainstaluj pulseaudio bo jak jeden program używa Alsy to 2 ma dostęp zablokowany jak pulse jest to dźwięk działa z każdego programu po wgraniu pulse wykonaj moja poradę poprzedniego postu vs pulse a następnie w każdym programie ustaw karta muz pulse i managerze audio kde ustaw żeby pulse było 1 na górze :wink:.


(marcin82) #8

Pokaż jeszcze wyniki poleceń:

pacman -Q | grep flash

pacman -S hwinfo && hwinfo --arch

(fufus) #9

Nie mogę w biosie wyłączy integry (gigabyte ga-ep35c-ds3r rev2.1)

Czyli mam doinstalować PulseAudio (pacman -S pulseaudio)

i wywalić potem te pliki :slight_smile: zaraz spróbuję.

moja poradę poprzedniego [b]postu vs pulse[/b] a następnie

???


(marcin82) #10

Nie instaluj PulseAudio, bo urwiesz ;] Podaj wynik polecenia:

cat /proc/asound/cards

lspci -k

(foreste) #11

Amarok używa globalnych ustawień ale kadu czy inny program poza gałezi kde m a w ustawieniach wybor karty muzyczne to wyvbiesz pulse audio w ustawieniach :).


(fufus) #12

Kapkę za późno napisałeś że urwę, doinstalowałem póki co i zaczęło grać :D, zaraz zobaczymy czy się nie popsuje, bo czasem wcześniej już też grało, a potem nie.

Tylko że zainstalowałem i nic więcej nie klikałem... zaczęło grać

a to wynik polecenia:

Sorki za taki długi tekst, nie wiem jak tu zrobić zwijany spoiler.

-- Dodane 30.04.2013 (Wt) 23:06 --

No i po restarcie się urwało :stuck_out_tongue: znaczy vlc niby gra, amarok gra a przeglądarka nie ;D

Samo KDE też nie zagrało na starcie.

-- Dodane 30.04.2013 (Wt) 23:12 --

Wydaje się że wszystko gra prócz przeglądarki.


(marcin82) #13

Ustal nazwy modułów jądra z jakich korzystają karty dźwiękowe. Zajrzyj tutaj:

https://wiki.archlinux.org/index.php/Ad ... sound_card

i stosownie do tego przewodnika ustal domyślną kartę dźwiękową. PulseAudio radziłbym wywalić. Im mniej "skomplikowania" tym lepiej. Daj znać czy działa.

Podaj wyniki wszystkich komend, o które pytałem.


(LeserGD) #14

W konfiguracji Biosu w sekcji Integrated Peripherals wyłącz Azalia Codec , integra zamilknie.


(fufus) #15

możesz mi to przełożyć na nasz? Kapkę krucho u mnie z angielskim o ile proste rzeczy rozumiem tak tu mam problem dokładnie zrozumieć, a nie chce popsuć coś sobie w systemie ;>

PulseAudio finalnie wywaliłem bo nic nie pomogło :frowning:


(marcin82) #16

Podaj wynik:

lspci -k

(fufus) #17

masz kilka postów temu :wink:


(LeserGD) #18

Według wiki Archa, aby ustawić domyślną kartę powinieneś przygotować plik /etc/modprobe.d/alsa-base.conf z zawartością

options snd slots=snd_ca0106,snd_hda_intel

options snd_ca0106 index=0

options snd_hda_intel index=1

(fufus) #19

Wyłączyłem kartę zintegrowaną. Przeglądarka dalej nie gra, reszta gra :stuck_out_tongue: Kompletnie już nie rozumiem

Na raz vlc, amarok, kadu też grają jak coś.

EDIT: Już się zabieram za zrobienie pliku :slight_smile:

-- Dodane 30.04.2013 (Wt) 23:53 --

Mam mały problem, nie mogę zrobić tego pliku bo nie moge odpalić nic z prawami roota aby tam zrobić plik o.O

dolphina też nie mogę, odpalić to samo.

przez nano da się jakoś nowy plik zrobić?


(marcin82) #20

Po utworzeniu pliku oraz restarcie komputera podaj jeszcze wynik polecenia:

cat /proc/asound/cards