Artefakty graficzne w Ubuntu 13


(Mikserfixer) #1

Witajcie,

zainstalowałem dzisiaj Ubuntu 13, wszystko działa OK, tylko, że przy robieniu niektórych czynności na ekranie/oknie pojawiają się artefakty.

Poniżej parę screenów:


(dragonn) #2

Ale te programy które wyżej pokazujesz chyba działają przez Wine? Czy są to natywne? Jeśli przez Wine - na pewno pomoże coś aktualizacja Wine do najnowsze wersji (są dla ubuntu odpowiednie repozytoria dodatkowe do tego). Jeśli natywne to podziel cię informacją jak masz kartę graficzną i jakie sterowniki (zamknięte/otwarte).


(Mikserfixer) #3

Steam to zwykła wersja Linuxowa, Lol działa przez Wine'a.

Spróbowałem zaaktualizować sterowniki, pobrałem je ze strony amd pod linuxa, którego mam ale nie wiem jak je zainstalować.

W paczce był tylko plik .run, który da się edytować w notepadzie.

Spróbuję pobrać je z Centrum Oprogramowania Ubuntu.

@edit

Po pobraniu AMD Catalyst Center z Centrum Oprogramowania Ubuntu i uruchomieniu go wywala taki komunikat:

140x8ht.png


(dragonn) #4

Ubuntu ma na pewno jakieś menu w którym można zainstalować sterowniki, przynajmniej zawsze było (program się ten jakoś nazywał właśnie "Sterowniki"). Druga opcja jest aktualizacja sterowników otwartych - tutaj trzeba zaktualizować kernel + mesa.


(Mikserfixer) #5

Zaznaczyłem tą opcję i dałem zapisz zmiany. Co teraz?


(skrzek) #6

instalujesz przez sudo sh

może wymagać kompilacji po każdej aktualizacji kernela.


(dragonn) #7

Najprawdopodobniej zrestartować system.


(marcin82) #8

Najpierw trzeba podać wynik polecenia z konsoli:

lsb_release -a

X -version

lspci -k | grep -A2 VGA

Chyba ugniemy się pod presją i poprawimy zbugowane sterowniki ... zegar tyka - musimy zrobić to szybko! :smiley:


(Mikserfixer) #9

Po restarcie systemu, najpierw jest fioletowe tło. Nic się nie wczytuje. Później pojawia się na chwilę biała kreska w lewym górnym rogu i ekran znika a na monitorze pojawia się "Brak sygnału". Próbowałem uruchomić w trybie bezpiecznego pulpitu ale w tym przypadku pojawia się tylko czarny ekran.

Po wpisaniu pierwszej komedy pokazuje się:

No LSB modules are available.

Distributor ID: Ubuntu

Description: Ubuntu 12.04.4 LTS

Release: 12.04

Codename: precise

Po wpisaniu tej drugiej:

X.Org X Server 1.14.5

Release Date: 2013-12-12

X Protocol Version 11, Revision 0

Build Operating System: Linux 2.6.42-37-generic x86_64 Ubuntu

Current Operating System: Linux ubuntu 3.11.0-15-generic #25~precise1-Ubuntu SMP Thu Jan 30 17:39:31 UTC 2014 x86_64

Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.11.0-15-generic root=UUID=743EDE8A3EDE4530 loop=/ubuntu/disks/root.disk ro quiet splash vt.handoff=7

Build Date: 06 January 2014 01:37:48PM

xorg-server 2:1.14.5-1ubuntu2~saucy1~precise2 (For technical support please see http://www.ubuntu.com/support))

Current version of pixman: 0.30.2

Before reporting problems, check http://wiki.x.org

to make sure that you have the latest version.

A po wpisaniu tej ostatniej pokazuje się:

00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Richland [Radeon HD 8470D]

Subsystem: Advanced Micro Devices, Inc. [AMD/ATI] Richland [Radeon HD 8470D]

Kernel driver in use: radeon