Background-image nie wyświetla się


(Derekdx) #1

Witam

mam problem z css a dokładnie z background-image, za nic nie moge wyswietlic obrazka

oto moj kod html:

wp.pl	[/code]




i css

[code]a#button, a#button:active, a#button:visited { background: url('imgaes/button.jpg') #fff no-repeat bottom; width: 153px; height: 50px; display: block; } span.hide { display:none; }

wszystko zaczerpniete ztad:

http://www.zaradni.pl/porada/1238,jak_z ... e_przycisk

oczywiscie obrazek lezy w

index.html

-/images

-button.jpg

Proszę o pomoc bo juz sam nie wiem o co z tym chodzi mecze sie z tym juz od jakiegos czasu i nic konstruktywnego nie wymyslilem niby wszystko jest ok ale nie dziala

z gory dzieki


(Spam) #2

imgaes → images


(Derekdx) #3

niestety to nie to teraz pokazuje mi sie białe pole zamiast obrazka


(M@ster) #4

Zła składnia parametru CSS "background", powinno być:

background: color url(...) repeat position;

czyli w twoim przypadku:

background: #fff url(images/button.jpg) no-repeat left bottom;

Ścieżka do obrazka jest brana względem arkusza stylów a nie dokumentu który go załącza.


(mario@) #5

Bez różnicy.

Sprawdź dokładnie położenie pliku, jego rozszerzenie, prawa do odczytu oraz czy przypadkiem nie nadałeś innych stylów dla tego samego id.


(Monczkin) #6

DerekDX , nazwij proszę temat konkretnie, bez zbędnych próśb w tytule. Inaczej wyciągnę konsekwencje. Przeczytaj proszę ten temat http://forum.dobreprogramy.pl/viewtopic.php?f=16&t=394978


(Derekdx) #7

w sumie ta informacja najbardziej mi pomogła dzieki wielkie wszystkim za pomoc