Battlefield 3 - directx problem


(Maciej Fly2) #1

Witam,

mam oryginalnego, co podkreślam już na samym początku :stuck_out_tongue: Battlefielda 3. Gra ładnie się zainstalowała i zaktualizowała. Kiedy jednak w chodzę na battleloga z zamiarem pogrania na multi, mam problem z directxem.

Kiedy klikam quickmatcha bądź coopa, to po ,,loading level'' wyskakuje następujący błąd:

Failed creating D3D device of at least version 10.0 on adapter "NVIDIA GeForce 8800 GT (Microsoft Corporation - WDDM v.1.1)'' with driver "Unknown". Error is DXGI_ERROR_UNSUPPORTED ("Unsupported.").

This is typically caused by not having required DirectX support in the GPU.

For NVIDIA GPUs, DirectX 10.0 support is required.

For AMD and GPUs from other vendors, DirectX 10.1 support is required.

Mam procesor Intel Core 2 Quad q6600 2.4 GHz, kartę GeForce 8800 GT 512 mb i 256 bit. W czym może tu być problem?

*Kampania też nie działa

*tutaj mam raport z ,,can you run it'' na minimalnych

CPU

Minimum: 2 GHz DUAL CORE (Core 2 Duo 2.4 GHz or Athlon X2 2.7 GHz)

You Have: Intel® Core2 Quad CPU Q6600 @ 2.40GHz

PASS

Click here for the latest CPU drivers.

CPU Speed

Minimum: Info

You Have: 2.4 GHz

RAM

Minimum: 2 GB

You Have: 4.5 GB

PASS

OS

Minimum: Windows Vista (Service Pack 1) 32-bit

You Have: Microsoft Windows 7 Service Pack 1 (build 7601), 64-bit

PASS

Click here for the latest Windows drivers.

Video Card

Minimum: (AMD): DirectX 10.1 compatible with 512 MB RAM (ATI Radeon 3000, 4000, 5000 or 6000 series, with ATI Radeon HD 3870 or higher performance)(NVIDIA): DirectX 10.0 compatible with 512 MB RAM (NVIDIA GeForce 8, 9, 200, 300, 400 or 500 series, with NVIDIA GeForce 8800 GT or higher performance)

You Have: GeForce 8800 GT

PASS

Click here for the latest Video drivers.

Features: Minimum attributes of your Video Card

Required You Have

Video RAM 512 MB 2.2 GB

Pixel Shader version 4.0 (ATI 4.1) 4.0

Vertex Shader version 4.0 (ATI 4.1) 4.0

Sound Card

Minimum: Yes

You Have: High Definition Audio Device

PASS

Click here for the latest Sound Card drivers.

Free Disk Space

Minimum: 20 GB

You Have: 195.2 GB

PASS


(Sokar11) #2

Z tego co znalazłem karta wymaga co najmniej DirectX 10 a ten DirectX jest dostępny od Windowsa Visty. Jak masz Windowsa XP to tam jest DirectX 9.0 i dlatego może gra nie odpalać.


(Maciej Fly2) #3

wpisałem komendę directxa, mam na kompie DirectX 11


(Sokar11) #4

spróbuj ściągnąć directX 11 jak znajdziesz i przeinstaluj. Zainstaluj także dirextx 9.0 bo Windows Seven nie ma 9.0. Może to pomoże?


(Maciej Fly2) #5

okej, zaraz spróbuję


(system) #6

To pokazuje, że nie masz zainstalowanych sterowników od nVidii.


(Maciej Fly2) #7

Z tego co wiem to są aktualne


(kamilek030190xd) #8

Do Battlefielda sa potrzebne najnowsze sterowniki ze strony NVIDIA. "NVIDIA GeForce 8800 GT (Microsoft Corporation - WDDM v.1.1)"-tak jak napisał yorkfield25 ten napis świadczy o tym że sterowniki zostawły zainstalowane lecz sa to stery najzwyklejsze,takie "aby były". Zamiast "Microsoft Corporation" powinno pisać "NVIDIA Corporation"


(CZiPEN) #9

Czemu czepiliście się tego XP. Przecież w pierwszym poście wyraźnie pisze, że ma Windows 7 x64.

Sterki:

http://www.nvidia.pl/object/win7-winvista-64bit-285.62-whql-driver-pl.html


(Maciej Fly2) #10

Przetestowałem na innych:

  1. laptop vaio - tutaj ładnie, coop ok, kampania ok, strasznie długie wczytywanie multi o.O

  2. laptop asus u36jc - instaluję właśnie ;D

  3. teraz jeszcze stacjonarny MAM WINDOWSA 7vhome premium 64 bit tak dla info, czy mógłbym prosić o jakiś link do tych specjalnych driverów? ;D

@up - dzięki, zaraz testuję :wink:

-- Dodane 29.12.2011 (Cz) 16:41 --

Nowe drivery pomogły, bardzo dziękuję :slight_smile:


(Czester29) #11

Witam. Ja ma podobny problem. Tylko, ze u mnie wyskakuje taki komunikat: failed creating D3D device of at least version 10.0 on adapter ATI Mobiliti Radeon HD 2400 with driver unknown error is DXGI ERROR UNSUPPORTED. this is typically caused by not having the minimum required DirectX support in the GPU. For Nividia GPU DirectX 10.0 for amd and gpu from other vendors DirectX 10.1 support is required. Ja ma karta gr. ati mobility radeon 2400HD. procesor intel pentium dual T2330 1.6 GHZ. Pamięc ram 2.00GB. gra się zainstalowała ale jak chce uruchomic to takie cos sie pokazuje. koledzy dajcie podpowiedz, bo ja jestem zielony. WINDOWS VISTA


(kamilek030190xd) #12

Jaki windows??


(Czester29) #13

VISTA


(kamilek030190xd) #14

Pobierz to i zainstaluj http://download.chip.eu/pl/DirectX-SDK_67958855.html a tak w ogóle to ta karta Twoja nie jest za dobra na battlefielda i nie wiem czy w ogóle bedziesz mógł na niej grać w tę grę... Jak nie pomoże to to zainstaluj najnowsze sterowniki do karty http://support.amd.com/us/gpudownload/Pages/index.aspx


(Czester29) #15

Dzięki kamilek tak myślałem ze ta karta juz sie do niczego nie nadaje szkoda ze nie moge jej wymienic, ale sciągam to co mi podałes moze sie uda. pozdro.


(kamilek030190xd) #16

jak zainstalujesz to napisz jaki jest efekt


(Czester29) #17

nie mogę tego zainstalowac directX SDK na koniec instalacji pokazuje error codu s1023


(Lukaszbobek12) #18

potrzeba co najmniej DirectX 10.1


(kamilek030190xd) #19

Wymień grafe:)