Błąd Generic host Process for Win32 Services w XP SP3


(Okij1) #1

Powstał problem z moim komputerem. Sądzę, że to z powodu jakiegoś robaka lub innego wirusa.

Mam Windowsa XP Pro Service Pack 3. Jak mi się wydaje w przeciągu tygodnia może dwóch zaczął pojawiać mi się monit: "Błąd Generic host Process for Win32 Services". W raporcie tworzonym przez Windows pojawiła się informacja dotycząca sygnatury błędu: szAppName: svchost.exe; szAppVer: 5.1.2600.5512; szModName: unknown; szModVer: 0.0.0.0; offset: 6fe217c2. Mam zainstalowanego Avast! Free Antivirus.

Inne objawy:

  1. autoodtwarzanie czasem nie działa (np. przy wkładaniu płyty do napędu komputer nie wykonuje żadnej akcji); próbowałem użyć AutoFixa, ale problem się pojawia;

  2. wyłączenie internetu przez naciśnięcie na ikonkę monitorów koło zegara powoduje, że ikonka nie znika, ale internetu też nie ma, a włączyć go ponownie już nie można; chyba że uruchomi się ponownie komputer;

  3. niebieska dolna belka windowsa w pewnym momencie zmienia kolor na szarą, a kształt na podobny do Windowsa 95/98, a po krótszej lub dłuższej chwili powraca do poprzedniego stanu;

  4. pojawił się monit z błędem dotyczącym NVIDIA.

Avast nic nie wykrył. A ArcaVirMicroScan wykrył:

C:\System Volume Information_restore{4E5935AF-6568-452A-9E99-9D0B4D41A12D}\RP355\A0071054.exe <- Generic.26.57651,

Choć nie wiem czy to jest przyczyną powyższego. A ponieważ nie wiem co to za plik, to go nie usunąłem - tylko taka była możliwość albo usunąć, albo zostawić.

Czytałem poprzednie wątki na forum (np. http://forum.dobreprogramy.pl/blad-generic-host-process-for-win32-services-t93075.html), ale tam chodziło o sytuację, gdy nie ma Service Pack 3, a u mnie to jest. Co do programu Windows Worms Doors Cleaner, o którym mowa we wskazanym linku, to na stronie dobreprogramy.pl, w pierwszym poście (z 24.07.2011 0:08 przez UnixStyle297) przy tym programie, napisane jest, że program ma wirusa, więc nie instalowałem go.

Zrobiłem też OTL, mam nadzieję, że prawidłowo:

OTL.txt tu

Extras.txt tu

Jeśli ktoś mógłby coś podpowiedzieć.


(Spandau) #2

Był w użyciu Combofix Proszę o raport z niego. Jakiego masz Firewalla?


(Okij1) #3

To prawda - używałem ComboFixa i oczywiście dostarczę raport, ale do poniedziałku wieczora nie mam dostępu do tego komputera, więc zrobię to w poniedziałek wieczorem. Co prawda nie wiem czy prawidłowo puściłem ComboFixa, no ale raport gdzieś tam powinien być.

Firewall pewnie jest avastowski, a jeśli nie ten to standardowy Windowsa. Przez ładnych parę lat wystarczało.

Dodatkowe objawy - wyłącza urządzenie dźwiękowe - komputer mówi, że nic nie wykrywa.


(Spandau) #4

Z tego co piszesz, Avast to sam antywirus, wygląda więc na to, że nie masz firewalla

Wyłącz i włącz przywracanie systemu na wszystkich dyskach. Instrukcja

Wykonaj pełne skanowanie Malwarebytes http://www.dobreprogramy.pl/Malwarebyte ... 13117.html Jak coś wykryje pokaż raport na forum

Czekam na raport Combofixa


(Okij1) #5

Podaję raport ComboFixa tu

Mam włączone przywracanie systemu na wszystkich dyskach - rozumiem, że mam to wyłączyć i ponownie włączyć?

Zaraz podam co wykrył Malawarebytes - właśnie go puściłem.

Co do firewalla - to chyba faktycznie ten Avast nie ma go, ale wiedzę, że mam standardowy Windowsa. Choć tam jest sporo wyłączeń, ale to zaraz zobaczę jakie, bo właśnie zablokowana została możliwość podejrzenia jej ustawień i włączenia. Wygląda na to, że została wyłączona.

-- Dodane 05.12.2011 (Pn) 18:19 --

A przepraszam. Robiłem już skan programem Malwerebytes.

Oto log: tu

-- Dodane 05.12.2011 (Pn) 18:20 --

Oczywiście w razie potrzeby zrobię kolejne skany.


(Spandau) #6

Tak

Odinstaluj Combofixa Start - Uruchom - wpisujesz lub skopiuj

"c:\documents and settings\ja\Pulpit\ComboFix.exe" /uninstall i Enter

Uruchom OTL klikasz Sprzątanie

DRV - 1998-09-16 08:07:10 | 000,041,472 | ---- | M [Kernel | Auto | Running] -- C:\WINDOWS\system32\drivers\sfc4.sys -- (SFC4)

Zastanawia mnie ten plik Wykonaj pełne skanowanie Malwarebytes. To które zrobiłeś to szybki skan.

Proszę o raport Gmera instrukcja otl-gmer-rsit-dss-inne-instrukcje-t370405.html

Uaktualnij Avasta, przeskanuj cały system Avastem oraz zainstaluj dodatkowo Comodo firewall http://www.dobreprogramy.pl/Comodo-Pers ... 20399.html


(Okij1) #7

Co do ComboFixa to uruchamiam go z płyty więc nie mam go zainstalowanego na dysku twardym.

Proszę oto log z Malwarebytes, który zrobiłem wczoraj wieczorem: tu . Przy okazji tam w logu wykazany jest jakiś wpis systemowy, jednocześnie program Malwarebytes przeniósł coś do kwarantanny - "PUM.Disabled.SecurityCenter". Czy mam coś z tym obiektem zrobić, czy raczej go nie ruszać.

Robiłem też wczoraj pełne skanowanie Avastem - nic nie wykrył. niestety nie wiem czemu nie zapisał żadnego raportu, mimo że wcześnie sprawdzałem, żeby na pewno został zapisany. Jest niestety tylko wcześniejszy raport, zresztą z przerwanego skanowania.

Teraz zabieram się do OTL - Sprzątania. A potem do Gmera.

-- Dodane 06.12.2011 (Wt) 19:29 --

OTL - włączyłem Sprzątanie: program kazał wyłączyć/włączyć Windowsa, żeby usunąć pliki (choć nie wiem jakie, ale widzę, że chodziło chyba o pliki OTLa) - zrobiłem.

Ściągnąłem Gmera. Włączyłem, kliknąłem szukaj i tu... pojawił się po chwili, od paru lat nie widziany "blue screen". Z ostrożności nie włączyłem ponownie Gmera.


(Spandau) #8

To możesz usunąć - to ustawienie Centrum zabezpieczeń.

Zainstaluj IE8 dla windwos XP http://www.dobreprogramy.pl/Internet-Ex ... 12086.html

Wejdź na windwos update i zainstaluj wszystkie ważne poprawki jakie się tam pojawią.

Zainstalowałeś Comodo Firewall? Napisz czy błąd nadaw występuje?


(Okij1) #9

PUM.Disabled.SecurityCenter - usunąłem.

Instaluję IE 8, potem pościągam aktualizacje. Choć na co dzień i tak z reguły korzystam z Firefoxa.

Co do firewall, to myślałem, że standardowy windowsowski firewall wystarczy, ale rozumiem, że skoro coś takiego się pojawiło, to powinienem mieć lepszą zaporę?

Co do wyskakiwania błędu: ok. 1,5 godziny komputer jest włączony (do internetu również) i błąd na razie nie wyskoczył.

Jakkolwiek mam pytanie: czy wiadomo co to jest, to co mi się pojawiło - te objawy, błąd - czym to zostało spowodowane?

-- Dodane 07.12.2011 (Śr) 19:16 --

A teraz oprócz tego, że nie działa autoodtwarzanie, to jeszcze jak wkładam pendrive'a, to mi wyskakuje nie następna w kolejności literka na oznaczenie napędu np. "G:", ale przeskakuje o jedną i zamiast "G:" jest "H:". A "G:" nie jest nigdzie przyporządkowane i takiego napędu nie ma.


(Spandau) #10

Nie ma znaczenia czy używasz IE czy nie Zasadą jest jeśli nie używasz to należy zaktualizować i zostawić. To może być jeden z powodów dla których pojawia się ten błąd. Instalacje Comodo firewall zaleciłem bo to powinno pomóc w ochronie otwartych portów. Do ich zamknięcia służy programik http://www.dobreprogramy.pl/Windows-Wor ... 11744.html


(Okij1) #11

Comodo zainstalowałem.

Co do programu Windows Worms Doors Cleaner, o którym mowa we wskazanym linku, to na podanej stronie, w pierwszym poście (z 24.07.2011 0:08 przez UnixStyle297) przy tym programie, napisane jest, że program ma wirusa, więc nie instalowałem go.

Na razie obserwuje komputer, monitu póki co nie było. Aczkolwiek niczego przecież znaczącego nie zrobiłem. Poza tym cały czas mam dziwne objawy w postaci braku Autoodtwarzania i przeskakiwania o jedną literę w przypadku podłączenia nowego napędu (zamiast G: wyskakuje H:).


(Spandau) #12

No nie bądź śmieszny. Niektóre opinie nadają się na śmietnik Jeden gość w recenzji Combofixa napisał, że brak wad, w każdym razie żadnej wady nie wymienił, chyba pomylił przycisk recenzja z komentarzem, albo nie ma pojęcia o programie. Wracając do tematu autor pisze

Każdy antywirus może się pomylić. Opinii tych, w ogóle mi nie znanych antywirusów, nie biorę pod uwagę. Tak się składa, że korzystam z Kasperskiego i wykonałem skan oto dowód

wwdc.gif

To nastąpiło po użyciu Combofixa. Program robi to w celu zabezpieczenia komputera przed infekcjami z mediów przenośnych. Użyj Autoplay Repair Wizard http://www.microsoft.com/downloads/deta ... laylang=en Jak nie pomoże pisz


(Okij1) #13

Na moje wątpliwości co do programu Windows Worms Doors Cleaner, poza sytuacją z zainfekowanym (?) komputerem i moim w związku z tym poddenerwowaniem (choć wiem, że wiele z tych postów to banialuki), wpłynęło również to, że ten wpis, na który się powołałem, nie został usunięty albo choćby skomentowny przez redakcję portalu ani nikogo innego. Uznałem, że póki nie znajdę jakiegoś potwierdzenia lub zaprzeczenia tych informacji z postu od zdolniejszych od siebie, to poczekam. A teraz je mam, za co wielkie podziękowania.

Wracając do moich problemów z autoodtwarzaniem - próbowałem już wcześniej z Autoplay Repair Wizard, ale niestety nic nie zdziałał.

A co z przeskakującą literą napędu, o czym wcześniej wspominałem?

Za powyższe i dotychczasowe ogromnie dziękuję.


(Spandau) #14

Wklej do notatnika

Z menu Notatnika wybierasz - Plik - Zapisz jako - Zmieniasz rozszerzenie z .txt na wszystkie pliki - zapisz pod nazwą Fix.reg

Uruchom ten plik, potwierdź dodanie do rejestru, uruchom ponownie komputer. Zobacz czy działa

Hm przyznam, że nie zastanawiałem się wcześniej nad tym ale teraz widzę, że u mnie pendrive wykrywany jest pod literą K

Zobacz ten temat http://support.microsoft.com/kb/307844/pl Nie sprawdzałem więc nie jestem pewien czy dotyczy dysków wymiennych


(Okij1) #15

Nie wprowadziłem jeszcze powyższych zmian. Miałem problem - jak się okazało z Comodo Firewallem. Po prostu nagle spowolniło mi strasznie mocno komputer - po włączeniu komputera, pojawieniu się pulpitu, wszystkich ikonek na nim, ikonki na pasku nie pojawiły się wszystkie, a uruchomienie czegokolwiek graniczyło z cudem. Choć myszka chodziła sprawnie, a menu startu otwierało się poprawnie. Wyłączenie systemu trwało z 10 minut, jeśli nie więcej, podczas gdy normalnie to trwa ok. 1-1,5 minut. Po odinstalowaniu Comodo jak ręką odjął. Nie wiem czy to wyłączna wina Comodo, czy może w konfiguracji komputera jest coś, co w połączeniu z Comodo dało takie efekty, tak czy inaczej na razie przynajmniej Comodo odinstalowałem.

Poprzyglądam się, poobserwuję i zobaczę co dalej. A w międzyczasie wprowadzę podane wpisy do rejestru.

A czy wiadomo co działo się (a może jeszcze się będzie działo) z komputerem? Chodzi o ten błąd wskazany w tytule.


(Spandau) #16

Zdarza się, że oprogramowanie zabezpieczające może stwarzać probelmy.

Ten błąd może mieć różne podłoże. Krótko mówiąc system mógł zostać zainfekowany ponieważ oprogramowanie, które masz jest nieaktualne. Dotyczy to systemu (SP i inne aktualizacje dostępne przez windows update) oraz oprogramowania szeroko rozumianego jak: (IE, Java, Adobe) a przede wszystkim oprogramowanie zabezpieczające Antywirus zapora itp


(Okij1) #17

Dziękuję za wszystko. Ponieważ jeszcze nie byłem przy wadliwym komputerze, to obiecuję, że po Nowym Roku wszystko powprowadzam i zobaczę co z tymi aktualizacjami się dzieje. Póki co wszystkiego dobrego w Nowym Roku i jeszcze raz wielkie dzięki.