Błąd ndiswrapper-dkms w testowym ubu 10.10


(niezDarek) #1

no i sprawa tyczy sie ubuntu 10.10, tak wiem jest to wersja testowa, jeszcze alpha ale ambicja chyba nie pozwala zamykać się w stabilnych wersjach :stuck_out_tongue:

no i tu pojawił sie problem, co bym nie instalował, usuwał wywalam błąd z ndiswrapper-dkms

przy instalacji czegokolwiek lub usuwaniu w synaptic wywala taki oto błąd:

E: ndiswrapper-dkms: podproces zainstalowany skrypt post-installation zwrócił kod błędu 10

a w przypadku Centrum oprogramowania wyskakuje:

installArchives() failed: (Odczytywanie bazy danych ... 

(Odczytywanie bazy danych ... 5%

(Odczytywanie bazy danych ... 10%

(Odczytywanie bazy danych ... 15%

(Odczytywanie bazy danych ... 20%

(Odczytywanie bazy danych ... 25%

(Odczytywanie bazy danych ... 30%

(Odczytywanie bazy danych ... 35%

(Odczytywanie bazy danych ... 40%

(Odczytywanie bazy danych ... 45%

(Odczytywanie bazy danych ... 50%

(Odczytywanie bazy danych ... 55%

(Odczytywanie bazy danych ... 60%

(Odczytywanie bazy danych ... 65%

(Odczytywanie bazy danych ... 70%

(Odczytywanie bazy danych ... 75%

(Odczytywanie bazy danych ... 80%

(Odczytywanie bazy danych ... 85%

(Odczytywanie bazy danych ... 90%

(Odczytywanie bazy danych ... 95%

(Odczytywanie bazy danych ... 100%

(Odczytywanie bazy danych ... 190759 plików i katalogów obecnie zainstalowanych.)

Usuwanie quadrapassel ...

Przetwarzanie wyzwalaczy dla gconf2...

Przetwarzanie wyzwalaczy dla hicolor-icon-theme...

Przetwarzanie wyzwalaczy dla desktop-file-utils...

Przetwarzanie wyzwalaczy dla python-gmenu...

Rebuilding /usr/share/applications/desktop.pl_PL.UTF8.cache...

Przetwarzanie wyzwalaczy dla man-db...

Przetwarzanie wyzwalaczy dla menu...

Przetwarzanie wyzwalaczy dla python-support...

Konfigurowanie ndiswrapper-dkms (1.56-1) ...

Removing old ndiswrapper-1.56 DKMS files...


------------------------------

Deleting module version: 1.56

completely from the DKMS tree.

------------------------------

Done.

Loading new ndiswrapper-1.56 DKMS files...

First Installation: checking all kernels...

Building only for 2.6.35-6-generic

Building initial module for 2.6.35-6-generic


Error! Bad return status for module build on kernel: 2.6.35-6-generic (i686)

Consult the make.log in the build directory

/var/lib/dkms/ndiswrapper/1.56/build/ for more information.

Traceback (most recent call last):

  File "/usr/share/apport/package-hooks/dkms.py", line 57, in 

    report.write(open(apport.fileutils.make_report_path(report), 'w'))

IOError: [Errno 2] No such file or directory: '/var/crash/ndiswrapper-dkms.0.crash'

dpkg: błąd przetwarzania ndiswrapper-dkms (--configure):

 podproces zainstalowany skrypt post-installation zwrócił kod błędu 10

Wystąpiły błędy podczas przetwarzania:

 ndiswrapper-dkms

Konfigurowanie ndiswrapper-dkms (1.56-1) ...

Removing old ndiswrapper-1.56 DKMS files...


------------------------------

Deleting module version: 1.56

completely from the DKMS tree.

------------------------------

Done.

Loading new ndiswrapper-1.56 DKMS files...

First Installation: checking all kernels...

Building only for 2.6.35-6-generic

Building initial module for 2.6.35-6-generic


Error! Bad return status for module build on kernel: 2.6.35-6-generic (i686)

Consult the make.log in the build directory

/var/lib/dkms/ndiswrapper/1.56/build/ for more information.

Traceback (most recent call last):

  File "/usr/share/apport/package-hooks/dkms.py", line 57, in 

    report.write(open(apport.fileutils.make_report_path(report), 'w'))

IOError: [Errno 2] No such file or directory: '/var/crash/ndiswrapper-dkms.0.crash'

dpkg: błąd przetwarzania ndiswrapper-dkms (--configure):

 podproces zainstalowany skrypt post-installation zwrócił kod błędu 10

więcej info chyba jest podane, mimo że to wersja testowa mam pytanie jak się tego pozbyć, podobno to bug 10.10 tak wujek google twierdzi ale może jest jakieś magiczne rozwiązanie, zapytać nie zaszkodzi

może downgrade jądra jeśli tak można :stuck_out_tongue:


(roobal) #2

Jeśli nie potrzebujesz Ndiswrappera to go wywal. Z tego co mi się wydaje błąd jest w skrypcie budującym moduł Ndiswrappera ze źródeł. Jeśli chodzi o downgrade jądra to problemu nie ma, ponieważ nie jest związane zależnościami a oprócz tego można mieć zainstalowanych kilka wersji.

Może zamiast testować wersje niestabilne i masz ambicję to skompiluj własne jajko dostosowane do twojego sprzętu :wink:

Pozdrawiam!


(niezDarek) #3

ok, wywaliłem ndiswrapper'a i problemu już nie ma :smiley:

kompilacja własnego jądra... to jest myśl :smiley: spróbuje :stuck_out_tongue: