Błąd pliku sshnas21.dll


(Patryk94) #1

Witam

Podczas uruchamiania systemu wyświetla się okna z napisem

wystąpił problem podczas ładowania pliku

C:\Windows\system32\sshnas21.dll

Nie można odnaleźć określonego modułu

wcześniej tego nie miałem, co mogę zrobić aby to usunąć?

System windows 7 64bit

Log z OTL: http://wklej.org/id/377372/

Pozdrawiam


([i]DAEMON) #2

Mój pierwszy post, mam nadzieję że pomogę :slight_smile:

W Custom Scans/Fixes wklej:

:Processes

killallprocesses


:OTL

O4 - HKU\S-1-5-21-1498001295-2037718935-2238716252-1001..\Run: [AdobeBridge] File not found

O4 - HKU\S-1-5-21-1498001295-2037718935-2238716252-1001..\Run: [EPSON Stylus S20 Series] C:\Windows\SysWow64\spool\DRIVERS\x64\3\E_IATIEAE.EXE File not found

O4 - HKU\S-1-5-21-1498001295-2037718935-2238716252-1001..\Run: [Metropolis] C:\Windows\SysWow64\sshnas21.DLL (ApexDC++ Development Team)

O4 - HKU\S-1-5-21-1498001295-2037718935-2238716252-1001..\Run: [ZE18MW23GY] C:\Users\Patryk\AppData\Local\Temp\Xlh.exe (ApexDC++ Development Team)

O4 - HKU\S-1-5-19..\RunOnce: [mctadmin] C:\Windows\SysWow64\mctadmin.exe File not found

O4 - HKU\S-1-5-20..\RunOnce: [mctadmin] C:\Windows\SysWow64\mctadmin.exe File not found

O33 - MountPoints2\{1b55f2fa-7283-11df-b919-00248cb89571}\Shell - "" = AutoRun

O33 - MountPoints2\{1b55f2fa-7283-11df-b919-00248cb89571}\Shell\AutoRun\command - "" = I:\Autorun.exe -- File not found

O33 - MountPoints2\{fae53ea5-9d8f-11df-8972-00248cb89571}\Shell - "" = AutoRun

O33 - MountPoints2\{fae53ea5-9d8f-11df-8972-00248cb89571}\Shell\AutoRun\command - "" = E:\Setup.exe -- File not found

[2010-08-15 23:47:24 | 000,196,608 | ---- | C] (ApexDC++ Development Team) -- C:\Windows\Xdymea.exe

[2010-08-15 23:47:17 | 000,241,664 | ---- | C] (ApexDC++ Development Team) -- C:\Windows\SysWow64\sshnas21.dll


:Files

C:\Users\Patryk\AppData\Local\Temp\Xlh.exe


:Commands

[reboot]

Podaj log z usuwania i nowy log z OTL.

Podawaj również plik Extras.txt


(Patryk94) #3

Wydaje mi się, że wszystko jest ok, komunikat znikł:wink:

OTL: http://wklej.org/id/377393/

Extras: http://wklej.org/id/377394/

dzięki za pomoc. a tak żeby nie tworzyć już nowego tematu. dałoby radę wyłączyć autostart programu logmeinhamachi wlasnie przez OTLa? próbowałem już wieloma sposobami jednak nic nie pomaga :oops:


([i]DAEMON) #4

W Custom Scans/Fixes wklej:

:OTL

O4 - HKLM..\Run: [LogMeIn Hamachi Ui] C:\Program Files (x86)\LogMeIn Hamachi\hamachi-2-ui.exe (LogMeIn Inc.)

O2:[b]64bit:[/b] - BHO: (no name) - {DBC80044-A445-435b-BC74-9C25C1C588A9} - No CLSID value found.

O18:[b]64bit:[/b] - Protocol\Handler\livecall {828030A1-22C1-4009-854F-8E305202313F} - Reg Error: Key error. File not found

O18:[b]64bit:[/b] - Protocol\Handler\ms-help {314111c7-a502-11d2-bbca-00c04f8ec294} - Reg Error: Key error. File not found

O18:[b]64bit:[/b] - Protocol\Handler\msnim {828030A1-22C1-4009-854F-8E305202313F} - Reg Error: Key error. File not found

O18:[b]64bit:[/b] - Protocol\Handler\skype4com {FFC8B962-9B40-4DFF-9458-1830C7DD7F5D} - Reg Error: Key error. File not found

Z Hamachi nie powinno być już problemów.

Dla dokładności przeskanuj system MalwareBytes i użyj CCleaner.


(Patryk94) #5

ok autostart wyłączył się :slight_smile:

tylko teraz mam problem z samą aplikacją, kiedy uruchomię ją wyświetla się okno:

Language file not found

Some text messages may render incorrectly.

da się coś z tym zrobić? :slight_smile:


(deFco247) #6

Cały powyższy skrypt dla OTL nie nadaje się do niczego.

Ten problem na pewno zniknie, bo Hamachi nie będzie się już w ogóle uruchamiać.

OTL w przypadku wstawienia w skrypcie linii )4 nie tylko usuwa wpis autostartu, ale również plik, który jest nim uruchamiany.

Konieczne będzie przywrócenie tego pliku na swoje miejsce z folderu C:_OTL

Natomiast te wpis występują na każdym, 64-bitowym Windows. Zresztą i tak OTL nie tknie 64-bitowej części systemu.


([i]DAEMON) #7

Bardzo przepraszam, mój błąd.


(Patryk94) #8

właśnie o to mi chodzilo aby hamachi nie uruchamiało się przy starcie. odznaczenie tego np w CCleanerze nie dawało rezultatów