Błąd podczas instalacji sterowników karty dźwiękowej


(Maroń) #1

Mój sprzęt

Płyta główna MS 7327

AMD Athlon 64 x2 5000+

1gb ram

Karta dźwiękowa jest zintegrowana- realtek alc888

Windows XP SP2

Opis problemu:

Zakupiłem sobie nową kartę dźwiekową Sound Blaster Xi-fi Audio (SB1040).

Wyłączyłem kartę zintegrowaną w BIOSie.

Odinstalowałem sterowniki ze starej karty.

Na poczatku nie wiedząc czemu nie rozpoznawało mi tej karty (w menadżerze urządzeń wykrywało ją jako "nieznane urządzenie"), ale coś tam porobiłem i rozpoznaje ją jako Sound Blaster Xi-fi... no ale sterowniki nie są wgrane więc dźwięku nie ma.

I tutaj to z czym się męczę: Chcę zainstalować sterowniki do nowej karty dźwiękowej, włączam, włącza się Install Shield Wizard wybieram język, w następnym oknie pasek szybko dojeżdża do końca i wyskakuje Error:

error number: 0x80040706

description: object reference not set

setup will now terminate

Dodam jeszcze, że ściągnąłem jeszcze 2 innych sterowników, ale to niczego nie zmieniło.

Szukałem na polskich i zagranicznych forach, niestety odpowiedzi nie znalazłem. Czysciłem rejestr, odpalałem kompa w Trybie awaryjnym awaryjnym-NIC to nie dało, cały czas to samo. Format był robiony niecałe 2 miesiące temu, nie chce znowu go robic.

Bardzo proszę o pomoc, Pozdrawiam


(stalesz) #2

Doinstaluj SP3 i aktualizacje.http://support.creative.com/Products/Pr ... px?catid=1 Starej karty nie musiałeś wyłączać w BIOS,wystarczyło w menadżerze.Sound Blaster Xi-fi Audio (SB1040 ? czy X-fi


(Maroń) #3

No rzeczywiście X-fi, mój błąd.

Co do SP3, chciałem go juz dawno zainstalować, tylko że z tym tez jest problem i kiedys próbowałem juz wielu rzeczy, niestety nie zadziałało. Wyskakuje taki bład przy próbie instalacji SP3:Wystąpił błąd wewnętrzny i bodajże w następnym oknie "Instalacja nie została ukończona" cos takiego.


(stalesz) #4

http://programy.computerworld.pl/pc/176 ... .3.pl.html


(Maroń) #5

Dzięki pobiorę sobie go, jednak juz wczesniej pobierałem z internetu, no i poprzez aktualizacje instalowałem ale zawsze ten sam błąd, zrobiłem wszystko zgodnie z tym co napisane było na stronie microsoftu odnosnie tego błędu..

A i jeszcze chciałbym dodać, że zdenerwowałem się i chciałem na krótki czas wrócic do starej karty-niestety nie dało sie zainstalować sterowników do realteka bo w InstallShield wystapił identyczny błąd(ten o którym pisałem w 1 poscie), zaraz po formacie 1,5 miesiąca temu normalnie je zainstalowałem..


(stalesz) #6

Przeskanuj system Malwarebytes-antimalware.Uszkodzony Instalator ...


(Maroń) #7

Przeskanowałem.

O o chodzi z uszkodzonym instalatorem?? Jaki instalator jest uszkodzony? Z SP3 sprawdzałem 2 i błąd wewnętrzny wyskakuje, a ze sterowników z karty sprawdzałem 4 i ten sam błąd cały czas.

-- Dodane 20.12.2010 (Pn) 17:42 --

Mam rozumiec, ze bez formata się nie obejdzie? Bo już nie wiem co to może być i jeszcze się wkurzam bo wgl teraz dźwięku nie mam, bo starych sterów też nie da sie zainstalowac przez ten error nr 0x80040706

P.S czytałem wiele tematów o tym błędzie, niestety żadne "rozwiązania" problemu nie zadziałały.

Dzięki za pomoc i chyba niestety w wolnej chwili zrobie tego formata ;/