Błąd podczas uruchamiania Ubuntu - nie znajduje dysku


(system) #1

Na samym początku uprzedzam, że jest to mój pierwszy kontakt z Linuxem i jestem zupełnie zielony. Postanowiłem zainstalować Ubuntu 10.04, którego ściągnąłem z ubuntu.pl. Instalacja poszła gładko bez problemów. Po zakończeniu instalacji system uruchomił się ponownie po czym pojawił się czarny ekran z takim napisem:

Gave up waiting for root device. Common problems:

  • Boot args (cat /proc/cmdline)

  • Check rootdelay= (did the system wait long enough?)

  • Check root= (did the system wait for right device?)

-Missing modules (cat /proc/modules; ls /dev)

ALERT! /dev/disk/by-uuid/1d82191f-51f8-4b55-8af7-4024eb04cb39 does not exist. Dropping to shell!

Przypominam, że nie znam się zupełnie na linuxie i proszę o konkretne podpowiedzi co mam robić krok po kroku. Z góry dziękuje za pomoc.

/Nutrol


(BenderBendingRodriguez) #2

(OSTRZEGAM ŻE DAŁOBY SIĘ TO NAPRAWIĆ GRAFICZNIE ALE POLECAM PRZEŁAMAĆ STRACH PRZED KONSOLĄ BO ONA NIE GRYZIE)

Zabootuj jeszcze raz z live cd.

Rozumiem że masz Ubuntu czyli GNOME, jeśli jest inaczej to napisz (jak masz niebieski interfejs to jest kubuntu;)

Jak już zabootujesz to otwórz gnome-terminal (wciśnij jednocześnie Alt + F2 i wpisz gnome-terminal, takie wygodne narzędzie do szybkiego wywoływania aplikacji).

W tym gnome terminal wpisuj po kolei ( i nam tu pokaż):

fdisk -l (to pokazuje nam wszystkie partycje dyskowe na komputerze, używając analogii pokazuje nam kawałki tortu i jak jest “pokrojony” :slight_smile:

Następnie skieruj się właśnie tam gdzie Ci pokazywało błąd podczas bootowania czyli /dev/disk/by-uuid/ i wpisz

ls -l

Jak już to nam pokażesz możemy iść dalej

P.S. Nie wiem jeszcze co podejrzewać ale prawdopodobnie masz nieprawidłowo “wpisany” dysk w konfiguracji (rzadko się zdarza bo te adresy uuid się nie zmieniają chyba że partycjonujesz dysk i usuniesz np. partycje).