Błąd przy aktualizacji


(D35CART35) #1

W systemie antergos wyskakuje błąd przy aktualizacji pakietów alsa-utils i alsa-plugins,
nie wiem w czym jest problem, czy mógł by ktoś coś podpowiedzieć.
Za pomoc dziękuje.


(pocolog) #2

Odpal aktualizację w konsoli i wklej tutaj co wypluwa.

pacman -Syu


(D35CART35) #3

Dobrze
chuck@quest ~]$ sudo pacman -Syu
[sudo] hasło użytkownika chuck:
:: Synchronizowanie baz danych z pakietami…
antergos jest aktualne
core jest aktualne
extra 1660,5 KiB 2,34M/s 00:01 [######################] 100%
community 4,1 MiB 2,58M/s 00:02 [######################] 100%
multilib jest aktualne
:: Rozpoczynanie pełnej aktualizacji systemu…
rozwiązywanie zależności…
szukanie sprzecznych pakietów…

Pakiety (2) alsa-plugins-1.1.5-1 alsa-utils-1.1.5-2

Do pobrania: 0,99 MiB
Do zainstalowania: 2,27 MiB
Zmiana po aktualizacji: 0,13 MiB

:: Kontynuować instalację? [T/n] t
:: Pobieranie pakietów…
alsa-plugins-1.1.5-… 61,1 KiB 1071K/s 00:00 [######################] 100%
alsa-utils-1.1.5-2-… 953,7 KiB 2,45M/s 00:00 [######################] 100%
(2/2) sprawdzanie kluczy w bazie [######################] 100%
(2/2) sprawdzanie spójności pakietów [######################] 100%
błąd: alsa-plugins: signature from “Anatol Pomozov anatol.pomozov@gmail.com” is unknown trust
:: Plik /var/cache/pacman/pkg/alsa-plugins-1.1.5-1-x86_64.pkg.tar.xz jest uszkodzony (Niepoprawny lub uszkodzony pakiet (podpis PGP)).
Czy chcesz go usunąć? [T/n] ^C
Interrupt signal received
Dzięki za zainteresowanie.


(pocolog) #4

Wpisz i sprawdź czy wystarczy

sudo pacman -S archlinux-keyring && sudo pacman -Syu


(D35CART35) #5

Dziękuje za podpowiedź, myślę że na razie jest ok :wink:


(pocolog) #6

Problem prawdopodobnie rozwiązałby się sam przy wydaniu kolejnej poprawki.


(D35CART35) #7

@pocolog Przepraszam chciałem się zapytać w czym był problem,
wiesz pacmana to ja się dopiero uczę, lepiej znam apt.:wink:


(pocolog) #8

Paczka miała nieprawidłowe podpisy pgp czy coś… Coś im się nie zsynchronizowało chyba :wink: Ja też na co dzień nie używam archa, więc dokładnie ci nie wytłumaczę.


(Xyzz) #9

Problem polegał na tym, że do mirrora trafiły paczki “alsa-utils” i “alsa-plugins” podpisane nowymi kluczami a nie trafił tam jeszcze tam pakiet “archlinux-keyring” zawierający nowe klucze. Chyba zmienił się opiekun tych pakietów.