Błąd w trakcje aktualizacji programów, uszkodzony pakiet ubuntu mate 18.04


(ccomp) #1

Dzień dobry
Próbuję uaktualnić swoje zainstalowane programy na ubuntu mate 18.04

ale wyskakuje błąd


apt-get upgrade

Czytanie list pakietów… Gotowe
Budowanie drzewa zależności
Odczyt informacji o stanie… Gotowe
Należy uruchomić “apt --fix-broken install”, aby je naprawić.
Następujące pakiety mają niespełnione zależności:
libglvnd-dev : Wymaga: libglvnd0 (= 1.0.0-2ubuntu2.1) ale 1.0.0-2ubuntu2.2 jest zainstalowany
Wymaga: libglvnd-core-dev (= 1.0.0-2ubuntu2.1) ale 1.0.0-2ubuntu2.2 jest zainstalowany
Wymaga: libegl1 (= 1.0.0-2ubuntu2.1) ale 1.0.0-2ubuntu2.2 jest zainstalowany
Wymaga: libgles2 (= 1.0.0-2ubuntu2.1) ale 1.0.0-2ubuntu2.2 jest zainstalowany
Wymaga: libgl1 (= 1.0.0-2ubuntu2.1) ale 1.0.0-2ubuntu2.2 jest zainstalowany
Wymaga: libglx0 (= 1.0.0-2ubuntu2.1) ale 1.0.0-2ubuntu2.2 jest zainstalowany
Wymaga: libopengl0 (= 1.0.0-2ubuntu2.1) ale 1.0.0-2ubuntu2.2 jest zainstalowany
E: Niespełnione zależności. Proszę spróbować wykonać “apt --fix-broken install” bez pakietów (lub podać rozwiązanie).
root@komp052018:/home/comp052018# apt --fix-broken install
Czytanie list pakietów… Gotowe
Budowanie drzewa zależności
Odczyt informacji o stanie… Gotowe
Naprawianie zależności… Gotowe
The following additional packages will be installed:
libgles1 libglvnd-dev
Zostaną zainstalowane następujące NOWE pakiety:
libgles1
Następujące pakiety zostaną zaktualizowane:
libglvnd-dev
1 aktualizowanych, 1 nowo instalowanych, 0 usuwanych i 388 nieaktualizowanych.
Konieczne pobranie 0 B/14,6 kB archiwów.
Po tej operacji zostanie dodatkowo użyte 66,6 kB miejsca na dysku.
Kontynuować? [T/n] t
(Odczytywanie bazy danych … 820040 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu …/libgles1_1.0.0-2ubuntu2.2_amd64.deb …
Rozpakowywanie pakietu libgles1:amd64 (1.0.0-2ubuntu2.2) …
dpkg: błąd przetwarzania archiwum /var/cache/apt/archives/libgles1_1.0.0-2ubuntu2.2_amd64.deb (–unpack):
próba nadpisania “/usr/lib/x86_64-linux-gnu/libGLESv1_CM.so.1”, który istnieje także w pakiecie nvidia-340 340.106-0ubuntu3
Przygotowywanie do rozpakowania pakietu …/libglvnd-dev_1.0.0-2ubuntu2.2_amd64.deb …
Rozpakowywanie pakietu libglvnd-dev:amd64 (1.0.0-2ubuntu2.2) nad (1.0.0-2ubuntu2.1) …
dpkg: błąd przetwarzania archiwum /var/cache/apt/archives/libglvnd-dev_1.0.0-2ubuntu2.2_amd64.deb (–unpack):
próba nadpisania “/usr/lib/x86_64-linux-gnu/libGLESv1_CM.so”, który istnieje także w pakiecie nvidia-340 340.106-0ubuntu3
Wystąpiły błędy podczas przetwarzania:
/var/cache/apt/archives/libgles1_1.0.0-2ubuntu2.2_amd64.deb
/var/cache/apt/archives/libglvnd-dev_1.0.0-2ubuntu2.2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@komp052018:/home/comp052018#

Próbowałem

apt-get install -f
apt --fix-broken install

i nic

Posiadam karte graficzną
gf 9500 GT

Proszę o pomoc
Dziękuje


(marcin82) #2

388 nieaktualizowanych.

sudo su -
apt-get update && apt-get dist-upgrade

(ccomp) #3

Dzień dobry
komenda
apt-get update && apt-get dist-upgrade

nic nie daje
nie da się nawet zrobić
apt-get install

wprowadzenie komendy
apt-get update && apt-get dist-upgrade

Stary:23 http://ppa.launchpad.net/yannubuntu/boot-repair/ubuntu bionic InRelease
Pobrano 83,2 kB w 7s (11,7 kB/s)
Czytanie list pakietów… Gotowe
Czytanie list pakietów… Gotowe
Budowanie drzewa zależności
Odczyt informacji o stanie… Gotowe
Należy uruchomić “apt --fix-broken install”, aby je naprawić.
Następujące pakiety mają niespełnione zależności:
libglvnd-dev : Wymaga: libglvnd0 (= 1.0.0-2ubuntu2.1) ale 1.0.0-2ubuntu2.2 jest zainstalowany
Wymaga: libglvnd-core-dev (= 1.0.0-2ubuntu2.1) ale 1.0.0-2ubuntu2.2 jest zainstalowany
Wymaga: libegl1 (= 1.0.0-2ubuntu2.1) ale 1.0.0-2ubuntu2.2 jest zainstalowany
Wymaga: libgles2 (= 1.0.0-2ubuntu2.1) ale 1.0.0-2ubuntu2.2 jest zainstalowany
Wymaga: libgl1 (= 1.0.0-2ubuntu2.1) ale 1.0.0-2ubuntu2.2 jest zainstalowany
Wymaga: libglx0 (= 1.0.0-2ubuntu2.1) ale 1.0.0-2ubuntu2.2 jest zainstalowany
Wymaga: libopengl0 (= 1.0.0-2ubuntu2.1) ale 1.0.0-2ubuntu2.2 jest zainstalowany
E: Niespełnione zależności. Proszę spróbować wykonać “apt --fix-broken install” bez pakietów (lub podać rozwiązanie).


(pocolog) #4

Czytałeś co podpowiada ci konsola?