Błędy na home.pl z najnowszą Devaną 1.6.6


(bartus2003) #1

Witam otóż pod adresem:

http://bartus2003.home.pl/travland

Zainstalowałem najnowszą devanę na serwerze home.pl.

I już na starcie pojawiają się takie błędy... W czym problem? Podobny problem miałem z innym skryptem na tym serwerze aly wystarczyło stworzyć folder /tmp i problem zniknął...

Oto plik antet.php:

<?php

session_start();

//if (isset($_SESSION["user"][0])) include "./language/".$_SESSION["user"][16];

//else if (isset($_SESSION["lang"])) include "./language/".$_SESSION["lang"];

include "./language/it.php";

$title=$lang['title']; $announcement=$lang['announc']; $m=49; $n=49;

$db_host="localhost"; $db_user="root"; $db_pass=""; $db_name="travland";

$top_ad="

| | "; $bottom_ad=" | |

"; $bottom_text=""; if (isset($_SESSION["user"][0])&&($_SESSION["user"][4]>1)) {$top_ad=""; $bottom_ad=""; $bottom_text="";} function logo($title) {echo "";} function menu_up() { global $lang; if (isset($_SESSION["user"][1], $_GET["town"])) { $_GET["town"]=clean($_GET["town"]); $loc=town_xy($_GET["town"]); $map_lnk="".$lang['map'].""; } else $map_lnk="".$lang['map'].""; echo "".$lang['home']." | "; if (!isset($_SESSION["user"][1])) echo "".$lang['login']." | ".$lang['register']." | "; else echo "".$lang['logout']." | "; echo $map_lnk." | ".$lang['forum']." | ".$lang['about']." | "; if (isset($_SESSION["user"][1])) echo "".$lang['profile']." | Top 10 | ".$lang['towns']." | "; } function menu_down() { global $lang; if (isset($_SESSION["user"][0], $_GET["town"])) { $_GET["town"]=clean($_GET["town"]); echo "".$lang['townCenter']." | ".$lang['statistics']." | "; } if (isset($_SESSION["user"][0])) $alert=msg_rep_alert($_SESSION["user"][0]); if ($alert[0][0]) $alert[0]="".$alert[0][0]." "; else $alert[0]=""; if ($alert[1][0]) $alert[1]="".$alert[1][0]." "; else $alert[1]=""; if (isset($_SESSION["user"][1])) echo "".$alert[0].$lang['reports']." | ".$alert[1].$lang['messages']." || ".$lang['chat']." | "; if (((isset($_SESSION["user"][4]))&&($_SESSION["user"][4]>2)&&($_SESSION["user"][4]<4))) echo "Panel Natar | "; if (((isset($_SESSION["user"][4]))&&($_SESSION["user"][4]>3)&&($_SESSION["user"][4]<5))) echo "Panel MH | "; if ((isset($_SESSION["user"][4]))&&($_SESSION["user"][4]>4)) echo "".$lang['adminPanel']." | "; } function about() {global $bottom_text; echo $bottom_text;} $system=array(); $system[0]=5;//chat message life, in minutes $system[1]=5;//chat refresh time, in seconds ?>[/code]


(Sitemaster) #2

katalog tmp jest? ma ustawione prawa do odczytu/zapisu?


(bartus2003) #3

Tak jest i ma prawa.


(ra-v) #4

Sprawdź jaką wartość ma "session.auto_start" funkcją ini_get(). Może sesja startuje automatycznie na każde żądanie i stąd te błędy. W każdym razie nastawiłbym się na maila do admina....


(bartus2003) #5

Ok, chyba poradziłem sobie dodając przed session start:

session_save_path("tmp");