Boot.ini kłopot z wyborem systemu


(Linkinparkkrotek) #1

Mam problem z tym :frowning: Chce aby było tak żeby automatycznie XP się ładował a nie Ubuntu. No więc szukałem znalazłem to zastosowałem sie do tego lecz po zapisaniu z listy wuboru znika mi M$ XP :frowning:

Więc prosze o pomoc, co w tym zmienić żeby działało :slight_smile:

Z góry dzieki.


(roobal) #2

Wczoraj bawiłem się dokładnie z tym samym. chciałem żeby automatycznie ładowało mi mandrivę 2007 free.

Ja po prostu zamieniłem pozycję na liście bootowania, tak że mandriva była pierwsz na liście.

Zrób to tak:

# menu.lst - See: grub(Cool, info grub, update-grub(Cool

# grub-install(Cool, grub-floppy(Cool,

# grub-md5-crypt, /usr/share/doc/grub

# and /usr/share/doc/grub-doc/.


## default num

# Set the default entry to the entry number NUM. Numbering starts from 0, and

# the entry number 0 is the default if the command is not used.

#

# You can specify 'saved' instead of a number. In this case, the default entry

# is the entry saved with the command 'savedefault'.

# WARNING: If you are using dmraid do not change this entry to 'saved' or your

# array will desync and will not let you boot your system.

default 0


## timeout sec

# Set a timeout, in SEC seconds, before automatically booting the default entry

# (normally the first entry defined).

timeout 10


## hiddenmenu

# Hides the menu by default (press ESC to see the menu)

#hiddenmenu


# Pretty colours

#color cyan/blue white/blue


## password ['--md5'] passwd

# If used in the first section of a menu file, disable all interactive editing

# control (menu entry editor and command-line) and entries protected by the

# command 'lock'

# e.g. password topsecret

# password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/

# password topsecret


#

# examples

#

# title Windows 95/98/NT/2000

# root (hd0,0)

# makeactive

# chainloader +1

#

# title Linux

# root (hd0,1)

# kernel /vmlinuz root=/dev/hda2 ro

#


#

# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST


### BEGIN AUTOMAGIC KERNELS LIST

## lines between the AUTOMAGIC KERNELS LIST markers will be modified

## by the debian update-grub script except for the default options below


## DO NOT UNCOMMENT THEM, Just edit them to your needs


## ## Start Default Options ##

## default kernel options

## default kernel options for automagic boot options

## If you want special options for specific kernels use kopt_x_y_z

## where x.y.z is kernel version. Minor versions can be omitted.

## e.g. kopt=root=/dev/hda1 ro

## kopt_2_6_8=root=/dev/hdc1 ro

## kopt_2_6_8_2_686=root=/dev/hdc2 ro

# kopt=root=UUID=7db16cae-1574-4d82-b80a-2f0eee97b7e3 ro

# kopt_2_6=root=/dev/hda7 ro


## default grub root device

## e.g. groot=(hd0,0)

# groot=(hd0,6)


## should update-grub create alternative automagic boot options

## e.g. alternative=true

## alternative=false

# alternative=true


## should update-grub lock alternative automagic boot options

## e.g. lockalternative=true

## lockalternative=false

# lockalternative=false


## additional options to use with the default boot option, but not with the

## alternatives

## e.g. defoptions=vga=791 resume=/dev/hda5

# defoptions=quiet splash


## should update-grub lock old automagic boot options

## e.g. lockold=false

## lockold=true

# lockold=false


## altoption boot targets option

## multiple altoptions lines are allowed

## e.g. altoptions=(extra menu suffix) extra boot options

## altoptions=(recovery) single

# altoptions=(recovery mode) single


## controls how many kernels should be put into the menu.lst

## only counts the first occurence of a kernel, not the

## alternative kernel options

## e.g. howmany=all

## howmany=7

# howmany=all


## should update-grub create memtest86 boot option

## e.g. memtest86=true

## memtest86=false

# memtest86=true


## should update-grub adjust the value of the default booted system

## can be true or false

# updatedefaultentry=false


## ## End Default Options ##


# This entry automatically added by the Debian installer for a non-linux OS

# on /dev/hda1

title Microsoft Windows XP Professional

root (hd0,0)

savedefault

makeactive

chainloader +1


title Ubuntu, kernel 2.6.17-10-generic

root (hd0,6)

kernel /boot/vmlinuz-2.6.17-10-generic root=/dev/hda7 ro quiet splash

initrd /boot/initrd.img-2.6.17-10-generic

quiet

savedefault

boot


title Ubuntu, kernel 2.6.17-10-generic (recovery mode)

root (hd0,6)

kernel /boot/vmlinuz-2.6.17-10-generic root=/dev/hda7 ro single

initrd /boot/initrd.img-2.6.17-10-generic

boot


title Ubuntu, memtest86+

root (hd0,6)

kernel /boot/memtest86+.bin

quiet

boot


### END DEBIAN AUTOMAGIC KERNELS LIST


# This is a divider, added to separate the menu items below from the Debian

# ones.

title Other operating systems:

root

Wklej mój wpis do pliku menu.lst zamiast tego, który Ty podałeś. Oczywiście musisz to zrobić jako root, np. przy wykorzystaniu midnight comandera:

sudo mcedit /boot/grub/menu.lst

Po wklejeniu mojego wpisu XP będzie na pierwszym miejscu na liście bootawani, czyli będzie się bootował jako pierwszy system :slight_smile:

Pozdrawiam!


(Kostrzewa83) #3

wystarczy zmienic wpis:

default 0

na odpowiedni, tzn.:

default 0

oznacza ze domyslnie startuje pierwsza pozycja z listy wyboru

default 1

domyslnie startuje druga pozycja z listy itd.


(roobal) #4

Robiłem tak, ale mi się gruby posypał i odmówił posłuszeństwa i musiałem bootować z lini komend :slight_smile:

Myślę, że łatwiej po prostu zmienić pozycję na liście bootowania, mniej zabawy :slight_smile:

Pozdrawiam!


(Linkinparkkrotek) #5

dzieki wam, za pomoc :slight_smile:

zastosowałem roobal twoją porade i pomogła :slight_smile:


(Kostrzewa83) #6

to musiales cos wiecej pozmieniac bo to nie mozliwe zeby grub poszedl do piachu tylko przez zmiane domyslnego systemu