Bootowanie Linuxa z USB na starym komputerze


(MrK_) #1

Dzień dobry, mam dość nietypowy problem z bootowaniem Linuxa z USB.

Na wstępie dodam że instalowałem na komputerze Windowsa 10 z USB i wszystko poszło bez problemów, niestety z instalacją Linuxa tak łatwo nie jest, ale nie chcę się tak szybko poddawać :slight_smile:

Posiadam stary dość już komputer (zdjęcie specyfikacji) na którym mam zainstalowanego Windowsa 10 (nie narzekam na jakieś wolne działanie), postanowiłem jednak spróbować przejść na Debiana z GNOME czy też Ubuntu, potrafię jako tako obsługiwać terminal i dystrybucje na bazie Debiana, pierwsza próba padła na Ubuntu.

Problem polega na tym że stworzyłem bootowalnego pendrive’a przy pomocy Rufusa. Próbowałem wiele kombinacji - różne systemy plików, różne schematy partycjonowania - chociaż w Windowsem poszło dużo łatwiej to Linux nie chce się bootować. Po podłączeniu pendrive’a wszystko teoretycznie działa ale komputer zawiesza się na POST Screenie, może nawet nie zawiesza, bo wciskając klawisze NUM na klawiaturze widać że ta reaguje po diodach LED sygnalizujących Num Lock.
Myślałem że może to być wina czy jakiś problem z Ubuntu - niestety wyniki Google dotyczą zazwyczaj problemów z laptopami, nie udało mi się znaleźć żadnego zbliżonego problemu do mojego ani jego rozwiązania, ale może źle szukałem.

Druga próba była z Debianem GNOME, ponownie próbowałem Rufusa, ale efekt jest identyczny.
Teraz spróbowałem użyć UNetBootin i wykonałem pełne formatowanie Pendrive’a w Windowsie (wcześniej stosowałem tylko “Szybkie formatowanie”), niestety nic to nie dało.

Gdzieś w odmętach internetu znalazłem propozycję by wyłączyć hibernację w Windowsie 10, nie wiem co to miałoby dać ale wyłączyłem komendą
powercfg -h off
Oczywiście również nie pomogło

Spróbowałem jeszcze zbootować sam instalator przez sieć aby sprawdzić że może po prostu daję za mało czasu komputerowi, pendrive sformatowany pełnym formatowaniem, ISO wypalone przy pomocy UNetBootin, ale niestety zostawiłem komputer na ponad półtorej godziny i bezskutku.

W BIOSie próbowałem:

  • Wyłączyć USB Legacy Mode - W ogóle nie zaczyna nawet bootować pendrive’a, uruchamia się Windows 10
  • Przestawiać kolejność bootowania zostawiając na pierwszym miejscu USB-* - Bootuje tylko przy USB-HDD, przy pozostałych USB-ZIP, USB-FDD i USB-CDROM włącza się Windows

Jeszcze mogę chyba dodać że testowałem i sprawdzałem na dużo nowszym i lepszym komputerze, tam wszystko działało bez problemów przy pierwszej próbie.

I chyba tyle - potrzebuję pomocy żeby móc spróbować Linuxa


(marcin82) #2

Podaj model płyty głównej, procesora, karty graficznej i ilość pamięci RAM.


(MrK_) #3

Zaktualizowałem pierwszy post o zdjęcie


(adrian218) #4

Pobierz win32diskimager


Tylko jak dasz przeglądaj to zmień rozszerzenie z img na wszystkie wybierz iso. Rufus jest jakis kaprysny a win32diskimager jest niezawodny w tych kwestiach.


(MrK_) #5

Spróbuję i dam znać chociaż zauważ proszę że próbowałem już dwoma po kilka razy, wydaje mi się że to nie wina programu :frowning:


(MrK_) #6

Tak jak myślałem, nic to nie dało. Debian GNOME nie startuje
@marcin82 @adrian218
Nie możecie coś poradzić? :frowning:


(pocolog) #7

Czytając odpowiedź tutaj:


Dochodzę do wniosku że ta płyta główna jest dosyć kapryśna jeśli chodzi o bootowanie z USB. Spróbuj podpiąć pendrive dopiero po włączeniu komputera, ale przed wykrywaniem systemów operacyjnych. Dysk do bootowania wybierz przez uruchomienie quick boot menu z klawisza [f12]. W ustawieniach bios sprawdź czy masz włączone Legacy USB, USB Controller, USB Storage… a ja w wolnej chwili poszukam innych rozwiązań :wink:


(MrK_) #8

Spróbowałem i nic to nie dało. Wydaje mi się, że płyta główna nie ma problemu z odnalezieniem pendrive’a (na POST jest nawet podawana jego nazwa), ale zrobiłem tak:

  1. Wszedłem do BIOSu i upewniłem się że wymienione opcje są włączone (USB Storage, Legacy USB, USB Controller itd.)
    https://i.imgur.com/ZnQxZlH.jpg

  2. Wyłączyłem z priorytetów bootowania USB, dalem na pierwszym miejscu dysk i na drugim napęd
    https://i.imgur.com/iMyMGqm.jpg

  3. Spróbowałem najpierw z wpiętym pendrive od początku , wybrałem USB-HDD, i efekt był taki jak ostatnio

  4. Zresetowałem próbowałem wpinać po logo producenta/przed logo. Generalnie kombinowałem i zazwyczaj załapywało mniej więcej

  5. Spróbowałem sprawdzić bez wpinania, wybrałem USB-HDD bez pendrive’a i włączył się należycie Windows 10 po krótkiej chwilii

  6. Spróbowałem w Rufusie wybrać opcję dodatkowej partycji dla starych biosów.
    Wygenerowałem log: https://pastebin.com/RD9bZG6n
    Nic to nie dało, nawet nie zaczyna bootować pendrive’a, włącza się normalnie Windows 10

  7. Spróbowałem jeszcze raz w Rufusie żeby wygenerować logi jak ktoś chce poczytać, ale chyba nie znalazłem żadnego stosu błędów ani nic co by mi się rzuciło w oczy :smiley:
    https://pastebin.com/DDaMbLFY

No i wykonałem profesjonalne zdjęcie mojego POST Screena, widać tam że pendrive jest odnajdowany


(pocolog) #9

Próbowałeś utworzyć pendrivie pod rufusem z opcją kopiowania plików metodą DD?


(MrK_) #10

@pocolog Tak, uruchamia się normalnie Windows 10
Sprawdzałem oczywiście też sumy MD5 plików, są poprawne


(pocolog) #11

Podczas startu systemu przyciskasz f12, pojawia się menu wyboru dysku do bootowania, wybierasz hdd+, rozwija się kolejne menu i wybierasz USB?


(MrK_) #12

Nie, wybieram USB-HDD, wygląda to tak:


(pocolog) #13

To wybierz hard disk + i z następnego menu USB, tak jak ci pisałem.


#14

Wyłączenie hibernacji wingrozy, a przede wszystkim opcji “fast start”, bo o nią głównie idzie, umożliwia systemowi rzeczywiste wyłączenie się i zostawienie filesystemów ze znacznikiem “zamknięte” lub “czyste”.
Inaczej żaden linuks nie ruszy, a gdyby nawet to będzie się pluł.
Czyli… idziesz sobie gdzieś do opcji systemu i tam wyłączasz w diabły następujące: fast start, hibernację oraz wszelkie “suspend to ram, czy suspend to disk”.
Po wyłączeniu pełen reboot koniecznie. A zaś potem możesz walnąć w cli tą komendę, którą już podałeś “powercfg -h off”, żeby wingrozie nie przyszło do głowy sobie czasami włączyć tego. Bo może miewać takie humorki.

Druga rzecz… to mobo ma nieco inne opcje w swym biosie niż zazwyczaj.
Używasz jednej z dwu "usb fdd, albo usb hdd. Któraś powinna ruszyć.
Ale trzeba odpowiednio przygotować penka. Zwłaszcza przy usb fdd, trzeba po prostu oszukać bios, że ma do czynienia z floppem.
Przy usb hdd jest nieco lepiej, bo wystarczy trzymać się kilku zasad…
formatowanie normalne, a nie szybkie penka jako fat (może być 32),
partycja oznaczona jako “lba” oraz "boot"
zachowanie limitu położenia początkowych sektorów partycji startowej poniżej 1204 cylindra.
I to ostatnie jest najważniejsze, bo na tym przeważnie się wywalają te mobasy.


(MrK_) #15

@pocolog Tam już w ogóle nie ma moje pendrive’a, ale za chwilę z tym powalczę gdy wykonam czynności polecone przez @MartinaNeumayer
@MartinaNeumayer Wyłączyłem fast start w rejestrze w panelu sterowania, hibernację w konsoli. Robię normalne formatowanie pendrive’a, bez żadnych ikonek, FAT32

partycja oznaczona jako “lba” oraz "boot"
zachowanie limitu położenia początkowych sektorów partycji startowej poniżej 1204 cylindra.

Tu niestety nie wiem, w rufusie takich ustawień nie mam, gdzie mogę to ustawić? Mini Tool Partion?


#16

To będzie gdzieś w tym programie windowsa do zarządzania dyskami. Przynajmniej tam być powinno
Kwestia rozłożenia partycji to po prostu tak ją ustawić by zaczynała się od początku. Nie wiem jak to powiedzieć inaczej?

Dobra… jak na obrazku… To tylko przykład więc na detal nie zwracaj uwagi.

Jest jakiś tam sobie penek i ma dwie partycje. Startowa (bootowalna) musi być jako pierwsza. Jeśli patrzysz w tym programie, to po prostu jak najbliżej lewej krawędzi okna. Tak jak ta zaznaczona.
O… w ten sposób powiem. Im bliżej lewej krawędzi tym lepiej.


(MrK_) #17


Niby chyba zrobiłem, pełne formatowanie, bez ikonek, FAT32, metoda nagrywania ISO
Ale nadal nie rozumiem @MartinaNeumayer jak sprawdzić oznaczenie partycji czy jest lba, boot, wyżej screen z Zarządzania Dyskami


(krystian3w) #18

W nawiasie obok zdrowy?


(MrK_) #19

No dobra, w takim razie. Co to miało dać? Jest jedna partycja, podstawowa, aktywna, bootowalna. Pełne formatowanie, FAT32, bez żadnych ikonek ani żadnych featursów, nic się nie zmieniło chyba że coś źle zrozumiałem :frowning:


(MrK_) #20

@pocolog Nie bardzo mogę tam wybrać USB, mam jedynie dysk oraz " Dodatkowe bootowalne dyski" (zaraz spróbuję wstawić screena), po wybraniu tych bootowalnych kart wyskakuje “Boot CD/DVD” ale nie wydaje mi się że bootuje coś z USB chociaż trochę poczekam, przy Windowsie 10 też trochę instalator się ładował