Brak dostępu do partycji windows


(stb.kornel) #1

Witam,
Od kilku dni nie mam dostępu do partycji windows, która jest na tym samym kompie. Wcześniej nie było problemów. Chyba zbiegło się to z aktualizacją win10. Dostępu nie ma także z innych edycji live, więc problem leży po stronie windows.
W windows szybki start nie jest wybrany, a system zamknięty całkowicie.
Jakieś pomysły?


(FadeMind) #2

(stb.kornel) #3

Sama partycja jest bez błędów, a windows odpala się normalnie. Nie można się dostać z poziomu linuksa i wywala:
Error mounting system-managed device /dev/sda3: Command-line `mount “/media/sda3”’ exited with non-zero exit status 14: Windows is hibernated, refused to mount.
Failed to mount ‘/dev/sda3’: Operacja niedozwolona
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the ‘ro’ mount option.


(FadeMind) #4

W Terminalu dajesz kolejno:

sudo fdisk -l

Identyfikujesz partycję z Windowsem. Na przykład /dev/sda3
Wykonujesz polecenie (jak nie masz zainstalowanego narzędzia ntfsfix, to poszukaj go w swojej dystrybucji i doinstaluj):

sudo ntfsfix -d /dev/sda3

Uruchamiasz menadżer plików i po prostu otwierasz partycję NTFS, która wcześniej była niedostępna.


(stb.kornel) #5

No niestety:
kornel@kornel-linuks ~ $ sudo ntfsfix -d /dev/sda3
Mounting volume… Windows is hibernated, refused to mount.
FAILED
Attempting to correct errors…
Processing $MFT and $MFTMirr…
Reading $MFT… OK
Reading $MFTMirr… OK
Comparing $MFTMirr to $MFT… OK
Processing of $MFT and $MFTMirr completed successfully.
Setting required flags on partition… OK
Going to empty the journal ($LogFile)… OK
Windows is hibernated, refused to mount.
Remount failed: Operation not permitted


(SlawekB44) #6

Wyłącz Fast Boot w Windows. Powoduje on szybszy start, lecz komputer jest hibernowany i np odłączenie napięcia od zasilacza sypnie błędami w win.


(stb.kornel) #7

Jak już pisałem w pierwszym wpisie szybki start w windows jest wyłączony. Ale dzięki, może jakies inne pomysły?


(Domker) #8

Oczywiście zawsze możesz zamontować partycję Windows w trybie tylko do odczytu:
udisksctl mount -b /dev/sda3 -o 'ro'

Aby zamontować w trybie r/w spróbuj usunąć błąd jedną z niżej podanych metod:

Sposób 1
W Windows uruchom cmd.exe jako administrator i wpisz “powercfg /h off”.
Zobacz, czy Linux zamontuje Ci partycję Windows normalnie.

Sposób 2
Zahibernuj Windows i go wybudź.
Użyj “Wyłącz” z przytrzymanym klawiszem Shift
“State” powinno się zmienić i partycja powinna być dostępna dla Linux.

Sposób 3
Jeżeli nadal błąd występuje to koniecznie upewnij się, że na 100% sesja Windows nie jest zahibernowana. (robisz na własne ryzyko)
Pod Linux dosyć ryzykowne polecenie, ale usuwa plik hibernacji Windows (hiberfil.sys) i montuje partycję.
sudo ntfs-3g -o remove_hiberfile /dev/sda3 /mnt && sudo umount /dev/sda3


(stb.kornel) #9

Dziękuję Domker. Twój pierwszy sposób zadziałał !
Partycja Windows znowu się montuje.


(GioWDS) #10

Daje Ci on jednak dostęp tylko do odczytu :wink:
Następnym razem wciskaj Uruchom ponownie lub Zamknij z wciśniętym Shiftem.