Brak dźwięku po DVI to HDMI oraz brak HDCP


(scripter1) #1

Mam podłączony komputer do tv (a dokładniej jest to monitor z tunerem tv) kablem DVI->HDMI (a dokładniej przejściówka DVI->HDMI + kabel HDMI 10m) i z obrazem nie mam problemów.

Dźwięk do tej pory przysyłałem do niego osobnym kablem audio (jack) i działało to dobrze ale ostatnio pojawił mi się problem z gniazdem pod które miałem go podpiętego powodujący że działa mi tylko lewy kanał (gniazdo na dodatkowym śledziu podpiętym, sprawdziłem połączenie że jest ok).

Jako ze doczytałem się w instrukcji od karty graficznej że ma ona złącze spdif postanowiłem połączyć ją z kartą dźwiękową i spróbować przesyłać dźwięk cyfrowo.

Przeszukałem sieć i znalazłem kilka poradników jak skonfigurować sterownik nVidii aby wysyłała dźwięk przez HDMI/DVI.

I tu pojawia się mój problem ponieważ mimo poprawnego podłączenia wyjścia spdif karty dźwiękowej z wejściem spdif karty graficznej nie mam w sterowniku nVidii opcji przesyłania dźwięku, w sterowniku karty dźwiękowej mam włączone wyjście cyfrowe spdif.

Czytałem że w panelu sterowania w opcjach Dźwięków i urządzeń audio powinienem mieć dodatkowe urządzenie audio ale niestety mam tam tylko jedno Realtek HD Audio, wszystkie sterowniki mam poinstalowane i nie mam żadnych nierozpoznanych w menedżerze urządzeń.

Czy ktoś z was zetknął się już z takim problemem i wie jak go rozwiązać?

Moja konfiguracja:

WindowsXP SP3

Karta dźwiękowa: zintegrowana w płycie głównej GA-M61PME-S2

Karta graficzna: GV-NX84S512HP

Monitor/Tv: Samsung P2770HD

-- Dodane 04.12.2011 (N) 12:41 --

Według specyfikacji mój monitor nie obsługuje dźwięku po HDMI (przy połączeniu przez DVI oraz HDMI trzeba dźwięk przesyłać analogowo dodatkowym kablem) ale w menu serwisowym jest opcja "DVI Sound" którą uaktywniłem więc w teorii powinien już odbierać dźwięk cyfrowo.

-- Dodane 04.12.2011 (N) 13:15 --

Mam jeszcze inny problem choć mniejszego kalibru.

Mianowicie sterownik nVidii pokazuje mi że mój monitor nie obsługuje HDCP a według specyfikacji oraz info w menu serwisowym obsługuje.

Nie wiem jakie to ma znaczenie ani czy ma to jakiś związek z powyższym problemem z dźwiękiem ale jeśli ktoś wie czamu tak jest to też bym chciał to naprawić.


(Rovou5hou) #2

W sterowniku Nvidia dodatkowych opcji bym raczej nie szukał. GF 8400GS nie ma własnego kodeka audio, jego złącze SPDIF to zwykła "przelotka" pass-through. Z tego samego powodu nie pojawi się też prawdopodobnie żadne nowe urządzenie w Menadżerze Urządzeń. Po podłaczeniu kabelka konfiguracja powinna się ograniczyć do wybrania domyślnego urządzenia wyjsciowego audio w systemowym Panelu Sterowania ("Realtek HD Digital Output" o ile mnie pamięć nie myli). Jeśli taka opcja nie jest dostępna to może nawalił auto-sensing kodeka HD płyty, ew. kabelek jest źle podpięty (zamienione kolejnością piny).

Wg Prad monitor zdecydowanie obsługuje HDCP http://www.prad.de/en/monitore/review/2 ... art10.html, karta też nie powinna mieć problemów. Pytanie czy kabel daje radę? 10 m to dużo w przypadku HDMI, warto sprawdzić sprzęt z dużo krótszym dla porównania. Zgłaszany przez sterownik problem z "nieobsługiwaniem HDCP" może być też pokłosiem powyższych problemów z cyfrowym dzwiękiem.


(scripter1) #3

Dzięki za odpowiedź.

No więc właśnie w panelu sterowania mam jedynie Realteak HD Audio (w menedżerze urządzeń widnieje jako Realtek High Definition Audio) i nie mam żadnych innych.

Kabel spdif wydaje mi się że podłączyłem dobrze ale pewności nie mam bo nigdzie nie znalazłem oznaczeń który pin w złączu karty graficznej jest pinem GND a który SPDIFI a kabel który mam na obu wtyczkach wpinanych w płytę ma nadrukowane "DATA-" :shock:

Dla pewności jeszcze podłączę na próbę odwrotnie (oznaczenia złącza spdif w płycie głównej w instrukcji od niej mam jasno opisane).

Z tego co czytałem HDMI dobrze działa do ok 12m więc kabel nie powinien być problemem.

Postaram się jeszcze od kogoś pożyczyć krótszy kabel HDMI i sprawdzić.

Nie jestem też pewien czy mój monitor faktycznie obsługuje dźwięk po HDMI (niby włączyłem to w menu serwisowym ale tam jest ta opcja oznaczona "DVI Sound", może to działa ale tylko z kablem DVI :? ) ale na mój rozum to w panelu sterowania i tak powinno ni się pojawić cyfrowe wyjście.

Chyba że się mylę bo z HDMI mam małe doświadczenie a z SPDIF nie mam doświadczenia wcale.


(Rovou5hou) #4

To bardzo dziwne, nie spotkałem się jeszcze z podobnym przypadkiem. Zarówno na PCB karty jak i płyty pierwszy pin powinien być oznaczony zwyczajową jedynką lub małą (na ogół białą) strzałką. Do ich połączenia wybierasz (dla ułatwienia) białą lub jaśniejszą żyłę kabelka.

To prawda, ale tylko dobry kabel HDMI. Słabsze z tego co wiem potrafią "wymiękać" już przy 5 m.

Cytat z podanego w moim wcześniejszym poście odnośniku:

"The P2770HD naturally accepts HDCP-encrypted material via its HDMI input. Since it can therefore play back Blu-ray discs, it can be used as a small home cinema".

Aby aktywować dzwięk przez HDMI w kartach Nvidia pracujacych pod Windows nie potrzeba doktoratu z inżynierii dzwięku czy 3 letniego doświadczenia w temacie. Jeśli nie działa wina leży pewnie w drobiazgach, które łatwo przeoczyć. Co do cyfrowego wyjścia w systemowych opcjach dzwięku, z tego co pamiętam pojawia się po prawidłowym podpięciu do włączonego TV lub monitora z głośnikami. Nie jestem na 100% pewien, dawno tego nie praktykowałem.


(scripter1) #5

No i tak jest ale co mi po tym że mam oznaczony pin 1 jak nie ma opisu który pin jest od czego :?:

Na płycie głównej mam złącze spdif 3 pinowe i w instrukcji od niej mam jasno opisane ich oznaczenie (pin1 - Power; pin2 - SPDIFO; pin3 - GND) ale na karcie graficznej mam złącze 2 pinowe i oznaczony jedynie strzałką pin1 a nie ma nigdzie opisu jego funkcji...

Kierując się logiką (i screenami z neta) założyłem że pin1 złącza na karcie graficznej pełni funkcję SPDIFI i połączyłem go z pinem2 płyty a pin2 karty z pinem3 płyty więc powinno działać a tu zonk...


(Rovou5hou) #6

Wg mnie podpinasz prawidłowo. Pierwszy pin złącza karty to na 99,9% "data". GND jest zawsze jako drugie. Sytuacja jest nietypowa, wczytałem się więc odrobinkę w temat. Ten monitor jest bardzo "wybredny" jeśli chodzi o transmisję audio po HDMI, nie z każdym sprzętem lubi współpracować. Jeśli sam kabel HDMI jest w porządku to właśnie jego "niedogadywanie się" z kodekiem płyty obstawiam jako najbardziej prawdopodobną przyczynę. Podpięcie komputerka do sprawdzonego wcześniej pod tym kątem TV rozwiałoby ewentualne wątpliwości.