Brak dźwięku w ubuntu 8.04

(system) #1

Witam.

Mój problem wygląda następująco. Po aktualizacji z ubuntu 7.10 do 8.04 straciłem cały dźwięk w systemie tj. nie ma dźwięku ani w plikach mp3, ani filmikach (obraz jest), ani dźwięków systemu. Moja karta dźwiekowa to HDA Intel, na chipsecie Realtek ALC 883. Sprawdziłem system/preferencje/dźwięk i tam nie ma nic wyciszone. Sprawdziłem też Alsamixer i tam też nic nie jest wyciszone.

Z góry dziękuję za pomoc.

(Łukasz14) #2

raspiel , a sterowniki zainstalowałeś do tej wersji Ubuntu? :stuck_out_tongue:

(kamil_w) #3

@Łukasz14

Hahaha!! Wymiatasz. Używąłeś kiedyś Linuxa? Skoro ma ALSĘ, to ma sterowniki dźwięku, bo ALSA to właśnie stery do dźwięku :wink:

A tak od siebie:

Możliwe, że po aktualizacji nie masz jako użytkownik praw do obsługi dźwięku (nie takie numery mi Ubuntu robiło). Sprawdź, czy jesteś jako użytkownik w grupie 'audio". Jak nie, to dodaj się do tej grupy.

(Łukasz14) #4

kamil_w , sorki, ale z Linux’em jestem trochę na opak :stuck_out_tongue:

Kiedyś miałem kilka dni, żeby spróbowac jakieś alternatywy niż M$, ale Linux mnie raczej nie pociąga :wink:

(kamil_w) #5

jakbyś nie wiedział jak się dodaje użytkownika do grupy, to powinno zadziałać:

  • uruchom konsolę i zaloguj się jako root (aaa, sorry, zapomniałem Ubuntu nie ma konta roota) LOL

  • no to uruchom konsolę i :

    su gpasswd -a UŻYTKOWNIK audio

gdzie UŻYTKOWNIK, to nazwa towjego użytkownika. Oczywiście będziesz musiał podać hasło admina. Wyloguj się i zaloguj ponownie.

(mati75) #6

Najpierw wyedytuj :

sudo gedit /etc/modprobe.d/alsa-base

na końcu dopisz :

options snd-hda-intel model=x

gdzie x wpisz któreś z tego:

3stack

3stack-dig

6stack-dig

3stack-660

3stack-660-digout

lenovo

dallas

hp
(system) #7

kamil_w dodałem użytkownika audio (polecie poszlo dopiero przez “sudo”). mati75 zrobiłem to co napisałeś, dodawałem “x” po kolei, za każdym razem wylogowywując się po zapisaniu pliku. Nic nie pomogło.

(mati75) #8

w miejsce x wpisz ACER i powinno działać. Tumasz opis dla swojej karty.

(wojownik) #9

system - preferencje - dzwęk - może to i naiwne ale sprawdz czy ustawione masz na alsa

(matiit) #10

To raczej nie wina modułów (bo na 7.10) działało. To wina pewnie pulseaudio.

Zrób jak pisze wojownik.

(system) #11

Dzięki wielkie. Coś pomogło, ale nie wiem co bo po zrobieniu tego wszystkiego co opisaliście dźwięku nadal nie było, pojawił się dopiero następnego dnia. Jeszcze raz dzięki.

(SxMaN) #12

Proponuje 8.04 zainstalowac gdy wyjdzie wersja 8.04.1(pojawi się w lipcu), wtedy bugi powinny być załatane przynajmniej w większości. :wink:

(mati75) #13

wersja 8.04.1 to nic innego jak wersja 8.04 z wszystkimi aktualizacjami, które się pobiera do wersja 8.04.

(SxMaN) #14

Tak, dlatego w tej chwili gołe ubuntu 8.04 jest jak beta. po instalacji 8.04.1 lub po prostu zaktualizowaniu, bez grzebania w systemie, powinna już większość błędów zniknąć w tym te z dźwiękiem. :slight_smile: