Brak funkcji "opcje folderów"


(Orlandooo74) #1

Witam

Niedawno zrobiłem format dysku i zainstalowałem świeżego Windowsa xp. Po wejściu do systemu podpiąłem aparat aby przeżucic zdjęcia na komputer po odpięciu aparatu z komputera znikła funkcja "Opcje folderów" (Narzędzia->Opcje folderów). Czy ktoś wie jaka jest tego przyczyna? i jak to naprawic ? Proszę o pomoc.


(hevet) #2


(niezDarek) #3

zrób tak:

start>Uruchom wpisz

regsvr32 /i browseui.dll

regsvr32 /i shell32.dll

jak nie pomoże to sprawdź czy są te wpisy w rejestrze

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

(Orlandooo74) #4

A wiec tak: na początku wpisałem te dwie komendy " regsvr32 /i browseui.dll i regsvr32 /i shell32.dll" ale niestety nic nie pomoglo.. a drugiej rady ("jak nie pomoże to sprawdź czy są te wpisy w rejestrze") nie próbowałem ponieważ nie wiem jak mam to sprawdzic, bo ja nie zabardzo orientuje się w tych rzeczach i byłbym wdzięczny jak ktoś mógłby wyjaśnic mi dokładnie jak sprawdzic ten wpis w rejestrze.


(niezDarek) #5

start>uruchom wpisujesz regedit i szukasz odpowiednich kluczy z lewej strony rozwijając klucze


(Orlandooo74) #6

Gdy wpisałem "regedit" wyskoczył mi komunikat "Edycja rejestru zostala wyłączona przez administratora sieci" co robic ??


(niezDarek) #7

masz dostęp do konta Administrator na systemie ??

-jak tak to rób owe czynności tymże koncie.

-jak nie to musisz się chyba po prostu z tym pogodzić bo masz zablokowany dostęp przez administratora systemu do rejestru i zapewne także do opcji folderów, możesz jedynie poprosić administratora aby ci owe funkcje odblokował.


(Orlandooo74) #8

tak mam dostep do konta Administratora na systemie, wiec co mam zrobic ??

-- Dodane 05.05.2009 (Wt) 13:51 --

ja tą komede regedit wpisywałem właśnie z konta administratora..


(niezDarek) #9

zaloguj się na konto administratora i wykonaj te czynności.


(Orlandooo74) #10

napisałem że wykonałem te czynności na koncie administratora i dalej ten sam komunikat..


(niezDarek) #11

dobra sorry nie zauważyłem jak dodałeś dodatkową wypowiedź, w takim razie odblokuj dostęp do niego, wklej do notatnika ten skrypt:

'Enable/Disable Registry Editing tools

'Š Doug Knox - rev 12/06/99


Option Explicit


'Declare variables

Dim WSHShell, n, MyBox, p, t, mustboot, errnum, vers

Dim enab, disab, jobfunc, itemtype


Set WSHShell = WScript.CreateObject("WScript.Shell")

p = "HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System\"

p = p & "DisableRegistryTools"

itemtype = "REG_DWORD"

mustboot = "Log off and back on, or restart your pc to" & vbCR & "effect the changes"

enab = "ENABLED"

disab = "DISABLED"

jobfunc = "Registry Editing Tools are now "


'This section tries to read the registry key value. If not present an 

'error is generated. Normal error return should be 0 if value is 

'present

t = "Confirmation"

Err.Clear

On Error Resume Next

n = WSHShell.RegRead (p)

On Error Goto 0

errnum = Err.Number


if errnum <> 0 then

'Create the registry key value for DisableRegistryTools with value 0

	WSHShell.RegWrite p, 0, itemtype

End If


'If the key is present, or was created, it is toggled

'Confirmations can be disabled by commenting out 

'the two MyBox lines below


If n = 0 Then

	n = 1

WSHShell.RegWrite p, n, itemtype

Mybox = MsgBox(jobfunc & disab & vbCR & mustboot, 4096, t)

ElseIf n = 1 then

	n = 0

WSHShell.RegWrite p, n, itemtype

Mybox = MsgBox(jobfunc & enab & vbCR & mustboot, 4096, t)

End If

zapisz jako skrytpt.vbs i odpal

zobacz czy dalej dostęp do rejestru jest blokowany


(Orlandooo74) #12

ok udało się :slight_smile: mam dostęp do regedit co dalej ?


(niezDarek) #13

ale zapisujesz jako skrypt.vbs najważniejszą częścią jest .vbs i musi być obowiązkowo.


(Orlandooo74) #14

tak tak wiem już to zrobiłem co teraz ? (sorry że tak wszystko opornie ale słabiutko się znam na takich rzeczach..)

-- Dodane 05.05.2009 (Wt) 14:18 --

sprawdziłem i to "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced" znajduje się tam!


(niezDarek) #15

wykonaj te zmiany w rejestrze co zalecił ci user hevet

czyli:


(Orlandooo74) #16

niestety wykonałem wszystko to co mi napisałeś ale nadal to samo..


(niezDarek) #17

nie mam już pomysłów, ale zobacz jeszcze to:

viewtopic.php?f=22&t=319160#p2102956


(Leon$) #18

skoro możesz wejść do rejestru to:

start >> uruchom >> regedit

zaznacz Mój komputer >> zakładka Edycja >> znajdź >> w okienku wpisz NoFolderOptions >> znajdź następny

jak znajdzie PPM na NoFolderOptions >> usuń

zakładka Edycja >> znajdź następny >> znajdzie usuń

tak długo aż przeszuka cały rejestr będzie komunikat

wtedy zamykasz edytor rejestru >> restart komputera

jeśli masz XP Prof to można zrobić jak podałem lub

Start >> Uruchom >> gpedit.msc

Konfiguracja użytkownika >> Szablony administracyjne >> Składniki systemu Windows >> Eksplorator Windows >> PPM po prawej na opcje “Usuwa element menu Opcje folderów z menu Narzędzia” >> Właściwości >> zaznacz nieskonfigurowano lub Wyłączone >> Zastosuj >> OK

:slight_smile: